System requirements for SeaMonkey are outdated

RESOLVED FIXED

Status

defect
RESOLVED FIXED
7 years ago
Last year

People

(Reporter: unghost, Assigned: InvisibleSmiley)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

http://www.seamonkey-project.org/doc/system-requirements contains outdated information. Mac OS X 10.5 is not supported anymore.
Also perhaps some changes from https://www.mozilla.org/en-US/thunderbird/17.0/system-requirements/ should be ported, like Mac OS X 10.8 support and new GTK/Glib minimal required versions. Dunno about Windows 8 support.
Depends on: 708103
Yes we need to remove Mac OS X 10.5 and should probably add Mac OS X 10.8.

I checked the FF specs in addition to the TB ones. I think there's some confusion regarding the minimum GTK version requirement on Linux. AFAIK, the GTK minimum version was raised and subsequently changed back during the development phase of Gecko 17. I set a dependency to bug 708103 which was the reason why I set the minimum GTK version to 2.11 back in January. The FF requirements page currently still lists GTK 2.10. At this point, I don't know what's right and what's wrong.

I'm OK with adding Win 8 - even though I cannot verify it myself, we've seen reports from people on the newsgroups who tried it successfully.

I'll attach a first draft in a minute, subject to change depending on the outcome of the discussion I started over at bug 708103.
Posted patch update requirements draft (obsolete) — Splinter Review
Seeking feedback for all platforms (Windows, Mac, Linux) since the patch affects all of them.

Please report whether you see any issues (contradictions, incompletenesses, mistakes) for the platforms you're familiar with, both in comparison to FF/TB and the source code. Please don't assume I know better than you guys, all input is welcome. :-)

Feel free to ask more people for feedback as you feel appropriate.
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #684142 - Flags: feedback?(stefanh)
Attachment #684142 - Flags: feedback?(philip.chee)
Attachment #684142 - Flags: feedback?(neil)
Attachment #684142 - Flags: feedback?(bugspam.Callek)
If you downgrade minimal GTK version to 2.10, shouldn't you change back list of supported distributions according to Bug 708103 comment 4 ?
(In reply to Alexander L. Slovesnik from comment #3)
> If you downgrade minimal GTK version to 2.10, shouldn't you change back list
> of supported distributions according to Bug 708103 comment 4 ?

Maybe, but I don't think that's strictly necessary. These are only pointers anyway, and we're not going to list all possible Linux setups that fit the bill. ;-)
Comment on attachment 684142 [details] [diff] [review]
update requirements draft

I don't know how accurate the system requirements for the VC2010 redistributable package are on Microsoft's download site are, since they may have just quoted the latest service packs, but it says:
Windows XP Service Pack 3
Windows Server 2003 Service Pack 2
Windows Server 2003 R2
Windows Vista Service Pack 2
Windows Server 2008 Service Pack 2
Windows 7
Windows Server 2008 R2

Note that I wouldn't bother adding Windows Server 2003, and I don't know that we have 100% Windows 8 compatibility yet (I don't think we can set as default for instance).
Attachment #684142 - Flags: feedback?(neil) → feedback?(bugzilla)
Comment on attachment 684142 [details] [diff] [review]
update requirements draft

> Note that I wouldn't bother adding Windows Server 2003, and I don't know that
Agreed.

> we have 100% Windows 8 compatibility yet (I don't think we can set as default
> for instance)
AFAIK Firefox workaround is to launch the Win8 defaults settings window/app.
Attachment #684142 - Flags: feedback?(philip.chee) → feedback+
(In reply to Philip Chee from comment #6)
> > we have 100% Windows 8 compatibility yet (I don't think we can set as default
> > for instance)
> AFAIK Firefox workaround is to launch the Win8 defaults settings window/app.

Anyway, I feel that if a single, non-critical part of the application is broken on a platform or environment that shouldn't keep us from declaring general compatibility with that plat/env [1]. I think our users are more interested in whether the application as a whole runs in general. There seems to be some doubt regarding Win 8 among our users, and if that doubt is wrongful, let's dispel it.

[1] For example, revealing the profile folder from about:support is broken on Linux in certain non-Gnome environments.
Comment on attachment 684142 [details] [diff] [review]
update requirements draft

We could say "Mac OS X 10.6 or higher" if you think that sounds better.
Attachment #684142 - Flags: feedback?(stefanh) → feedback+
KaiRo pointed me at bug 814456. Following that, the FF and TB pages now consistently show GTK 2.18 among the minimum Linux requirements. Comparing that to the 2.10 requirement in configure.in I guess the FF/TB dependency is determined at compile time. Given that their build infra is at least different from ours AFAIK, I need to know which GTK version we have installed on the Linux machine that was used to build SM 2.14.

Note: If in fact GTK 2.18 is also our new minimum requirement I'll probably remove the list of supported distributions since I lack the time to gather the data needed for an updated one.
No longer depends on: 708103
Flags: needinfo?(ewong)
Jens: As I followed the GTK thing a bit I think it's save to say that we should point out GTK 2.18 as minimum requirement. See Bug 794285 Comment 4 on this, building against old GTK libraries works, but no efforts have been made to actually support running against old GTK libraries (maybe it does work by accident, but I have not read anything about that).
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #9)
> KaiRo pointed me at bug 814456. Following that, the FF and TB pages now
> consistently show GTK 2.18 among the minimum Linux requirements. Comparing
> that to the 2.10 requirement in configure.in I guess the FF/TB dependency is
> determined at compile time. Given that their build infra is at least
> different from ours AFAIK, I need to know which GTK version we have
> installed on the Linux machine that was used to build SM 2.14.

I just checked and found it's 2.10.4.
Flags: needinfo?(ewong)
Attachment #684142 - Flags: feedback?(bugzilla)
Attachment #684142 - Flags: feedback?(bugspam.Callek)
Posted patch final patchSplinter Review
Checking in src/doc/system-requirements.en.html;
/www/seamonkeyproject-org/src/doc/system-requirements.en.html,v  <--  system-requirements.en.html
new revision: 1.5; previous revision: 1.4
done
Attachment #684142 - Attachment is obsolete: true
Thanks everyone for the input. The website will be updated automatically in a few minutes.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Websites → SeaMonkey
You need to log in before you can comment on or make changes to this bug.