fix media partition on android and b2g panda sdcards

RESOLVED FIXED

Status

Infrastructure & Operations
RelOps
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dividehex, Assigned: dividehex)

Tracking

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
The Media partition, which has previously gone unused, is now being used for the panda android image.  In order for this to properly mount, it needs to be formatted in FAT instead of EXT4.  We need to change the Mozpool second stage script for both Android and B2G to properly format partition 6 (MEDIA).  In the android image, this is mounted by the vold auto mounting daemon as /mnt/sdcard.

Keep in mind, this does not mean we should be installing files to that partition during mozpool re-imaging (second stage).  We want to keep this process inline with typical android build output artifacts (eg. system data boot).  The /data partition is where bins and other files should be installed to be included with the android OS during installation.
we use this to store our testing data.  I am not really interested in anything else that might be stored on the /mnt/sdcard partition.

Updated

5 years ago
Duplicate of this bug: 818076
(Assignee)

Comment 3

5 years ago
The squashfs will need mkdosfs installed in order for the second stage to format it correctly.
(Assignee)

Comment 4

5 years ago
Created attachment 688549 [details] [diff] [review]
patch-1
Attachment #688549 - Flags: review?(dustin)
Comment on attachment 688549 [details] [diff] [review]
patch-1

Do we need a similar change for b2g?
Attachment #688549 - Flags: review?(dustin) → review+
(Assignee)

Comment 6

5 years ago
(In reply to Dustin J. Mitchell [:dustin] from comment #5)
> Comment on attachment 688549 [details] [diff] [review]
> patch-1
> 
> Do we need a similar change for b2g?

I don't believe so since b2g purposely mounts /mnt/sdcard to /data/media with fuse
(Assignee)

Comment 7

5 years ago
Created attachment 688857 [details] [diff] [review]
changes both b2g and android second stage script

I think it would be a good idea to change this for both b2g and android.  Even though b2g doesn't use this partition, this will keep it consistent.
Attachment #688549 - Attachment is obsolete: true
Attachment #688857 - Flags: review?(dustin)
Attachment #688857 - Flags: review?(dustin) → review+
(Assignee)

Comment 8

5 years ago
landed.  We will also need to update all the active pxe configs to the new squashfs image.
And once that's done, a puppet change to update config.ini:

[mozpool]
# this should correspond to a row in the pxe_configs table
b2g_pxe_config = panda-b2g.1
(Assignee)

Comment 10

5 years ago
Created attachment 689036 [details] [diff] [review]
puppetagain patch - update mozpool config.ini with new b2g pxe config

A new pxe config has been added as panda-b2g.2 which points to the new squashfs.
Attachment #689036 - Flags: review?(dustin)
Attachment #689036 - Flags: review?(dustin) → review+
(Assignee)

Comment 11

5 years ago
Comment on attachment 689036 [details] [diff] [review]
puppetagain patch - update mozpool config.ini with new b2g pxe config

landed
Attachment #689036 - Flags: checked-in+
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.