Last Comment Bug 819763 - Firefox doesn't display flash if inside transform-style:preserve-3d
: Firefox doesn't display flash if inside transform-style:preserve-3d
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 10 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 821751 842291 863673 903688 908073 915463 1185373 1249063 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-09 06:34 PST by Rodik Hanukaev
Modified: 2016-02-17 11:19 PST (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Rodik Hanukaev 2012-12-09 06:34:35 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Embedding a flash player inside a div element which has transform-style:preserve-3d applied to it.

jsfiddle testcase: http://jsfiddle.net/ek59Y/1/
in the testcase, there are two embedded flash players. one shows up, one is hidden because it has transform-style:preserve-3d applied to it's parent.

This is a part of a coverflow-style system which requires this transform style in order to z-index elements properly according to their 3d orientation


Actual results:

The flash did not render.
left clicking on it's position will not open any kind of context menu, which leads me to believe some kind of ghost element still exists there.
Upon removing the transform-style, or changing it to flat, the flash will render.


Expected results:

The flash player should have rendered properly, and z-indexed according to it's 3d orientation, and not it's DOM order.
Comment 1 Alice0775 White 2012-12-09 07:36:25 PST
Using Window Mode (wmode)helps.
Comment 2 Alexandra Lucinet, QA Mentor [:adalucinet] 2012-12-14 01:40:01 PST
Using the provided jsfiddle testcase, I was able to reproduce the issue on the latest Nightly.

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:20.0) Gecko/20121213 Firefox/20.0
Build ID: 20121213030751
Comment 3 Alice0775 White 2012-12-14 09:05:21 PST
*** Bug 821751 has been marked as a duplicate of this bug. ***
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-12-16 21:12:50 PST
We don't support windowed plugins in transforms. Use wmode=transparent or wmode=opaque.
Comment 5 Matthias Versen [:Matti] 2013-01-21 17:36:11 PST
*** Bug 832929 has been marked as a duplicate of this bug. ***
Comment 6 Benjamin Smedberg [:bsmedberg] 2013-01-22 13:35:11 PST
At this point, we are not going to fix this bug. You can get this to work by specifying wmode="opaque" (or "transparent").
Comment 7 felix.hageloh 2013-01-23 04:44:32 PST
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #6)
> At this point, we are not going to fix this bug. You can get this to work by
> specifying wmode="opaque" (or "transparent").

this bug was marked as duplicate [#832929] but it is not fixed by specifying wmode="opaque" (or "transparent")
Comment 8 Marek Raida 2013-02-18 07:47:30 PST
*** Bug 842291 has been marked as a duplicate of this bug. ***
Comment 9 Alice0775 White 2013-04-19 13:59:03 PDT
*** Bug 863673 has been marked as a duplicate of this bug. ***
Comment 10 andrewc 2013-04-26 07:40:21 PDT
I can confirm that this bug is still active. Adding wmode="transparent" or wmode="opaque" does not resolve it.

http://jsfiddle.net/MqCmX/4/
Comment 11 Benjamin Smedberg [:bsmedberg] 2013-04-26 08:22:44 PDT
WFM on Windows. Are you on mac, and if so isn't this a duplicate of mac-specific bug 832929?
Comment 12 andrewc 2013-04-26 08:30:15 PDT
My apologizes. You are correct. Works fine on Windows, despite the active bug in mac.
Comment 13 Mats Palmgren (:mats) 2013-08-10 08:12:24 PDT
*** Bug 903688 has been marked as a duplicate of this bug. ***
Comment 14 Mats Palmgren (:mats) 2013-08-23 09:27:19 PDT
*** Bug 908073 has been marked as a duplicate of this bug. ***
Comment 15 Alice0775 White 2013-09-11 17:01:20 PDT
*** Bug 915463 has been marked as a duplicate of this bug. ***
Comment 16 P297 2013-09-16 06:42:42 PDT
Just as a reminder; You can call it 832929 or 819763 specifying wmode="opaque" (or "transparent") doesn't change that:

Windows (XP to 8), FF 23.0.1: There is a black box
Mac OS (10.8), FF 23.0.1: Play Button (and other chrome) recognizes the hovering but no click

View: http://jsfiddle.net/aZMnP/
Comment 17 Georg Fritzsche [:gfritzsche] 2013-09-17 05:17:11 PDT
With the OS X issue being known, can you please (In reply to P297 from comment #16)
> Windows (XP to 8), FF 23.0.1: There is a black box
[...]
> View: http://jsfiddle.net/aZMnP/

Using wmode=opaque or wmode=transparent instead of wmode=Opaque (note the upper case) makes it work fine for me.
Comment 18 Marco Bonardo [::mak] 2015-07-20 00:27:56 PDT
*** Bug 1185373 has been marked as a duplicate of this bug. ***
Comment 19 Abe - QA 2015-12-07 13:19:02 PST
*** Bug 1185374 has been marked as a duplicate of this bug. ***
Comment 20 arni2033 2016-02-17 11:19:58 PST
*** Bug 1249063 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.