All users were logged out of Bugzilla on October 13th, 2018

clicking on link in three-pane crashes in docshell [@ nsDocShell::SetFocus]

VERIFIED FIXED in mozilla0.9.2

Status

()

VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: waterson, Assigned: bryner)

Tracking

({crash, regression})

Trunk
mozilla0.9.2
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
I'm crashing when clicking on a link in a message in the mailnews three-pane 
window. The problem appears to by with bryner's recent fix for bug 31809 (but 
it might also be the interaction of that change with valeski's recent change to 
nsDocShell).

Anyway, I'll attach a stack trace, but the basic problem is that presShell-
>GetRootFrame() is returning a null frame in nsDocShell::GetMainWidget().
(Reporter)

Updated

18 years ago
Severity: normal → critical
Keywords: crash, mozilla0.9.1, regression
(Reporter)

Comment 1

18 years ago
Created attachment 35549 [details]
stack trace at the crash.

Comment 2

18 years ago
hmmm I have a clean pull from 8pm tonight and I can't reproduce it. I wonder if
something was checked in later tonight which made this go away? Or is your tree
a recent pull too? 

Comment 3

18 years ago
I feel stupid. Of course I ran into this crash right after submitting my
comments. Please ignore, I see this. This will be a smoketest blocker tomorrow
morning so putting on the radar now. 
Severity: critical → blocker
Keywords: smoketest

Comment 4

18 years ago
*** Bug 82128 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Possible dupe of bug 53378?

Comment 6

18 years ago
*** Bug 82131 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
Setting OS=All one of the duplicates is on Linux.
OS: Windows 2000 → All

Comment 8

18 years ago
I didn't need to click on any link with my Mac build.  All I did was delete a 
message and I crashed when the next message was loading.  I had read several 
messages and deleted some prior to the crash.  I use IMAP and move-to-trash.

I have the same stack as the attachment.
Hardware: PC → All
(Reporter)

Comment 9

18 years ago
Created attachment 35608 [details] [diff] [review]
wallpaper
(Reporter)

Comment 10

18 years ago
I wallpapered over the crash for now, since bryner is not around. Clearing bug
from blocker status, but leaving open for bryner to verify that the fix is right.
Severity: blocker → critical
Keywords: smoketest

Comment 11

18 years ago
*** Bug 82147 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Target Milestone: --- → mozilla0.9.1

Comment 12

18 years ago
*** Bug 82155 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
restoring blocker status. We need this visible until workaround/fix is verified
in respin.
Severity: critical → blocker

Updated

18 years ago
Blocks: 50881

Comment 14

18 years ago
*** Bug 82291 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
moving to 0.9.2/normal severity since it doesn't crash with Waterson's
wall-papering fix, as tested in today's NS builds on Win98.  Bryner, please
review fix and verify if it can be permanent.
Severity: blocker → normal
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 16

18 years ago
Adding [@ nsDocShell::SetFocus] to summary for talkback tracking
Summary: clicking on link in three-pane crashes in docshell → clicking on link in three-pane crashes in docshell [@ nsDocShell::SetFocus]
(Assignee)

Comment 17

18 years ago
This wasn't quite the right fix, but danm came up with the right one in a
different bug, and it's checked in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
verified
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsDocShell::SetFocus]
You need to log in before you can comment on or make changes to this bug.