Last Comment Bug 820759 - Java Version 7 Update 10 is identified as old version and disabled on plugincheck on Firefox 17.0.1
: Java Version 7 Update 10 is identified as old version and disabled on pluginc...
Status: VERIFIED FIXED
:
Product: Websites
Classification: Other
Component: plugins.mozilla.org (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Carsten Book [:Tomcat]
Mentors:
Depends on:
Blocks: 821279
  Show dependency treegraph
 
Reported: 2012-12-12 03:40 PST by richardkinast
Modified: 2013-04-18 12:27 PDT (History)
9 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot (33.01 KB, image/png)
2012-12-12 03:56 PST, Carsten Book [:Tomcat]
no flags Details
screen shot of plugin check results (305.61 KB, image/jpeg)
2012-12-12 04:57 PST, richardkinast
no flags Details
screen shot of plugins page (303.65 KB, image/jpeg)
2012-12-12 05:00 PST, richardkinast
no flags Details
HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft with Java 7u9 (7.53 KB, text/plain)
2012-12-29 15:39 PST, Christian Riechers
no flags Details
HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins for Java 7u9 (14.74 KB, text/plain)
2012-12-29 15:40 PST, Christian Riechers
no flags Details

Description richardkinast 2012-12-12 03:40:04 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

1. opened  about:addons
2. clicked plugins tab
3. clicked "Check to see if your plugins are up to date"


Actual results:

1. https://www.mozilla.org/en-US/plugincheck/ opened in a new tab
2. plugincheck says "For your safety, Firefox has disabled your outdated version of Java. Please upgrade to the latest version."
3. Java has disappeared from the list of plugins and addons


Expected results:

plugincheck should have found Java Version 7 Update 10 (build 1.7.0_10-b18) as the current updated version of java.
Java update was run from the Windows 7 Control Panel Java applet.
Comment 1 Carsten Book [:Tomcat] 2012-12-12 03:56:40 PST
Created attachment 691273 [details]
screenshot

hm it works for, see screenshot. Maybe you need to activate java in the firefox plugin section see http://java.com/en/download/help/enable_browser.xml

then it should work
Comment 2 richardkinast 2012-12-12 04:57:31 PST
Created attachment 691291 [details]
screen shot of plugin check results

This is the plugin check page after uninstalling then reinstalling both java and firefox. I saved firefox persinal data during uninstall.
Comment 3 richardkinast 2012-12-12 05:00:07 PST
Created attachment 691293 [details]
screen shot of plugins page

This is my plugins page after uninstall and reinstall. Java is nowhere. How do I activate the plugin if it is not in the list?
Comment 4 Carsten Book [:Tomcat] 2012-12-12 05:03:06 PST
(In reply to richardkinast from comment #3)
> Created attachment 691293 [details]
> screen shot of plugins page
> 
> This is my plugins page after uninstall and reinstall. Java is nowhere. How
> do I activate the plugin if it is not in the list?

see http://support.mozilla.org/en-US/kb/update-and-unblock-java#w_enabling-java
Comment 5 Christian Riechers 2012-12-16 03:20:56 PST
I can confirm this bug. FF 17.0.1 flags Java 7 U10 as outdated.
"For your safety, Firefox has disabled your outdated version of Java. Please upgrade to the latest version."
With FF on Windows (both XP and 7) the Java plugin doesn't even show up in the list of installed plugins for me.
With FF on Linux the same "Firefox has disabled ..." message is shown on the plugin check page. However, the Java plugin is visible in the list of plugins and can be enabled. Once enabled, FF shows it as up to date.
Java 7 U9 did work just fine on both, Windows and Linux.
Comment 6 Alice Wyman 2012-12-16 10:28:10 PST
For the record, the Plugin Check message,  "For your safety, Firefox has disabled your outdated version of Java. Please upgrade to the latest version." can occur  when an up-to-date Java is manually disabled or when Java isn't even installed.

See Bug 753219 and its duplicate, Bug 786600
Comment 7 Christian Riechers 2012-12-20 11:17:04 PST
(In reply to Alice Wyman from comment #6)
> For the record, the Plugin Check message,  "For your safety, Firefox has
> disabled your outdated version of Java. Please upgrade to the latest
> version." can occur  when an up-to-date Java is manually disabled or when
> Java isn't even installed.

I do understand that, and I can confirm that behavior. However, the real problem is that with Windows Java 7U10 doesn't even show up in the Add-on Manager plugin list, even though it has been installed successfully. So there is no way to enable it inside FF.
The Java Plug-in is enabled in the Java control panel.
Comment 8 Alice Wyman 2012-12-20 13:35:26 PST
In case it helps, a win7 x64 user over at mozillaZine discovered that his problem was caused by a missing registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MozillaPlugins\@java.com/JavaPlugin 

He posted a fix here: 
http://forums.mozillazine.org/viewtopic.php?p=12548939#p12548939
Comment 9 Roger 2012-12-21 10:47:35 PST
We are also seeing comments made to java.com saying that users are having 7u10 blocked by the plugin checker. 

The site analytics also show that a higher number of Firefox users visiting the test and verification pages.
Comment 10 Christian Riechers 2012-12-23 07:33:25 PST
(In reply to Alice Wyman from comment #8)
> In case it helps, a win7 x64 user over at mozillaZine discovered that his
> problem was caused by a missing registry key:
> HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MozillaPlugins\@java.com/JavaPlugin 

Thanks. I've modified the registry key fix so that it fits for Win7 32 bit, and Java 7U10 plugin is back in FF. So it isn't a FF problem after all.
Comment 11 Thomas Ng 2012-12-24 14:07:29 PST
We are trying to reproduce the case where our JRE 7u10 installer failed to create the correct MozillaPlugins registry key - but so far we had no luck to reproduce yet.   If you know the exact steps to reproduce the registry problem - please let us know.  Thanks!
Comment 12 Thomas Ng 2012-12-24 14:50:48 PST
I can reproduce now!  At least with this setup:

7u5 + FX 2.1.1 installed first.

Install 7u10 ->  this will cause plugin registration problem.   Looks like we have a bug in deploy registration code to handle this case.   Plugin from 2.1.1 is still being registered as fault.   I need to debug more to find out the problem.

In my case, uninstall of FX 2.1.1 will correct the problem and bring back 7u10 as default plugin.

Also, 7u5 upgrade to 7u10 works okay for me.  (no FX 2.1.1 standalone install)   7u10 plugin gets registered correctly.

Would be great if Mozilla can confirm this is what they are seeing as well.  Thanks!
Comment 13 Bernd 2012-12-25 07:02:54 PST
"uninstall of FX 2.1.1 will correct" indeed does the trick without any registry hacking
Comment 14 drghughes 2012-12-25 11:08:54 PST
Uninstalling JavaFX 2.1.1 fixed the problem for me too.
Comment 15 Thomas Ng 2012-12-25 13:23:23 PST
Good to know the workaround worked - you should be able to continue to load JavaFX content with 7u10 alone, since 7u10 have JavaFX co-bundled already.  You should not need the standalone JavaFX 2.1.1 anymore with 7u10.

Sorry for the inconvinence caused by the bug.
Comment 16 Christian Riechers 2012-12-29 03:45:31 PST
(In reply to Thomas Ng from comment #15)
> Good to know the workaround worked - you should be able to continue to load
> JavaFX content with 7u10 alone, since 7u10 have JavaFX co-bundled already. 
> You should not need the standalone JavaFX 2.1.1 anymore with 7u10.

I did uninstall JavaFX right after installing 7u9. When updating to 7u10 I uninstalled 7u9 first and then installed 7u10. The problem is 100% reproducible for me on Win 7 and Win XP. I do not have a JavaFX I can uninstall, and hence the workaround isn't applicable.

As mentioned in comment 10, manually adding the registry key fixed the problem.
Comment 17 Thomas Ng 2012-12-29 10:05:23 PST
Christian:  Thanks for the information.  Would you mind to share a few more information please so we can investigate your case further ?

1.  when you install 7u10 - is there any other JRE installed on the machine ?
2.  can you share the registry contents before you install 7u10 for the following keys please ?

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft
HKEY_LOCAL_MACHINE\SOFTWARE\Oracle
HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins  (If there is anything Java here only)
Comment 18 Christian Riechers 2012-12-29 15:39:36 PST
Created attachment 696551 [details]
HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft with Java 7u9
Comment 19 Christian Riechers 2012-12-29 15:40:57 PST
Created attachment 696552 [details]
HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins for Java 7u9
Comment 20 Christian Riechers 2012-12-29 15:44:34 PST
(In reply to Thomas Ng from comment #17)
> 1.  when you install 7u10 - is there any other JRE installed on the machine ?
No, I did uninstall 7u9 prior to installing 7u10.

> 2.  can you share the registry contents before you install 7u10 for the
> following keys please ?
> 
> HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft
> HKEY_LOCAL_MACHINE\SOFTWARE\Oracle
> HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins  (If there is anything Java here
> only)

See comments 18 and 19 above. There is no HKEY_LOCAL_MACHINE\SOFTWARE\Oracle key.
Comment 21 charles.fuller 2012-12-29 19:49:49 PST
Some further information in case this helps someone figure out the cause of the problems. NB: Please read to the end of this list, or you will miss a key point.

1. Environment: Windows XP Service Pack 3 (32bit), Firefox 16.0.2.
1. I check Secunia's website daily, so I saw that there was a new version of Java available. This was about the 12th. December.
2. I used the Firefox "Plugin Checker" page to see which plugins needed updating - Java and Flash were identified.
2. I used Windows XP's Java Applet in Control Panel (with Firefox closed) to perform the usual online update - this was about a day after the update was published.
3. The Java update allegedly went through successfully, as did the Flash upgrade.
4. I used the Firefox "Plugin Checker" page again and no trace of the Java plugins anywhere (I have the About:Plugins extension installed to tell me where it finds the file). The Java website reports that there's a major problem with the Java installation.
5. I downloaded the complete Java version 1.7u9 file from the Java website (note that the 1.7u10 version was not then available anywhere that I could find within the Java or Oracle sites).
6. I uninstalled both JavaFx and Java using the Windows Add/Remove Programs.
7. I installed Java 1.7u9 completely from the downloaded "offline" installation file.
8. The Java website reported that Java was installed correctly. I did not dare to go anywhere near the Firefox "Plugin Checker" page since I knew that it would disable the Java installation.
9. On the 13th. December I saw that the complete "offline installation" Java version 1.7u10 file was available on the Java website so I downloaded this and installed it (without uninstalling 1.7u9).
10. I then tried the Firefox "Plugin Checker" page and no problems were reported, and Java was not disabled.
11. I've just looked and I can't see any trace of JavaFx on the system.
12. I suspect that the online update launched from the Java applet in Control Panel (which appeared several days before the full "offline" package) may have contained processing errors or omitted some steps. Unfortunately I've wiped the log file which might confirm this.
Comment 22 Thomas Ng 2012-12-31 11:08:07 PST
Christian:  Thanks for the information.   Are those reg files showing the state of the registry after you uninstalled 7u9, and before you install 7u10 ?

Or was it while 7u9 is still installed ?

thanks.
Comment 23 charles.fuller 2012-12-31 11:41:26 PST
In case this helps, I can give simple instructions on how to view or recover the relevant Windows registry information from a Windows 2000 or XP 32bit (and possibly Vista or 7 - I'm not sure if the software runs on these versions) computer. This technique assumes that there's a Windows recovery dataset old enough somewhere on the computer (it's not necessary to restore the old version) - this dataset is simply read after making a permissions change.

Unfortunately I applied lots of Windows updates on the 23rd. December, so the relevant Windows system saves have been dropped from my computer.
Comment 24 Christian Riechers 2013-01-01 14:11:18 PST
(In reply to Thomas Ng from comment #22)
> Are those reg files showing the
> state of the registry after you uninstalled 7u9, and before you install 7u10?
> 
> Or was it while 7u9 is still installed ?

It's showing the state of the registry while 7u9 is still installed.
Comment 25 Thomas Ng 2013-01-02 17:37:36 PST
Thanks!  these are all useful comments.  I believe we have enough information to have a fix for the bug.  we will let you know when fix is available for testing in a developer preview release on java.net.

Christian:  As a workaround for now - after you have uninstalled ALL JREs and JavaFX runtime in the system, if you check these registry branch:

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment
HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Web Start
HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Plug-in

They should be empty.  If not, you can manually remove them.

And then try install 7u10 JRE again - it should get you back to working state.
Comment 26 Alice Wyman 2013-01-11 15:52:41 PST
Related Oracle bug: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8005410
Comment 27 Carsten Book [:Tomcat] 2013-04-18 06:23:11 PDT
should be fixed now
Comment 28 raymond [:retornam] (needinfo? me) 2013-04-18 12:27:09 PDT
verified fixed http://www.mozilla.org/plugincheck

Note You need to log in before you can comment on or make changes to this bug.