SVG graphic clipped with mask applied

VERIFIED FIXED in Firefox 19

Status

()

Core
SVG
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: birtles, Unassigned)

Tracking

({regression})

Trunk
mozilla20
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17 affected, firefox18 affected, firefox19 verified, firefox20 verified)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
For the SVG graphic in the URL there are four horizontal bars to which a mask is applied. Parts of this masked area appear clipped. The size of the area appears to vary depending on the window size such that the larger the window, the less of the masked region that is visible.

So far this has been reproduced on Windows 7 with Aurora both with and without Azure, and on Linux with Nightly.

(Note that similar bugs: bug 779035, bug 797231, bug 779029 etc. all appear to be Windows-specific whereas this is cross-platform.)

Appears to renders correctly in Firefox 16 but not 17.
(Reporter)

Comment 1

5 years ago
Created attachment 691663 [details]
Test file

Here is the file from the URL for posterity.
(Reporter)

Comment 2

5 years ago
Created attachment 691664 [details]
Clipped (incorrect) result - Firefox 19
(Reporter)

Comment 3

5 years ago
Created attachment 691666 [details]
Correct result - Chrome 24
status-firefox18: --- → affected

Comment 4

5 years ago
svg.display-lists.painting.enabled = false helps

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/688734575830
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120802041638
Bad:
http://hg.mozilla.org/mozilla-central/rev/074fb996dfd7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120802062038
Pushlog
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=688734575830&tochange=074fb996dfd7


Regression window(m-c)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a799b5bff84c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120801155239
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b077c43a4306
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120801163038
Pushlog
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a799b5bff84c&tochange=b077c43a4306

Suspected: Bug 776054
Blocks: 776054
Keywords: regressionwindow-wanted
(Reporter)

Comment 5

5 years ago
Thanks Alice for the regression tracking!

Looks like this might be a dupe of bug 818841 (which may be partly a dupe of bug 797507).
Fixed by bug 806432.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 806432
Resolution: --- → FIXED

Updated

5 years ago
status-firefox19: affected → fixed
status-firefox20: affected → fixed
Target Milestone: --- → mozilla20
Verified fixed FF 19b4 Win 7, Ubuntu 12.04 and Mac OS X 10.7.5
status-firefox19: fixed → verified
Verified fixed FF 20RC Win 7, Ubuntu 12.04 and Mac OS X 10.7.5
Status: RESOLVED → VERIFIED
status-firefox20: fixed → verified
You need to log in before you can comment on or make changes to this bug.