Closed Bug 823559 Opened 7 years ago Closed 7 years ago

Make Java plugins OOP again

Categories

(Core :: Plug-ins, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla21
Tracking Status
firefox20 --- disabled
firefox21 --- fixed

People

(Reporter: gfritzsche, Assigned: gfritzsche)

References

Details

Attachments

(2 files)

OOP was disabled for Java on all platforms in bug 563891 for issues with access to window.java.

window.java has since been removed in bug 748343, so we should be able to make Java OOP again, i.e. undo this:
https://bug563891.bugzilla.mozilla.org/attachment.cgi?id=507339
Attachment #694424 - Flags: review?(joshmoz)
Attachment #694424 - Flags: review?(joshmoz) → review+
Hrm, apparently we can't go with this without further investigation :(

On http://www.java.com/en/download/testjava.jsp i hit:

> WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004003: file /Users/georg/moz/mozilla-central/intl/uconv/src/nsCharsetConverterManager.cpp, line 301
> WARNING: Not running on the plugin's main thread!: file /Users/georg/moz/mozilla-central/dom/plugins/ipc/PluginModuleChild.cpp, line 1076
> ###!!! ASSERTION: Should be on the plugin's main thread!: 'IsPluginThread()', file ../../../dist/include/mozilla/plugins/PluginMessageUtils.h, line 214
> ###!!! ABORT: not on worker thread!: 'mWorkerLoop == MessageLoop::current()', file ../../dist/include/mozilla/ipc/AsyncChannel.h, line 210
> mozilla::ipc::AsyncChannel::AssertWorkerThread() const+0x00000057 [/Users/georg/moz/mozilla-central/objdir/dist/NightlyDebug.app/Contents/MacOS/XUL +0x02131547]
> mozilla::ipc::RPCChannel::Call(IPC::Message*, IPC::Message*)+0x0000004E [/Users/georg/moz/mozilla-central/objdir/dist/NightlyDebug.app/Contents/MacOS/XUL +0x0214247E]
> mozilla::plugins::PPluginInstanceChild::CallNPN_ConvertPoint(double const&, bool const&, double const&, bool const&, NPCoordinateSpace const&, NPCoordinateSpace const&, double*, double*, bool*)+0x00000243 [/Users/georg/moz/mozilla-central/objdir/dist/NightlyDebug.app/Contents/MacOS/XUL +0x022D0C73]
> mozilla::plugins::child::_convertpoint(_NPP*, double, double, NPCoordinateSpace, double*, double*, NPCoordinateSpace)+0x000000DA [/Users/georg/moz/mozilla-central/objdir/dist/NightlyDebug.app/Contents/MacOS/XUL +0x0210EFDA]
> MozNPN_ConvertPoint+0x00000014 [/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/MacOS/JavaAppletPlugin +0x0000326F]
> MacNPAPIJavaPlugin::updateWindowLocation()+0x00000030 [/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/MacOS/JavaAppletPlugin +0x0000C95E]
> ###!!! ABORT: not on worker thread!: 'mWorkerLoop == MessageLoop::current()', file ../../dist/include/mozilla/ipc/AsyncChannel.h, line 210
We added that just for Java because java sucks. This is on some other java thread? If so we should just make convertpoint fail on the incorrect thread.
Attachment #694509 - Attachment is patch: true
Attachment #694509 - Flags: review?(benjamin) → review+
Depends on: 824069
https://hg.mozilla.org/mozilla-central/rev/fc2cce7ad2d0
https://hg.mozilla.org/mozilla-central/rev/40822fe6962b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Should I be worried that this was fixed before bug 718233 / bug 559432?
Good question, does that still reproduce? I'll check into it when i'm back.
Blocks: 705570
Blocks: 728933
Depends on: 839750
Backed out on Aurora for further investigation:
 https://hg.mozilla.org/releases/mozilla-aurora/rev/d9452857a6d2
So this backout made bug 705570 return in all of its perma-orange glory.
Backed out (or re-landed depending on your perspective).
https://hg.mozilla.org/releases/mozilla-aurora/rev/028f5d36f9cc
Blocks: 828889
No longer blocks: 828889
Per bug 824069, comment 290 and following, this will be backed out once 20 hits beta due to the permaleaks possibly hiding other issues.
Depends on: 841914
Depends on: 857096
Target Milestone: mozilla20 → mozilla21
Depends on: 872969
You need to log in before you can comment on or make changes to this bug.