Last Comment Bug 825665 - Possible FF Cache Problem on Win8 (64bit) resulting in incomplete web pages
: Possible FF Cache Problem on Win8 (64bit) resulting in incomplete web pages
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Networking: Cache (show other bugs)
: 17 Branch
: x86_64 Windows 8
: -- major with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
https://support.mozilla.org/en-US/que...
: 817321 821940 825575 832346 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-31 12:49 PST by tcm.home
Modified: 2016-02-18 07:01 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
?


Attachments

Description tcm.home 2012-12-31 12:49:43 PST
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Most if not all Samsung Laptops (mine here are two samples bought in germany) with Windows 8 64 Bit preinstalled have a problem using the newest, stable version of FireFox 32 Bit.


Actual results:

It is not very deterministic, but it happens about 30 through 50 Percent of the usage time, that pages are not completly loaded. Most the time the CSS is missing and the page is completly unformatted. Sometimes Javascript is missing (like in google mail) and off and on flash content is not displayed. Pressing "F5" doesn't bring the page back. Pressing "CTRL-F5" usually does the trick.

There is a thread on mozilla support regarding this issues:

https://support.mozilla.org/en-US/questions/941815

Since I am a software developer I tried narrow the problem down though firebug and wireshark. One occurrence I had on a webpage of National Geographics where a video was supposed to be displayed. The Flash content was simply not there, just a place holder, but no flash itself.

Tracing the problem further I found out through firebug, that the SWF was not realoded from the server, since the server said that the document was not modified. Checking the Firefox cache, I discovered, that the SWF is in the cache as an entry, however the physical file behind it is missing (including the last subdirectory of the path).

The SWF wasn't reloaded even pressing CTRL-F5. From the way the page loaded I figure, that the SWF is loaded through javascript, where the "Refresh Cache" effect from "CTRL-F5" doesn't apply anymore.

Clearing the complete Cache (Options->Advanced->Clear Cached Web Content) remedies the Problem for a while, however it seems to always return.

Uninstalling programs, disabling default plugins and so on (for ex. no firewall) didn't remedy the problem.


Expected results:

The pages should load completely and correctly.

I am still trying to debug the Problem but I have limited knowledge of the firefox system. It is always possible that some 3rd Party Program is the cause of this. Windows itself is on the newest Patch Level. Most Samsung Add On Programs are deactivated except the most basic device drivers.

I am open to suggestions how to tackle this.
Comment 1 Matthias Versen [:Matti] 2012-12-31 17:05:50 PST
We have more reports about this issue, i will dupe them to this bug because it contains the best description.

Reporter: Are you willing to help us with creating a Cache logfile ?
You would have to use a Aurora build that has logging of the cache enabled and creating the log. This logfile can get very big depending on how long it will take to reproduce the issue after clearing the disk cache.

bug 808532/bug 771832 is related
Comment 2 Matthias Versen [:Matti] 2012-12-31 17:06:33 PST
*** Bug 825575 has been marked as a duplicate of this bug. ***
Comment 3 Matthias Versen [:Matti] 2012-12-31 17:09:16 PST
*** Bug 821940 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Versen [:Matti] 2012-12-31 17:11:45 PST
*** Bug 817321 has been marked as a duplicate of this bug. ***
Comment 5 Matthias Versen [:Matti] 2012-12-31 17:17:18 PST
I request to block for Firefox 18. I know that it's to late for blocking and I'm not sure if this is already fixed in FF18 but this looks like a really big issue to me.

Reporter or someone from the dupes: Could be please run http://www.mozilla.org/de/firefox/beta/ and test it ?
Please clear the disk cache once to be sure that your cache is in a good state.
Comment 6 Leos Literak 2013-01-01 03:15:58 PST
I tested beta version for an hour and it seems to work.
Comment 7 Leos Literak 2013-01-01 05:47:47 PST
ooops, it did it again, when I started to work at home.
Comment 8 tcm.home 2013-01-01 16:06:02 PST
Happy new Year and thank you for the positive response.

Sorry about writing back so late. Due to new years. I actually have to work tomorrow again, but I'll do some intensive testing on the laptop tomorrow evening with the Aurora build and will report back.

Disabling the AntiVirus didn't do the trick either.

In the mean time some people reported on the support thread that cleaning the cache completely with an external tool got rid of the problem entirely.

From the surf behavior of my wife revisiting the same pages over and over again, my guess is that either the initial safe of cache data fails or when the cache starts to purge old data it purges too much (like a whole sub branch like the "last" subdirectory in the path, which also contains data that is not to be purged). This however is just an educated guess and might of course be wrong.

I hope the Aurora Build Data is going to enlighten the problem further.

I have a few questions about this though:

* Can you supply a direct link to the build I am supposed to use, please?
* Will log in data (password etc.) be part of the log data (some of the errors actually happen on gmail or google+, so these are one of the best test sites for this)?

Thank you for your replies.
Comment 9 dickvl 2013-01-01 17:26:19 PST
Either one of these should give you the latest beta (Firefox 18).
http://www.mozilla.org/en-US/firefox/all-beta.html
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest-beta/

The latest Aurora build (Firefox 19) can be found here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora/

See also:
http://www.mozilla.org/en-US/firefox/channel/

You can also delete the cache folder manually.
You can find the location of the cache on the about:cache page.
Comment 10 tcm.home 2013-01-02 04:15:54 PST
I was just able to check one more case of a page loading incomplete in my work break with the stable release (I won't get to test any other until tonight).

In this case pressing CTRL-F5 brought the page back fully.

Before I checked like last time if the missing file would be found in about:cache but not physicallly. Trying to access the the html code of the page to determin the missing .css file, I already got an error for firefox loading the html code. Curiously the error must've occured DURING the page load, because the html part was clearly visible. Tracing back the cache entry I found that it was saved in cache directory .../2/12. Browsing to this directory I found that *all* subdirectories containing cached data were missing. There were only the 4 cache index files in the directory.

Upon pressing CTRL-F5 the cache subdirectories reappeared.

If this happens every time, It would explain why the effect is so drastic off an on. At the time I checked for the SWF there were other cache directories present, but maybe the cache just filled up again to a degree and it also had the previous purge happening as I could observe now.

The people at the support forum wanted me to emphasize the fact, that after uninstalling the Samsung support center software, the problems with Firefox seem to be permanently gone for some users. I don't know if this is relevant to this bug though. Involvement of 3rd Party Software is possible, but who says this problem is limited to only one single program? I will pursue this possibility if testing with debug software won't yield any usuable results.
Comment 11 tcm.home 2013-01-02 04:18:36 PST
Oh and before I forget it, Google Chrome seems to have the same kind of issues as firefox.
Comment 12 tcm.home 2013-01-02 08:47:27 PST
How do I enable logging of caching and obtain the logs? I tried to look for a reference but didn't find any so far. Any hint would help.
Comment 13 tcm.home 2013-01-02 22:47:32 PST
> Reporter: Are you willing to help us with creating a Cache logfile ?
> You would have to use a Aurora build that has logging of the cache enabled
> and creating the log. This logfile can get very big depending on how long it
> will take to reproduce the issue after clearing the disk cache.

I have downloaded an Aurora build, however I don't know how to activate the logging capability there. Is that build already enabled for creating cache logs or would a custom build be required? Sadly I don't have any system setup to compile firefox right now, so that is out of the question so far.

I am willing to test. The Aurora build also showed the same errors.
Comment 14 Leos Literak 2013-01-04 11:12:54 PST
we want to help to identify the problem
Comment 15 Leos Literak 2013-01-14 21:40:39 PST
it is annoying that you have two volunteers wishing to help and there is no response from developers :-(
Comment 16 tcm.home 2013-01-15 23:44:24 PST
I was able to build Aurora from source and checked various options. I believe though after looking at the source that the aurora nightly build should be sufficient for log generation.

I was able to turn the logging on with the downloaded build and able to reproduce the problem. Sadly I was doing something more sensitive on e-bay, so I am reluctant to share this log file without looking at it first myself.

In the mean time the Thread on the board seems to confirm, that the workaround by uninstalling one part of the Samsung Software seems to do the trick getting rid of the error.

So this might be a software combination problem after all.

To turn on logs, you need to create a batch file (.bat) which fill with (see http://www.mozilla.org/projects/nspr/reference/html/prlog.html for reference) :

set NSPR_LOG_MODULES=cache:4
set NSPR_LOG_FILE=mylogfile.txt
<absolute-path-to-firefox>\firefox.exe

Replace the Path and maybe add a Path to the NSPR_LOG_FILE setting and then run the batch file. Erase cache and surf until the occurs. Best is to remember the URL it happened with. Close Aurora and you have the log.

One strange phenomenon that I had was, that after closing Aurora the log file had NULL Bytes in the first X kb of the file, which prevented me of viewing the log in a normal text editor at first. After cutting the NULL Bytes away in a hex editor, all was good.
Comment 17 Matthias Versen [:Matti] 2013-01-16 00:36:07 PST
>In the mean time the Thread on the board seems to confirm, that the workaround by 
>uninstalling one part of the Samsung Software seems to do the trick getting rid of 
>the error.

Which part ?

Sorry that I somehow missed your comments but note that I'm not a developer.
Comment 18 tcm.home 2013-01-16 01:06:42 PST
I was referring to this Thread: https://support.mozilla.org/en-US/questions/941815

Current workaround is:

1) Removed Samsung SWUpdater and Support Center
2) Used CCleaner to fully clear all internet cache's
3) Rebooted
4) Optionally reinstall SW Updater

Seems to work for at least 3 people now.
Comment 19 Matthias Versen [:Matti] 2013-01-18 16:42:13 PST
*** Bug 832346 has been marked as a duplicate of this bug. ***
Comment 20 Honza Bambas (:mayhemer) 2013-02-04 16:40:37 PST
Bug 808532 has been present in 18,19, now fixed in all affected versions. 
Bug 771832 has been present in 4.0 up to 19, now fixed in versions 17 to 19.

I think that while you were using a browser version affected with one of these bugs, a cache entry w/o the data file has been created.

Condition to get rid of affect of those two bugs is to clean the cache.

We had to land bug 812483 just for those affected versions to avoid the load error w/o forcing a silent or user initiated cache cleanup to fix the problem...

To strength the theory, was the profile ever running a beta/aurora/nightly build of Firefox?

(In reply to Leos Literak from comment #7)
> ooops, it did it again, when I started to work at home.

With what version exactly (about:buildconfig)?

Note You need to log in before you can comment on or make changes to this bug.