Closed Bug 826347 Opened 7 years ago Closed Last year

msn.com doesn't recognize Firefox OS on smartphones.

Categories

(Web Compatibility :: Mobile, defect, P5)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: lmandel, Assigned: karlcow)

References

()

Details

(Whiteboard: [uaoverride] [country-all] [sitewait] [serversniff])

msn.com serves a desktop site to B2G. Bug 819210 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
OS: Gonk (Firefox OS) → All
Summary: msn.com doesn't recognize B2G UA as mobile → msn.com doesn't recognize Fennec and B2G UAs as mobile
→ http GET http://www.msn.com/  User-Agent:'Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0' | grep -i mobile

[nothing]

→ http GET http://www.msn.com/ User-Agent:'Mozilla/5.0 (Linux; Android 4.0.4; Galaxy Nexus Build/IMM76B) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.133 Mobile Safari/5
35.19' | grep -i mobile

<h2>Object moved to <a href="http://mobile.msn.com/">here</a>.</h2>


or if you prefer (keeping only the relevant data)

→ http GET http://www.msn.com/  User-Agent:'Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0' 

HTTP/1.1 302 Found
Location: http://ca.msn.com/?rd=1&ucc=CA&dcc=CA&opt=0



→ http GET "http://www.msn.com/" User-Agent:'Mozilla/5.0 (Linux; Android 4.0.4; Galaxy Nexus Build/IMM76B) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.133 Mobile Safari/535.19' 

HTTP/1.1 302 Found
Location: http://mobile.msn.com/

Tried to send an email to Chris Woods (Microsoft) but the address doesn't work anymore I guess he is not working there anymore. I have seen plenty of other microsofties emails in the bugzilla. Now the job is to find the right person. :)
tried to contact another person of Microsoft.
Assignee: nobody → kdubost
Whiteboard: [uaoverride] → [uaoverride] [country-all] [sitewait] [serversniff]
In the process. Contact established.

> Hi Karl,
> 
> I have forwarded your inquiry to our mobile dev team.  I will get back to you shortly.
> 
> Thank you,
> ******
Just status update, I'm in contact with two persons at Microsoft for this bug.
The latest email exchange we had was on August 26, 2013. Waiting an answer from them.
Duplicate of this bug: 759118
sent a reminder.
Status: NEW → ASSIGNED
ZTE Open (Firefox OS) still receiving the desktop site. Hmm.
# Firefox for Android is solved

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: ca.msn.com
User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 302 Found
Content-Length: 150
Date: Thu, 31 Oct 2013 18:39:23 GMT
Location: http://home.mobile.en.ca.msn.com/
P3P: CP="BUS CUR CONo FIN IVDo ONL OUR PHY SAMo TELo"
S: CH1SCH060101328
Server: Microsoft-IIS/8.0
X-Powered-By: ASP.NET


# Firefox OS.
Still not working

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: ca.msn.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Cache-Control: no-cache, no-store
Content-Encoding: gzip
Content-Length: 41260
Content-Type: text/html; charset=utf-8
Date: Thu, 31 Oct 2013 18:40:30 GMT
P3P: CP="BUS CUR CONo FIN IVDo ONL OUR PHY SAMo TELo"
Pragma: no-cache
S: CH1SCH060061546
Server: Microsoft-IIS/8.0
Set-Cookie: MC1=V=3&GUID=37a94b644d5241619c5c9058871b79a7; domain=.msn.com; expires=Sat, 31-Oct-2015 18:40:31 GMT; path=/
Set-Cookie: MC1=V=3&GUID=37a94b644d5241619c5c9058871b79a7; domain=.msn.com; expires=Sat, 31-Oct-2015 18:40:31 GMT; path=/
Set-Cookie: mh=MSFT; domain=.msn.com; expires=Sat, 31-Oct-2015 18:40:31 GMT; path=/
Set-Cookie: CULTURE=EN-CA; domain=.msn.com; expires=Thu, 07-Nov-2013 19:40:31 GMT; path=/
Vary: Accept-Encoding
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
errorCodeCount: [0:0]
Sent a ping to know if we can get the Firefox OS too.
From the forums a user notice that going to http://www.msn.com in Firefox for Android now redirects directly to Bing.
Yep, confirmed. Meanwhile Chrome gets sent to http://t.msn.com.
Currently in Canada with Firefox ANDROID

Accessing http://www.msn.com/ redirects to a mobile friendly content
at http://home.mobile.en.ca.msn.com/device/default.aspx

If I go at the bottom to click on Worldwide, I get a list of countries.
1. Select Thailand, get an error page for Desktop
2. Select India, get another error page. 404
3. Select USA English or Spanish, back to the Canadian Web site
4. Select Brazil, getting the mobile site http://home.mobile.br.msn.com/device/default.aspx
5. Select France, getting the mobile site http://home.mobile.fr.msn.com/device/default.aspx
6. Most of them seem to be working

On Firefox OS, still not working. Receiving Desktop site.
On December 23, a person from Microsoft told me that the Engineering was planning to fix that by July 2014.
Duplicate of this bug: 958683
I closed 958683 as a dupe of this, which was reported specifically about US people getting redirected to bing.com. Feel free to reopen if it makes more sense to have diff. issues... this bug is maybe getting a little crowded. :)
We are not yet in July 2014, so this is not solved. Cf Comment #13
But tested from Japan.
Entering http://msn.com/ we get redirected on a ZTE Open device Firefox 1.2
to http://jp.msn.com/?rd=1&ucc=JP&dcc=JP&opt=0
which is the desktop content too.

Also the site http://onmobile.msn.com/ seems to describe sites on Mobile for different microsoft Web properties.

They have a section called "Mobile Web"
http://onmobile.msn.com/en/Platforms/MobileWeb

If I ask details about MSN
http://onmobile.msn.com/en/Products/MobileWeb/MSN

> Just type MSN.com in your mobile browser on your 
> Windows Phone 8, iPhone (iOS 5+) or Android (2.3+) 
> smartphone. The new MSN was built from the ground 
> up to bring you a clean, simple and fast way to 
> stay in the know. Built for touch, you can navigate 
> the new MSN with just your thumb. Swipe through our 
> top channels and when you’re done reading an article, 
> swipe to view the next article. We’ve reimagined 
> MSN for your smartphone.

That seems a very restricted view of the Mobile Web. :)

Setting IEMobile 10 User agent. The version sent for MSN is 
http://t.jp.msn.com/?rd=1&ucc=JP&dcc=JP&opt=0

It has a lot of grid stuff in the CSS and so looks obviously broken on Firefox OS. For example.

> body div.head{-ms-grid-column:2}
> .banner body div.head{-ms-grid-row:2}
> body.banner{-ms-grid-rows:auto auto auto auto auto}
> body.banner #banners{-ms-grid-column:2}

Setting the user agent to be Safari on iOS 4 (old), the version sent is still, but different content that IEMobile 10. It looks like a version for low end mobile. It doesn't contain any Webkit or Microsoft profile and works well in Firefox OS.
http://t.jp.msn.com/?rd=1&ucc=JP&dcc=JP&opt=0


Setting the user agent to be Android 4.4 - Chrome 30
"Mozilla/5.0 (Linux; Android 4.4; Nexus 5 Build/BuildID) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/30.0.0.0 Mobile Safari/537.36"
It displays ok. There are a few webkitism and surprisingly some -ms- properties without the equivalent of non prefixed. It's not always consistent.

Example: 

> #fbcount iframe,#twcount iframe{
>  border:0;
>  height:2rem;
>  overflow:hidden;
>  -webkit-transform:none;
>  -webkit-transform-origin:0 0
> }

A bit of flexbox too with old wiki syntax.

> display:-webkit-box;

It's quite easy to fix. The site has been made for a fixed screen size, which is unfortunate. because they were close to have something which could be easily adjusted to a wide variety of smartphones with One stylesheet to rule them all.
http://t.jp.msn.com/?rd=1&ucc=JP&dcc=JP&opt=0
Duplicate of this bug: 980543
Target Milestone: --- → Jul
Tested again today and not solved on both Firefox OS and Firefox Android.
When emulating a Chrome 30 Mobile on Android 4.4 UA, we receive a perfectly working mobile site.

We just need to receive the same version.

Contacting someone different at Microsoft.
Summary: msn.com doesn't recognize Fennec and B2G UAs as mobile → msn.com doesn't recognize Firefox Android and Firefox OS on smartphones.
Duplicate of this bug: 1092624
With the modifications of the User Agent to include Firefox Android version Number we receive now the mobile site.

Firefox OS is still receiving the Desktop version. We could add UA override to send Firefox Android version number.
Blocks: 1180543
OS: All → Gonk (Firefox OS)
Priority: -- → P5
Summary: msn.com doesn't recognize Firefox Android and Firefox OS on smartphones. → msn.com doesn't recognize Firefox OS on smartphones.
Closing as we are not working on Firefox OS anymore.
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.