Closed Bug 827255 Opened 7 years ago Closed 7 years ago

[Bluetooth][Hfp] Enable AG error result code

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla21
blocking-b2g tef+
Tracking Status
firefox20 --- wontfix
firefox21 --- fixed
b2g18 + fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- fixed

People

(Reporter: gyeh, Assigned: gyeh)

References

Details

Attachments

(3 files, 2 obsolete files)

AT+CMEE command is to enable the use of result code +CME ERROR:<err> as an indication of an error relating to the functionality of the AG.

Please see 4.9 "Report Extended Audio Gateway Error Results Code" of HFP 1.5 for more detail.
Since we don't support voice recognition in AG, just reply "ERROR" when receiving AT+BVRA command.
Assignee: nobody → gyeh
Attachment #698594 - Flags: review?(echou)
Blocks: 827230
Comment on attachment 698594 [details] [diff] [review]
Patch 1(v1): Enable AG error result code

Review of attachment 698594 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, r+ with nits addressed.

::: dom/bluetooth/BluetoothHfpManager.cpp
@@ +746,5 @@
>        message.AppendInt(TOA_UNKNOWN);
>        message += ",,4";
>        SendLine(message.get());
>      }
> +  } else if (msg.Find("AT+COPS=") != -1) {

I think that would make more sense moving this part to bug 827230. The dependency has been already set, so it should be fine.

::: dom/bluetooth/BluetoothHfpManager.h
@@ +22,5 @@
> + * and 3GPP 27.007" in Bluetooth hands-free profile 1.6
> + */
> +enum BluetoothCmeError {
> +  AG_FAILURE = 0,
> +  OPERATION_NOT_ALLOWED = 3,

I checked HFP 1.6 and found a constants is missing:

   +CME ERROR: 1 – no connection to phone
Attachment #698594 - Flags: review?(echou) → review+
Final patch.

const of "no connection to phone" is added, and AT+COPS= part is moving to Bug827230.
Attachment #698594 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/5561a6bf08b2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Please nominated for uplift approval with a risk assessment.
NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): no
User impact if declined: would miss a Bluetooth HFP feature which is neccesary for certification
Testing completed: mozilla-central
Risk to taking this patch (and alternatives if risky): Fairly low. Just parse an AT command and keep the value as a member variable.
String or UUID changes made by this patch: no
Attachment #728898 - Flags: approval-mozilla-b2g18?
Comment on attachment 728898 [details] [diff] [review]
patch 1: for b2g18, r=echou

Review of attachment 728898 [details] [diff] [review]:
-----------------------------------------------------------------

Been in product already for a while - approving for uplift.
Attachment #728898 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
This bug(and other 9 bugs) block Bluetooth certification. So, these bugs need to be marked as tef+ and landed to v1.0.1 in order to pass Bluetooth certification: 

bug 827255
bug 827212
bug 827266
bug 828175
bug 823346
bug 827230
bug 828798
bug 835740
bug 846647
bug 828160

So, mark these bugs as tef?. These fixes have some dependency and it would be better to have them landed in a specific order. Gina has a good view on this.
blocking-b2g: --- → tef?
I recommend to land these patches in the following order:

01. bug827204
02. bug827255
03. bug823346
04. bug827230
05. bug828798
06. bug827212, patch 1
06. bug827212, patch 2
07. bug827266
08. bug828175
09. bug846647
10. bug825861
11. bug825851
12. bug835740




I'm going to attach patches for b2g18_v1_0_1 for each bug. Please land them in the above order. There should be no conflict and feel free to let me know if I can be any help.
Attached patch b2g18_v1_0_1 patch (obsolete) — Splinter Review
tef- for now until tef release partner confirms this is blocking BT cert.
blocking-b2g: tef? → -
Seems it is confirmed as per bug 868347
blocking-b2g: - → tef+
v1.0.1 patch updated.
Attachment #738762 - Attachment is obsolete: true
Ryan, I've updated all patches. Please land them in the following order, thanks.

01. bug827204
02. bug827255
(03. bug823346 has been landed on v1.0.1)
04. bug827230
05. bug828798
06. bug827212, patch 1
06. bug827212, patch 2
07. bug827266
08. bug828175
09. bug846647
10. bug825861
11. bug825851
12. bug835740
You need to log in before you can comment on or make changes to this bug.