[b2g-bluetooth] Modified BRSF value in hands-free profile

RESOLVED FIXED in Firefox 21

Status

()

defect
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: gyeh, Assigned: gyeh)

Tracking

21 Branch
mozilla21
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+, firefox21 fixed, b2g18+ fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

Attachments

(3 attachments, 2 obsolete attachments)

In our current central code base, following features are supported:
- (bit 0) Three-way calling
- (big 5) Ability to reject a call
- (big 6) Enhanced call status

Thus, value of BRSV (Bluetooth Retrieve Supported Features) should be updated to 97.

Besides, no return NS_ERROR_FAILURE for function SetJSObject in BluetoothUtil.cpp
Comment on attachment 707527 [details] [diff] [review]
Patch 1(v1): Modified BRSF value and return value in SetJsObject

Review of attachment 707527 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with nit addressed.

::: dom/bluetooth/BluetoothUtils.cpp
@@ +65,5 @@
>        if (!JS_SetProperty(aContext, aObj,
>                            NS_ConvertUTF16toUTF8(arr[i].name()).get(),
>                            &val)) {
>          NS_WARNING("Failed to set property");
> +        return false;

There is another place needs to be revised, too. Please search NS_ENSURE_TRUE in the same function and you'll notice that it would also return NS_ERROR_FAILURE if the condition doesn't match.
Attachment #707527 - Flags: review?(echou) → review+
Final patch with nits addressed.

https://hg.mozilla.org/integration/mozilla-inbound/rev/8c1d7f3cc036
Attachment #707527 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/8c1d7f3cc036
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Since we've landed several HFP feature bugs to b2g18 recently, BRSF should be revised as well. Nominate as tracking-b2g? and Gina will be in charge of the patch for b2g18.
tracking-b2g18: --- → ?
This patch is for b2g18.
Comment on attachment 731738 [details] [diff] [review]
Final patch for b2g-18, r=echou

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: Certification may fail.
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none
Attachment #731738 - Flags: approval-mozilla-b2g18?
Comment on attachment 731738 [details] [diff] [review]
Final patch for b2g-18, r=echou

small, bluetooth-only change, approving for uplift
Attachment #731738 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
This bug(and other 9 bugs) block Bluetooth certification. So, these bugs need to be marked as tef+ and landed to v1.0.1 in order to pass Bluetooth certification: 

bug 827255
bug 827212
bug 827266
bug 828175
bug 823346
bug 827230
bug 828798
bug 835740
bug 846647
bug 828160

So, mark these bugs as tef?. These fixes have some dependency and it would be better to have them landed in a specific order. Gina has a good view on this.
blocking-b2g: --- → tef?
I recommend to land these patches in the following order:

01. bug827204
02. bug827255
03. bug823346
04. bug827230
05. bug828798
06. bug827212, patch 1
06. bug827212, patch 2
07. bug827266
08. bug828175
09. bug846647
10. bug825861
11. bug825851
12. bug835740




I'm going to attach patches for b2g18_v1_0_1 for each bug. Please land them in the above order. There should be no conflict and feel free to let me know if I can be any help.
Posted patch b2g18_v1_0_1 patch (obsolete) — Splinter Review
tef- for now until partner confirms this is blocking BT cert.
blocking-b2g: tef? → -
Seems it is confirmed it blocks BT cer as per bug 868347
blocking-b2g: - → tef+
v1.0.1 patch updated.
Attachment #738777 - Attachment is obsolete: true
Ryan, I've updated all patches. Please land them in the following order, thanks.

01. bug827204
02. bug827255
(03. bug823346 has been landed on v1.0.1)
04. bug827230
05. bug828798
06. bug827212, patch 1
06. bug827212, patch 2
07. bug827266
08. bug828175
09. bug846647
10. bug825861
11. bug825851
12. bug835740
You need to log in before you can comment on or make changes to this bug.