Last Comment Bug 828146 - Scrollbar Visual Glitch ( regardless of the HWA on/off).
: Scrollbar Visual Glitch ( regardless of the HWA on/off).
Status: RESOLVED FIXED
: regression, testcase
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 18 Branch
: All All
: -- normal with 2 votes (vote)
: mozilla21
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
Mentors:
: 828824 830337 832836 (view as bug list)
Depends on:
Blocks: 810470 834742
  Show dependency treegraph
 
Reported: 2013-01-08 21:42 PST by Adam Frisby
Modified: 2013-04-26 07:44 PDT (History)
16 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
-
wontfix
-
fixed
-
fixed
unaffected


Attachments
scrollbar.png (1.02 KB, image/png)
2013-01-08 21:42 PST, Adam Frisby
no flags Details
Test case (630 bytes, text/html)
2013-01-08 23:11 PST, Adam Frisby
no flags Details
somewhat simpler testcase (342 bytes, text/html)
2013-01-23 21:10 PST, Robert O'Callahan (:roc) (email my personal email if necessary)
no flags Details
fix (3.38 KB, patch)
2013-01-30 21:25 PST, Robert O'Callahan (:roc) (email my personal email if necessary)
matt.woodrow: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta-
Details | Diff | Splinter Review

Description Adam Frisby 2013-01-08 21:42:36 PST
Created attachment 699572 [details]
scrollbar.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130108 Firefox/21.0
Build ID: 20130108033457

Steps to reproduce:

Have HW Acceleration enabled
Have Flash plugin installed and enabled (I'm on version 11.6.602.108)

Open this page in a new tab: https://github.com/ataranto/CefSharp
Open this page in a second tab: https://groups.google.com/forum/#!forum/cefsharp
Scroll down the page in the second tab


Actual results:

Scrollbar visually glitches


Expected results:

Scrollbar does not visually glitch
Comment 1 Adam Frisby 2013-01-08 23:11:39 PST
Created attachment 699593 [details]
Test case
Comment 2 Adam Frisby 2013-01-08 23:13:52 PST
I attached the most simplified html file I could still reproduces the bug.

Revised steps to reproduce:

Have HW Acceleration enabled
Have Flash plugin installed and enabled (I'm on version 11.6.602.108)

Open any page with flash content (e.g. Youtube) in one tab
Open Test Case html file in second tab
Scroll down the Test Case page
Comment 3 Adam Frisby 2013-01-08 23:23:39 PST
Sorry to keep replying.

With the test case I uploaded the glitch occurs for me both with or without HW acceleration enabled as well as without the flash tab being loaded. I have no idea whats happening.

Revised steps to reproduce:

Open Test Case html file
Scroll down the page
Comment 4 Adam Frisby 2013-01-08 23:30:51 PST
Also the original test case also works with Silverlight or Java. Load a webpage that has silverlight content (I used netflix) or load a page with a java applet and the visual glitch is present on the google groups page.
Comment 5 Alice0775 White 2013-01-09 01:27:02 PST
Regression range with comment#1 testcase

The problem happens regardless of the HWA on/off.
And It happens in Windows7 Aero and AeroBasic, but not in Windows7 Classic.

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/58ebb638a7ea
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121115172150
Bad:
http://hg.mozilla.org/mozilla-central/rev/a7ed19f7d21a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121116090659
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=58ebb638a7ea&tochange=a7ed19f7d21a


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/244493403e89
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121115151651
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/2c2c6ddb6fe6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121115163151
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=244493403e89&tochange=2c2c6ddb6fe6


In local build:
Last Good: a3ea6aa33de6
First Bad: 76e6feedd0d6

Triggered by:
76e6feedd0d6	Robert O'Callahan — Bug 810470. Part 2: Change nsDisplayBackground invalidation to store and compare the background positioning rect. r=mattwoodrow


Regression window(aurora-channel)
Good:
http://hg.mozilla.org/releases/mozilla-aurora/rev/51b78d081436
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121119014404
Bad:
http://hg.mozilla.org/releases/mozilla-aurora/rev/f0833ab13aef
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121119025204
Pushlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=51b78d081436&tochange=f0833ab13aef
Comment 6 Alex Keybl [:akeybl] 2013-01-13 13:31:36 PST
roc - if you're able to find a low risk fix here, we'd be happy to uplift. The user impact is not great enough to track for release though.
Comment 7 Alice0775 White 2013-01-14 08:45:50 PST
*** Bug 830337 has been marked as a duplicate of this bug. ***
Comment 8 Alice0775 White 2013-01-21 00:07:16 PST
*** Bug 832836 has been marked as a duplicate of this bug. ***
Comment 9 mjh563 2013-01-21 07:57:12 PST
Bug 832075 is similar to this, but I'm not sure if it's an exact duplicate.
Comment 10 Alice0775 White 2013-01-21 19:15:51 PST
*** Bug 832075 has been marked as a duplicate of this bug. ***
Comment 11 Robert O'Callahan (:roc) (email my personal email if necessary) 2013-01-23 21:10:46 PST
Created attachment 705732 [details]
somewhat simpler testcase
Comment 12 Robert O'Callahan (:roc) (email my personal email if necessary) 2013-01-23 21:11:37 PST
You need to shift-reload to get that testcase to work. Not sure why.
Comment 13 Robert O'Callahan (:roc) (email my personal email if necessary) 2013-01-30 21:25:19 PST
Created attachment 708455 [details] [diff] [review]
fix
Comment 14 Robert O'Callahan (:roc) (email my personal email if necessary) 2013-01-31 22:36:17 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/d7f45e033103
Comment 15 Ryan VanderMeulen [:RyanVM] 2013-02-01 13:18:15 PST
https://hg.mozilla.org/mozilla-central/rev/d7f45e033103
Comment 16 Robert O'Callahan (:roc) (email my personal email if necessary) 2013-02-03 17:55:00 PST
Comment on attachment 708455 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): DLBI
User impact if declined: Corrupt scrollbar drawing (and possibly corrupt drawing of other native-themed content)
Testing completed (on m-c, etc.): landed
Risk to taking this patch (and alternatives if risky): low risk patch. Just makes us invalidate more for themed content.
String or UUID changes made by this patch: none
Comment 17 Alex Keybl [:akeybl] 2013-02-04 16:01:43 PST
Comment on attachment 708455 [details] [diff] [review]
fix

Approving for Aurora, but it's too late for non-critical change on Beta at this point.
Comment 18 Ryan VanderMeulen [:RyanVM] 2013-02-04 17:54:55 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/0492f5009464
Comment 19 Karl Tomlinson (:karlt) 2013-02-04 20:34:20 PST
*** Bug 828824 has been marked as a duplicate of this bug. ***
Comment 20 Maria Grazia Alastra [:mga] 2013-04-26 07:44:03 PDT
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

Verified on Firefox 21.0b5, on Windows 7, 64 bits using the two provided testcases.

Note You need to log in before you can comment on or make changes to this bug.