Last Comment Bug 828824 - Scrolling a page up leaves residue in GTK slider
: Scrolling a page up leaves residue in GTK slider
Status: RESOLVED DUPLICATE of bug 828146
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 18 Branch
: x86 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 832075 (view as bug list)
Depends on:
Blocks: 810470
  Show dependency treegraph
 
Reported: 2013-01-09 22:48 PST by Przemek Kramarczyk
Modified: 2013-02-04 20:34 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot (202.22 KB, image/png)
2013-01-09 22:48 PST, Przemek Kramarczyk
no flags Details

Description Przemek Kramarczyk 2013-01-09 22:48:00 PST
Created attachment 700210 [details]
screenshot

User Agent: Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0 SeaMonkey/2.15
Build ID: 20130105222032

Steps to reproduce:

I use the mouse and scrollbar to scroll page.


Actual results:

there were artifacts on scrollbar (black horizontal lines).


Expected results:

scrollbar should be clean.
Comment 1 Matthias Versen [:Matti] 2013-01-09 23:34:08 PST
Is the scrollbar still working ?
Could be a dupe of bug 787465
Comment 2 Siim Ainsaar 2013-01-10 18:19:18 PST
I am seeing exactly the same in Firefox 18.0 (and not in any earlier version). Just hit End on any page (that needs scrolling) and scroll upwards. Scrolling downwards works. Moving the mouse over the scrollbar clears the artifacts.

I am using Gentoo Linux. Some GTK themes that exhibit the bug are Adwaita, Clearlooks, Glossy, Industrial, MurrinaGilouche and Unity. Some themes that are fine are Glider, MurrezaSilver, Raleigh, Redmond and ThinIce.

=====================================================================================

Some information from about:support (I created a new clean profile):


  Application Basics

        Name
        Firefox

        Version
        18.0

        User Agent
        Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

  Important Modified Preferences

      Name

      Value

        browser.cache.disk.capacity
        358400

        browser.cache.disk.smart_size_cached_value
        358400

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size.use_old_max
        false

        browser.places.smartBookmarksVersion
        4

        browser.startup.homepage_override.buildID
        20130110055122

        browser.startup.homepage_override.mstone
        18.0

        extensions.lastAppVersion
        18.0

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        93936

        privacy.sanitize.migrateFx3Prefs
        true

  Graphics

        Adapter Description
        NVIDIA Corporation -- GeForce 9300M GS/PCIe/SSE2

        Device ID
        GeForce 9300M GS/PCIe/SSE2

        Driver Version
        3.3.0 NVIDIA 310.19

        GPU Accelerated Windows
        0/1 Basic no information

        WebGL Renderer
        NVIDIA Corporation -- GeForce 9300M GS/PCIe/SSE2

        Vendor ID
        NVIDIA Corporation

        AzureCanvasBackend
        cairo

        AzureContentBackend
        none

        AzureFallbackCanvasBackend
        none

  JavaScript

        Incremental GC
        true

  Accessibility

        Activated
        false

        Prevent Accessibility
        0

  Library Versions

        Expected minimum version

        Version in use

        NSPR
        4.9.4
        4.9.4

        NSS
        3.14.1.0 Basic ECC
        3.14.1.0 Basic ECC

        NSSSMIME
        3.14.1.0 Basic ECC
        3.14.1.0 Basic ECC

        NSSSSL
        3.14.1.0 Basic ECC
        3.14.1.0 Basic ECC

        NSSUTIL
        3.14.1.0
        3.14.1.0


=====================================================================================

Information from about:buildconfig (I have compiled Firefox myself, but it is from the official Gentoo Portage repository):


about:buildconfig
Build Machine

localhost
Build platform
target
x86_64-pc-linux-gnu
Build tools
Compiler 	Version 	Compiler flags
x86_64-pc-linux-gnu-gcc 	gcc version 4.6.3 (Gentoo 4.6.3 p1.8, pie-0.5.2) 	-Wall -Wpointer-arith -Wdeclaration-after-statement -Werror=return-type -Wtype-limits -Wempty-body -Wno-unused -Wno-overlength-strings -Wcast-align -march=core2 -pipe -mno-avx -fno-strict-aliasing -ffunction-sections -fdata-sections -pthread -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks -fomit-frame-pointer
x86_64-pc-linux-gnu-g++ 	gcc version 4.6.3 (Gentoo 4.6.3 p1.8, pie-0.5.2) 	-Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Werror=conversion-null -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wcast-align -march=core2 -pipe -mno-avx -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks -fomit-frame-pointer
Configure arguments

--enable-application=browser --enable-optimize --with-system-jpeg --with-system-zlib --enable-pango --enable-system-cairo --disable-pedantic --disable-updater --disable-strip --disable-install-strip --disable-profilelocking --enable-default-toolkit=cairo-gtk2 --enable-official-branding --enable-dbus --disable-debug --disable-tests --enable-startup-notification --enable-system-sqlite --disable-necko-wifi --enable-ogg --enable-wave --with-system-libvpx --with-system-nspr --with-nspr-prefix=/usr --with-system-nss --with-nss-prefix=/usr --x-includes=/usr/include --x-libraries=/usr/lib64 --with-system-libevent=/usr --enable-system-hunspell --disable-gnomevfs --disable-gnomeui --enable-gio --disable-crashreporter --prefix=/usr --libdir=/usr/lib64 --disable-gconf --disable-mailnews --with-system-png --enable-system-ffi --with-default-mozilla-five-home=/usr/lib64/firefox --target=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --disable-gstreamer --enable-system-sqlite --enable-methodjit --enable-tracejit --enable-extensions=default
Comment 3 Philip Chee 2013-01-11 05:04:49 PST
In about:config do you have a preference called "gfx.content.azure.enabled" ?
If you do try toggling it from true to false.
Comment 4 Siim Ainsaar 2013-01-11 10:09:23 PST
I had gfx.content.azure.enabled=true, toggling it made no difference.
Comment 5 Siim Ainsaar 2013-01-12 22:48:42 PST
Looks like it is bug 297508 again. By the way, it also appears on the rightmost part of horizontal scrollbar.
Comment 6 Philip Chee 2013-01-13 05:36:49 PST
Which GTK+ theme are you using? Does this happen with other GTK+ themes?
Comment 7 Przemek Kramarczyk 2013-01-13 05:45:54 PST
(In reply to Philip Chee from comment #6)
> Which GTK+ theme are you using? Does this happen with other GTK+ themes?

I use clearlooks 0.6.2 engine. If i switch to Raleigh theme (default GTK+2 theme), scrollbar are OK. But Raleigh is ugly. I like Clearlooks engine.
Comment 8 Philip Chee 2013-01-14 05:50:28 PST
Moving to Core->Widget: Gtk
Comment 9 Siim Ainsaar 2013-01-14 08:56:09 PST
For some time I thought the culprit was the fix of bug 806583, as it touched the overflow algorithm. Unfortunately, reverting the most suspicious patch https://github.com/mozilla/releases-mozilla-central/commit/53af1033f75aec7ac7bb4951a031ec0e12343507 does not fix this bug here.
Comment 10 Karl Tomlinson (ni?:karlt) 2013-01-21 18:37:56 PST
Can reproduce with recent build.
Comment 11 Karl Tomlinson (ni?:karlt) 2013-01-22 23:21:08 PST
m-c regression window: 2012-11-16 to 2012-11-17

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=58ebb638a7ea&tochange=9a6d708faf3f

suggesting a changeset that was backported from 19 to 18.
Comment 12 Karl Tomlinson (ni?:karlt) 2013-01-23 18:17:53 PST
beta window: edc2aedfaed5 to 722b6d63295b
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=edc2aedfaed5&tochange=59e8632b391e
http://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=edc2aedfaed5&tochange=722b6d63295b

Perhaps a dupe of bug 828146, but symptoms are a little different.
With and without GL layers.
Comment 13 Karl Tomlinson (ni?:karlt) 2013-01-23 18:22:35 PST
*** Bug 832075 has been marked as a duplicate of this bug. ***
Comment 14 Karl Tomlinson (ni?:karlt) 2013-02-04 20:34:20 PST
Seems to be fixed by changes in bug 828146.

*** This bug has been marked as a duplicate of bug 828146 ***

Note You need to log in before you can comment on or make changes to this bug.