[Settings] Scroll bar should not go over the header

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Sergi, Assigned: ivanovpavel)

Tracking

unspecified
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(b2g18+ fixed, b2g18-v1.0.1 wontfix)

Details

(Whiteboard: visual design [UX-P1], TEF_REQ, PRODUCT-DELIGHT, uxbranch, landed in uxbranch)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 700266 [details]
Incorrect Scroll Bar :: Screenshot
(Reporter)

Updated

5 years ago
Whiteboard: visual design, incorrect implementation
Whiteboard: visual design, incorrect implementation → visual design, incorrect implementation, BerlinWW
Assignee: nobody → pivanov
Attachment #700266 - Flags: feedback?(kaze)
I ask Kaze for feedback because the patch for this bug will contains extra DOM elements.
I guess I’m OK with that because it would get us rid of a few “position: fixed” rules, but I don’t think it’s a good idea to do this three days before the release, the risk-over-value ratio seems to high.
Attachment #700266 - Flags: feedback?(kaze)
Josh, what do you think?
Flags: needinfo?(jcarpenter)
Every other app does this right. Settings should too :)
Flags: needinfo?(jcarpenter)
Blocks: 815609
Josh, we’re not saying we shouldn’t do it: we’re wondering if it’s worth the risk at this point.

Pavel, can you fix bug 815609 and this one in the UX branch?
Created attachment 701573 [details]
patch for Gaia repo
Attachment #701573 - Flags: review?(kaze)
Blocks: 830111
Comment on attachment 701573 [details]
patch for Gaia repo

move to UX branch
Attachment #701573 - Attachment is obsolete: true
Attachment #701573 - Flags: review?(kaze)
Created attachment 701584 [details]
patch for UX branch
Attachment #701584 - Flags: review?(kaze)
Comment on attachment 701584 [details]
patch for UX branch

clearing the review as it’s moved to the UX branch
Attachment #701584 - Flags: review?(kaze)
(Reporter)

Updated

5 years ago
Whiteboard: visual design, incorrect implementation, BerlinWW → visual design [UX-P1], TEF_REQ
Attachment #701584 - Flags: review?(sjochimek)
Attachment #701584 - Flags: review?(kaze)

Updated

5 years ago
Whiteboard: visual design [UX-P1], TEF_REQ → visual design [UX-P1], TEF_REQ, PRODUCT-DELIGHT

Updated

5 years ago
Attachment #701584 - Flags: review?(sjochimek)

Comment 10

5 years ago
Landed in uxbranch: https://github.com/gordonbrander/gaia/commit/2321a9ab3feeb9a9b4217aa4d63f2a4af0b96903
Whiteboard: visual design [UX-P1], TEF_REQ, PRODUCT-DELIGHT → visual design [UX-P1], TEF_REQ, PRODUCT-DELIGHT, uxbranch, landed in uxbranch

Comment 11

5 years ago
https://github.com/mozilla-b2g/gaia/commit/25d9e53380db967d76223c5f1e1940ed907ed447
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Master build : 2013-03-26-07-02-04
"mozilla-central" revision="28b048ffb7a7"
"integration/gaia-central" revision="44f6a17f24d4"
"gecko.git"revision="a800f14ea7022a78966f7fe14a9b0d11c569b151"
"gaia.git" revision="ace1eb32a313da1232bbdf9cff2581a4b036356d"

Verified on master, not on v1 train.
Status: RESOLVED → VERIFIED
status-b2g18: --- → affected

Comment 13

5 years ago
Comment on attachment 701584 [details]
patch for UX branch

Is this ready to raise to approval? with user value and risk in the comments? Our goal is to wrap up all Yedo and VxD changes by April 5th.
Yes, I think so.
The master commit hash for this specific bug is 6bbe58edb16169c94dda6426ce77059d06d2a4fe.

Comment 16

5 years ago
Thanks, Pavel. Can you please raise to approval? - I tried but don't have the appropriate permissions. Sorry!
Comment on attachment 701584 [details]
patch for UX branch

clearing the r? as it’s been landed in the UX branch anyway.
Attachment #701584 - Flags: review?(kaze)

Comment 18

5 years ago
Approval? still has not been raised on this. I would do it but I do not have permissions to do so. Please raise to approval so we can keep this moving for 1.1 and v1-train. Thank you!
Comment on attachment 701584 [details]
patch for UX branch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: see bug title
Testing completed: yes, QA checked on master
Risk to taking this patch (and alternatives if risky): very low, no logic change, small CSS change
String or UUID changes made by this patch: none
Attachment #701584 - Flags: approval-gaia-v1?(21)

Comment 20

5 years ago
visual design change requesting trackingb2g18 nom
tracking-b2g18: --- → ?
Attachment #701584 - Flags: approval-gaia-v1?(21) → approval-gaia-v1+
Depends on: 858722
This should _not_ be uplifted without bug 858722.
No longer depends on: 858722
Depends on: 858722
tracking-b2g18: ? → +
Blocks: 854031
Merged on v1-train: https://github.com/mozilla-b2g/gaia/commit/1a1e9b44e75252746bf5ebe343ee06fd3c300612
status-b2g18: affected → fixed
status-b2g18-v1.0.1: --- → affected
status-b2g18-v1.0.1: affected → wontfix
(In reply to Fabien Cazenave [:kaze] from comment #22)
> Merged on v1-train:
> https://github.com/mozilla-b2g/gaia/commit/
> 1a1e9b44e75252746bf5ebe343ee06fd3c300612
This commit unexpectedly merged partial patch of bug 830644 and causes style class in html is inconsistent with css definition. (grep "sim-code-area" in both files).

Furthermore, this patch also unexpectedly remove some DOM elements in settings/index.html and causes two regression bugs: bug 861215 and bug 861730. 
Sad. :'(
You need to log in before you can comment on or make changes to this bug.