Page elements display on top of each other

VERIFIED FIXED in mozilla0.9.4

Status

()

defect
--
major
VERIFIED FIXED
18 years ago
5 years ago

People

(Reporter: jacobus, Assigned: karnaze)

Tracking

({regression, testcase, top100})

Trunk
mozilla0.9.4
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(7 attachments)

(Reporter)

Description

18 years ago
Parts of the page are rendered on top of each other.
This won't occur the first time the page is rendered but will occur when the
page is reloaded.

Comment 1

18 years ago
I see this also with Linux build 2001052308, even on the first load. Changing OS
to all.
OS: Windows 98 → All

Comment 2

18 years ago
Correction: the first time I loaded it I saw the problem, when I reloaded it the
problem was still there.

However going to another page, then coming back, it gets rendered correctly. If
you then hit reload it looks messed up.

So it seems to be the only time it looks OK is a fresh reload from cache.

Comment 3

18 years ago
Confirming on 2001052608 Win2k, upping severity to Normal, and over to HTML
Tables as the layout is made with a table.

I'm seeing similar problems on http://www.firaxis.com/features/e3_2k1/ and
https://www.1822direkt.com/onlineb.ns4.html, but I don't know if those belong to
the same bug.

I remember having seen a similar bug report before, but I don't know the bug number.
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Component: Layout → HTMLTables
Ever confirmed: true
QA Contact: petersen → amar
Whiteboard: DUPEME

Comment 4

18 years ago
Updating summay from "Slightly odd rendering of layout" to "Page elements
display on top of each other".
Summary: Slightly odd rendering of layout → Page elements display on top of each other
(Assignee)

Comment 5

18 years ago
Amar, can you please develop a test case.
Keywords: qawanted
Target Milestone: --- → mozilla0.9.3

Comment 6

18 years ago
I've tried to make a local testcase but couldn't.  The bug seems to be caused
from the reflowing of the table after loading the logo
http://www.oasis-open.org/cover/images/rclogo460.gif

Comment 7

18 years ago
*** Bug 82036 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
Removing Status Whiteboard & Keywords. If you can find it good but I cant.
Keywords: qawanted
Whiteboard: DUPEME

Comment 9

18 years ago
Well, I just spent 30 minutes adding a comment to this bug, only to have it wiped
out because bugzilla wouldn't accept "correctness" and "nsCatFood" added by me,
and the comment was gone when I hit the back button as recommended.  If you don't
want to trust the help you get from your users, I guess you'll have to live with
less help.

Comment 10

18 years ago
cc'ing self

Comment 13

18 years ago
Build 2001061520 win32 installer sea talkback trunk
I can only see the effect of the bug in the last two testcases I attached when:
1. the browser window is maximised
2. pressing reload after opening the testcase

Comment 14

18 years ago
*** Bug 86424 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
another testcase from bug 86424
http://www.cizgi.com.tr/sss/sss2u.htm

Comment 16

18 years ago
*** Bug 87522 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
Another test case bottom of the science pages in the nytimes,
(free subscription site) This is an example one:
http://www.nytimes.com/2001/06/24/national/24PIPE.html

Comment 18

18 years ago
pg can you create a simplified testcase out of that page?

Comment 20

18 years ago
Open the attachment and then hit reload and you should see overlaping images.

Comment 22

18 years ago
Any relations with bug 83769??

Comment 23

18 years ago
*** Bug 83769 has been marked as a duplicate of this bug. ***

Comment 24

18 years ago
Is bug 88069 a dupe as well ?

Comment 25

18 years ago
*** Bug 88069 has been marked as a duplicate of this bug. ***
*** Bug 87418 has been marked as a duplicate of this bug. ***

Comment 27

18 years ago
Think this bug doesn't owe the awareness it should.
This one is having quite a great impact on mozilla and there
are a few around describing the same problem.

We should try to get this one down real soon.
Severity: normal → major
Working with the testcases, I was able to pin this down to a problem with the
image element, not the table (although something screwy is still happening with
the table layout).  If you add an explicit height and width to the image
'rclol460.gif' then the overlap does not occur.  It would seem that an
'auto'-sized image is ignored for the purposes of progressive table layout on
the first pass.  In some circumstances this can cause table cells to overlap
other table cells, dragging their content along with them.  Resizing the page
will fix the problem as the cell "magically" jumps back to its proper spot, with
the content again going along for the ride.  (Getting a reload straight from
cache also avoids the problem for some reason.) 
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=38770 demonstrates this
problem best, I think, especially since it demonstrates that explicitly-sized
elements are not affected by this odd behavior.

I will be attaching some testcases (modifications of the first two attachments)
to this entry in a few minutes and hope that
the information presented will allow the Mozilla folks to fix this one in a
jiffy.  I've seen it in a few sites (zoomerang.com for example) and fixing this
would be a major win.
Well, my testcase (http://bugzilla.mozilla.org/show_bug.cgi?id=87418), which is
supposed to be the same problem as this, can't be fixed by specifying any image
size, because the image is the background of a table.

http://overosa.dhs.org/musik.html
I didn't mean to imply that the sole source of trouble was the image not having
height and width-- just that adding them "resolved" the layout problem, which
would hopefully lead the coders to the right place in the table layout code to
actually fix this.  With luck, that will also resolve the problems reported in
#87418.
Oki, I see. Sorry :)

Comment 35

18 years ago
testcase from 87418

http://overosa.dhs.org/musik.html

Comment 36

18 years ago
attachment 38770 [details] looked good when I visit it for the first time
but looked messy second time and now it looks messy always.

same with http://www.nytimes.com/2001/06/24/national/24PIPE.html,
when I visit it for the first time I see it good but now and ever it's messed up
(the bottom).

I have "Enable Mem Cache" [x] turned on and "Enable Disk Cache" [ ] turned off.
what about http://www.zdnet.com/ ? it's also messy ...

there are some <hr> elements overlapping the text and pictures through
http://pes.internet.cz/ page.
(current trunk on Red Hat 7.1 Linux)

Updated

18 years ago
Keywords: mostfreq

Comment 37

18 years ago
*** Bug 90877 has been marked as a duplicate of this bug. ***

Comment 39

18 years ago
*** Bug 89326 has been marked as a duplicate of this bug. ***

Comment 40

18 years ago
*** Bug 84555 has been marked as a duplicate of this bug. ***

Comment 41

18 years ago
adding mostfreq
Keywords: mostfreq

Comment 42

18 years ago
adding top100 as this is seen on a number of top100 sites
Keywords: top100
cc'ing self

Keywords: mostfreq, top100

Updated

18 years ago
Keywords: mostfreq, top100

Comment 44

18 years ago
Another testcase:

https://ibp.scandinavian.net/secure/booking/pleasure/psearchavailability1.asp?Youth=1

The text overlaps the image. Notice that if you type something into the "Leaving
From" field, then minimize the window and maximize it again the page will
display correctly again. Shift-reloding it later brings back the overlap. This
page looks fine in 4.x.

Comment 45

18 years ago
I didn't have much time to investigate properly (sorry), but I think that
following URL is demonstration of this bug, too. 

http://areyours.com/s/inmigracion/programas/jubilarse/index.html
I know that page has lot's of errors and is not valid HTML, but it is rendered
fine in K-meleon 0.4, which uses Gecko (version from moz 0.9.1 IIRC) so the
problem is IMHO somewhere in latest mozilla.
--mondo

Comment 46

18 years ago
*** Bug 85848 has been marked as a duplicate of this bug. ***
*** Bug 92616 has been marked as a duplicate of this bug. ***

Comment 48

18 years ago
Missed 0.9.3.
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Comment 49

18 years ago
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: patch

Comment 50

18 years ago
r=savulov

Comment 51

18 years ago
sr=attinasi

Comment 52

18 years ago
*** Bug 90132 has been marked as a duplicate of this bug. ***

Comment 53

18 years ago
*** Bug 89777 has been marked as a duplicate of this bug. ***

Comment 54

18 years ago
*** Bug 91006 has been marked as a duplicate of this bug. ***

Comment 55

18 years ago
*** Bug 92042 has been marked as a duplicate of this bug. ***

Updated

18 years ago
(Assignee)

Comment 56

18 years ago
*** Bug 86708 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Hardware: PC → All
(Assignee)

Comment 57

18 years ago
The patch is in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 58

18 years ago
This fixed most problems I saw (zdnet.com, netem.cz) but I still see some
overlaping (<hr>/<img>/text elements) on http://pes.internet.cz/.
(Assignee)

Comment 59

18 years ago
amar or martin, can you file a new bug for the remaining issue on the new site. 
This bug has had enough.

Comment 60

18 years ago
OK, I filled bug 94320 about this http://pes.internet.cz/ mess...

Comment 61

18 years ago
*** Bug 94826 has been marked as a duplicate of this bug. ***
I'm afraid the bug on http://overosa.dhs.org/musik.html is still occurring (aug
22 nightly): http://bugzilla.mozilla.org/show_bug.cgi?id=58653
Sorry, sorry! That was the wrong bug #

The original bug is http://bugzilla.mozilla.org/show_bug.cgi?id=87418

That's the issue that is happening again.
All of iesbild.com works fine in Mozilla!

Again, I am sorry.
The testcase looks good even after reloading..
verified on win2k and Linux 7.1
Build ID : 2001-09-24
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.