Developer command screenshot "too much arguments"

RESOLVED DUPLICATE of bug 799769

Status

RESOLVED DUPLICATE of bug 799769
6 years ago
3 months ago

People

(Reporter: bistory, Unassigned)

Tracking

({regression})

18 Branch
x86
Windows 7
regression

Firefox Tracking Flags

(firefox18 affected, firefox19-, firefox20-, firefox21-)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 700917 [details]
firefox-bug.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

Steps to reproduce:

Hi !
I'm trying to use the screenshot command in the latest Firefox release and have a bug.
It seems that new arguments have been added but when I'm trying to add more than one argument (the file name), the command line give me an error "Too much arguments" ("Trop d'arguments" in French).

This tool worked in Firefox 16 and I didn't test it un Firefox 17.

Here the commands I tried :

screenshot test.png 50ms false #header

and with new arguments :

screenshot test.png false false 50ms false #header


Actual results:

It gives me an error "Too much arguments"


Expected results:

The screenshot should have been written on the disk.

Updated

6 years ago
Component: Untriaged → Developer Tools: Graphic Commandline and Toolbar

Comment 1

6 years ago
There is a regression indeed since the screenshot command passed from 4 args to 6.

m-c
good=2012-09-14
bad=2012-09-15
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e5af3d785252&tochange=9fff2012b66c

Surely one of these 3 bugs:
Girish Sharma — Bug 790294 - GCLI screenshot command should show preview., r=jwalker
Girish Sharma — Bug 790026 - [gcli] screenshot command could use a 'chrome' option, r=jwalker
Girish Sharma — Bug 788890 - GCLI screenshot command with no filename should copy to clipboard, r=jwalker
Status: UNCONFIRMED → NEW
status-firefox18: --- → affected
tracking-firefox19: --- → ?
tracking-firefox20: --- → ?
tracking-firefox21: --- → ?
Ever confirmed: true
Keywords: regression
Thsi is not a regression, but a syntax change that is covered in [1]. Please use '--delay' or '--clipboard' or '--fullpage' kind of options to properly use the command.''Basically all the parameters are optional, and optional parameters can be passed using the --optionsName syntax. The help menu for screenshot (help screenshot) is still not updated and is covered in bug 815342
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
bah. [1] was : Girish Sharma — Bug 788890 - GCLI screenshot command with no filename should copy to clipboard, r=jwalker

Updated

6 years ago
tracking-firefox19: ? → -
tracking-firefox20: ? → -
tracking-firefox21: ? → -
Resolution: INVALID → DUPLICATE
Duplicate of bug: 799769

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.