Tablets should use Android Spinners

RESOLVED FIXED in Firefox 20

Status

()

RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

unspecified
Firefox 21
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 fixed)

Details

Attachments

(4 attachments)

Tablets should use Android styled spinners in the Tabs UI to switch between different sections.
(Assignee)

Updated

6 years ago
Blocks: 817675
(Assignee)

Comment 1

6 years ago
Created attachment 702938 [details] [diff] [review]
Part 1: Spinners on tablets

This patch replaces custom popup menu with standard android spinners. A bunch of styling is added to the themes.xml and styles.xml -- because that's how android takes in those values (so bad Android! so bad!).
Attachment #702938 - Flags: review?(mark.finkle)
(Assignee)

Comment 2

6 years ago
Created attachment 702939 [details] [diff] [review]
Part 2: Split action-bar

Tablets now have a split action-bar to show add tab and extra menu.

Note: Split action-bars are used in android only for phones. This is to ensure to better use space for more common actions -- that needn't be burried under menu. They don't use it on tablets. We don't use on phones, but tablets.
Attachment #702939 - Flags: review?(mark.finkle)
(Assignee)

Comment 3

6 years ago
Created attachment 702941 [details] [diff] [review]
Part 3: Popup above anchor

This shows the custom menu above the anchor -- in tabs menu.
Basically we need to know the height of the content view to decide if it should show up or down. To do that, we call measure when we add content.
Attachment #702941 - Flags: review?(mark.finkle)
Attachment #702938 - Flags: review?(mark.finkle) → review+
Attachment #702939 - Flags: review?(mark.finkle) → review+
Attachment #702941 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

6 years ago
Created attachment 703029 [details] [diff] [review]
Part 4: Action Bar dividers

This shifts the action-bar divider to be contained inside the action-bar height. We have to add an extra view in our case for 2 reasons:
1. While supporting personas, we need to show this divider. If not, the layout seems messy without it. Hence we need a solid line.
2. It could be a part of the parent container. However, in phones with tabs, the tab's selected state is cut off. Usually android applications have the entire action-bar divider color to be same as tab-selected color. Thereby, when they are applied as background, and tabs on top, they don't face any issue. We use a orange for selection and grey as divider and hence have to use a separate view for the divider.
Attachment #703029 - Flags: review?(mark.finkle)
Attachment #703029 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 6

6 years ago
Comment on attachment 702938 [details] [diff] [review]
Part 1: Spinners on tablets

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature.
User impact if declined: Holo themed spinners will be missing in Tablets.
Testing completed (on m-c, etc.): Landed in m-c on 01/17
Risk to taking this patch (and alternatives if risky): Very low. This replaces a Button with a Spinner - which shows a DropDown by itself.
String or UUID changes made by this patch: None.
Attachment #702938 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 7

6 years ago
Comment on attachment 702939 [details] [diff] [review]
Part 2: Split action-bar

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature.
User impact if declined: Holo themed split action-bar on tablets.
Testing completed (on m-c, etc.): Landed in m-c on 01/17
Risk to taking this patch (and alternatives if risky): Very low. The messy "add new tab" button is moved to the bottom.
String or UUID changes made by this patch: None.
Attachment #702939 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 8

6 years ago
Comment on attachment 702941 [details] [diff] [review]
Part 3: Popup above anchor

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature.
User impact if declined: PopupMenu won't show.
Testing completed (on m-c, etc.): Landed in m-c on 01/17
Risk to taking this patch (and alternatives if risky): Very low. This shows the PopupMenu above the anchor. Needed for menu button at the bottom.
String or UUID changes made by this patch: None.
Attachment #702941 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 9

6 years ago
Comment on attachment 703029 [details] [diff] [review]
Part 4: Action Bar dividers

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature.
User impact if declined: Barely noticeable by anyone. ;)
Testing completed (on m-c, etc.): Landed in m-c on 01/17
Risk to taking this patch (and alternatives if risky): Very low. A slight change in moving the action-bar dividers up by 2dp.
String or UUID changes made by this patch: None.
Attachment #703029 - Flags: approval-mozilla-aurora?
Attachment #702938 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #702939 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #702941 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #703029 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
status-firefox20: --- → fixed
Blocks: 834407
Depends on: 844471
You need to log in before you can comment on or make changes to this bug.