In landscape orientation, menu not appearing when clicked yet accepts touches

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: pwd.mozilla, Assigned: sriram)

Tracking

({regression, reproducible})

Trunk
Firefox 22
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified, firefox21 verified, firefox22 verified, fennec20+)

Details

Attachments

(2 attachments)

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130219 Firefox/21.0
Build ID: 20130219031055

Steps to reproduce:

So occasionally, I'm getting this. I'll go to a site, and attempt to open the menu. Nothing will happen, so I'll attempt again, only to be told "Bookmark Added". I'll grab a logcat next time I see it.
Reporter

Updated

6 years ago
OS: Windows 7 → Android
Hardware: x86 → ARM
Keywords: steps-wanted
I just hit this after rotating my device and accessing the menu; the menu did not appear and when I hit the menu button again, I got "Bookmark Added".
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: reproducible
tracking-fennec: --- → ?
Keywords: steps-wanted
Assignee: nobody → sriram
tracking-fennec: ? → 20+
Status: NEW → ASSIGNED
Showed this to Lucas he thinks it might be a visibility thing + an offset issue; you can tap anywhere below where the menu should be in content after invoking the menu and have any item selected. In any case, he thinks it's a Sriram issue :)
Flags: needinfo?(sriram)
Catalin, can you get a regression range from either late Jan or early Feb?
Flags: needinfo?(catalin.suciu)
good build: 20.01.2013
bad build: 21.01.2013

pushlog:http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=01a8559f5560&tochange=01c964705be7
Flags: needinfo?(catalin.suciu)
My money is on bug 831402 with that custom-menu patch in there even though there are over 250 change-sets in the above pushlog.
Blocks: 831402
Also bug 832433 is there too
Sriram - This is a bug on Beta (Fx20). Can we get some movement on it?
Depends on: 838796
Duplicate of this bug: 838202
Duplicate of this bug: 838796
Summary: Menu not appearing when clicked and yet accepting touches → In landscape orientation, menu not appearing when clicked yet accepts touches
Duplicate of this bug: 838796
We wanted to position the MenuPopup over an anchor. In that calcuation, I had missed checking if there is enough space above the anchor. Which caused the problem in landscape mode. (Basically I checked "if there is no enough space at the bottom without shrinking, show above the anchor").

This patch fixes it (and won't affect the menu in beta).
Attachment #723614 - Flags: review?(mark.finkle)
Flags: needinfo?(sriram)
This patch cleanups the code for Nightly only. We kills the tabs-ui menu on nightly, and can cleanup the code by restricting it to show only "below" the anchor.
Attachment #723616 - Flags: review?(mark.finkle)
Attachment #723614 - Flags: review?(mark.finkle) → review+
Attachment #723616 - Flags: review?(mark.finkle) → review+
Comment on attachment 723614 [details] [diff] [review]
Patch: Nightly+

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Tabs-UI Menu.
User impact if declined: Menu won't be shown in landscape mode.
Testing completed (on m-c, etc.): Landed in m-i yesterday.
Risk to taking this patch (and alternatives if risky): Very less. This adds a proper check.
String or UUID changes made by this patch: None.
Attachment #723614 - Flags: approval-mozilla-beta?
Attachment #723614 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/078256713f76
https://hg.mozilla.org/mozilla-central/rev/6f57d1e1a4ee
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Attachment #723614 - Flags: approval-mozilla-beta?
Attachment #723614 - Flags: approval-mozilla-beta+
Attachment #723614 - Flags: approval-mozilla-aurora?
Attachment #723614 - Flags: approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
Blocks: 851065
Verified on Aurora 21.0a2 2013-03-14 and Firefox Mobile 20 beta 5 on LG Nexus 4 (Android 4.2.2)
You need to log in before you can comment on or make changes to this bug.