Story - Pop-up blocker info app bar

VERIFIED FIXED

Status

defect
P2
normal
VERIFIED FIXED
6 years ago
5 months ago

People

(Reporter: asa, Assigned: mbrubeck)

Tracking

Details

(Whiteboard: feature=story c=Info_app_bar u=metro_firefox_user p=5)

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

6 years ago
Posted file UC-93 Pop-up blocker info app bar (obsolete) —
No description provided.
Reporter

Updated

6 years ago
Priority: -- → P2
Reporter

Updated

6 years ago
Whiteboard: c=Info_app_bar u= p= → c=Info_app_bar u=metro_firefox_user p=
Reporter

Updated

6 years ago
Summary: Pop-up blocker info app bar → Story – Pop-up blocker info app bar
Whiteboard: c=Info_app_bar u=metro_firefox_user p= → c=Info_app_bar u=metro_firefox_user feature=story
Reporter

Updated

6 years ago
Depends on: 801191
OS: Windows 8 → Windows 8 Metro
Whiteboard: c=Info_app_bar u=metro_firefox_user feature=story → feature=story c=Info_app_bar u=metro_firefox_user p=0
Depends on: 836378

Updated

6 years ago
No longer depends on: 836378

Updated

6 years ago
Depends on: 838211
Assignee

Comment 1

6 years ago
Asa, Stephen: What order should the three buttons (allow once, always allow, never allow) appear in, and which one (if any) should be styled as the default?
Flags: needinfo?(asa)
Blocks: metrov1planning
No longer blocks: metrov1backlog
Reporter

Comment 2

6 years ago
The order should be once, always, never. Can we not have a default? The default should be "take no action" or "close this toolbar" which is what tapping in the content area gives you.
Flags: needinfo?(asa)
Assignee

Comment 3

6 years ago
Yes, we can have none of the buttons be default.
Reporter

Updated

6 years ago
Summary: Story – Pop-up blocker info app bar → Story - Pop-up blocker info app bar
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
Reporter

Updated

6 years ago
Priority: P2 → P3
Assignee

Updated

6 years ago
Depends on: 847620
Assignee: nobody → mbrubeck
Blocks: metrov1backlog
No longer blocks: metrov1planning
Priority: P3 → P2
QA Contact: jbecerra
Whiteboard: feature=story c=Info_app_bar u=metro_firefox_user p=0 → feature=story c=Info_app_bar u=metro_firefox_user p=5
Assignee

Updated

6 years ago
Depends on: 847984
Assignee

Updated

6 years ago
Depends on: 849271
Reporter

Updated

6 years ago
Depends on: 845348
Reporter

Updated

6 years ago
Duplicate of this bug: 845154
Assignee

Comment 5

6 years ago
This is done, unless we want to block in on the "NewUI" layout changes (bug 845348) which I think would be better treated as a design change separate from the functional stories.  Marking resolved because I believe the story as specified is complete.

QA Note:  For consistency with the rest of our UI, the button labels use "Title Capitalization" like in the mockups from bug 838211 (instead of "Sentence capitalization" like the strings in the story).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: feature=story c=Info_app_bar u=metro_firefox_user p=5 → feature=story c=Info_app_bar u=metro_firefox_user p=5 status=for_testing
Hey Matt, has Bug 845348 also blocks 845155 845156 849396.  Would you recommend removing those dependencies as well and treating this bug just as a separate design change?
Flags: needinfo?(mbrubeck)
Assignee

Comment 7

6 years ago
Yes, I think that would make sense -- I have work almost ready to land for those other stories, so I think we can close them all out, QA them, and handle bug 845348 as a "Change" story later when the NewUI work is ready to land.
Flags: needinfo?(mbrubeck)
Thanks for the update Matt.  Just need to temporarily reopen for adjustment in ScrumBug.  I will close soon after.

The other dependencies have been removed as you recommended.  Bug 845348 is not part of metro design work.
Status: RESOLVED → REOPENED
No longer depends on: 845348
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Blocks: metrov1it3
No longer blocks: metrov1backlog
Whiteboard: feature=story c=Info_app_bar u=metro_firefox_user p=5 status=for_testing → feature=story c=Info_app_bar u=metro_firefox_user p=5
Reporter

Comment 9

6 years ago
Attachment #703515 - Attachment is obsolete: true
Tested on 2013-03-12 on nightly built from http://hg.mozilla.org/mozilla-central/rev/7433bc4545c9
- The design elements of this story are verified.
- However, the behavior part of it is inconsistent:
1. Open http://www.popuptest.com/popup1.html and select "Never For This Site"
2. Reload the page.

Expected: I should not see the popups nor the notification bar.

Actual: Most times the notification bar comes up.

- Filing bug 850383 for the ability to reset the "Always For This Site" which in this case can be very annoying.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Hey Juan.  This story stays as resolved and then we file a separate Defect Story which links to it.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Filed bug 850398 for the other problem described in comment #10.
Status: RESOLVED → VERIFIED
Depends on: 867495
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130707 Firefox/25.0
Build ID: 20130707031138

WFM for iteration-9
Tested on Windows 8.1 preview using latest nightly build from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-07-03-11-38-mozilla-central/
I used same steps given in user story.
I am getting expected result.
User Agent:Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:25.0) Gecko/20130724 Firefox/25.0
Build ID: 20130724030204

WFM.

Tested on Windows 8.1 preview for iteration 10 using latest nightly from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-24-03-02-04-mozilla-central/

I followed user story and got expected result.
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130808030205
Built from http://hg.mozilla.org/mozilla-central/rev/fd4cf30428b0

WFM
Tested on windows 8 using latest nightly  for iteration-11. Followed steps provided in user story and got expected result.
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130826074752
Built from http://hg.mozilla.org/mozilla-central/rev/14b1e8c2957e

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in user story and got expected result.
OS: Windows 8 Metro → Windows 8.1

Updated

5 months ago
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.