bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[OPEN_][Call setting]call forwarding icon in status bar does not disappear when remove SIM card.(617001982823)

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: Firefox_Mozilla, Assigned: jaoo)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18+ verified, b2g18-v1.0.1 verified)

Details

(Whiteboard: [MZ])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Steps to reproduce:
1.go into settings-call settings;
2.turn on unconditional call forwarding;
3.power off and remove sim card;
4.power on again.
5.go into call settings;

Expected results:
1.call forwarding is turned on successful. It has the icon in status bar in step2;
2.the call forwarding icon disappears in step4.
3.call settings can not be operated when sim card removed;

Actual results:
1.when sim card is removed, the call forwarding icon also appears in status bar;
2.call waiting also can be opreated when sim card removed.

Comment 1

6 years ago
I think we should disable the trigger or unable to select the call forwarding if no SIM card in the phone. Need info from UX

Updated

6 years ago
Flags: needinfo?(jcarpenter)
Arthur, i recalled that you handled call forwarding settings bug earlier. mind taking a first look? thanks
Assignee: nobody → arthur.chen
When users enters the call settings page, maybe we can display an error message (using the shared confirm dialog) informing them the absent of SIM card and then disable all of the menu items.
(Reporter)

Updated

6 years ago
OS: Windows XP → Gonk (Firefox OS)
Hardware: x86 → ARM
Group: partner-confidential → mozilla-corporation-confidential
Group: mozilla-corporation-confidential

Updated

6 years ago
Whiteboard: [MZ]
Sorry for the delay in responding. I'm having trouble determining the right approach here because the implementation is so different from Larissa's original specs. Adding Kaze for needinfo on when that change happened, and if it was intentional. 

(In reply to Arthur Chen [:arthurcc] from comment #3)
> When users enters the call settings page, maybe we can display an error
> message (using the shared confirm dialog) informing them the absent of SIM
> card and then disable all of the menu items.

I suggest we: 

* Set the the Call waiting button OFF 
* Make it un-selectable
* Add a line of text beneath saying "No SIM card"
* Gray out all the items under "Call forwarding" and prevent them from being selected.

Does that sound correct?

I should note that I am already seeing some of this behavior in my current build.
Flags: needinfo?(jcarpenter)
Flags: needinfo?(kaze)
leo? as this is confusing for users
blocking-b2g: --- → leo?
Created attachment 718840 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/8343

Jose, could you help review this change? It made the following changes:
- Check the sim card state when displaying the call forwarding icon.
- Disable the list items when the sim card is not available. 
Thanks!
Attachment #718840 - Flags: review?(josea.olivera)
(Assignee)

Updated

6 years ago
Blocks: 824801
Very unlikely that user would not realize they have sim card missing, and mistake it because CF icon is showing. Not blocking, but tracking+.
blocking-b2g: leo? → leo+
tracking-b2g18: --- → +
Jose, thank you for reviewing. Changes I've made to address your comments are as follows:
- Initialize the icon state only once when the card state turns to ready and the airplane mode is off
- Disable all menu items in the call settings panel when the card state is not 'ready'. Enable all menu items and query the call forwarding options when it turns to 'ready'. 
- Update the state of the call settings menu in the main panel when the airplane mode changes.

Detail please refer to the pull request, thanks!
After had a discussion with Jose, the way of displaying the icon is as follows:

- If the user enables CF and enable airplane mode the icon should appear.
- If the user enables CF and enables airplane mode and reboot the phone the icon should not appear.
- If the user enable CF and enable airplane mode and reboot with a different ICC card the icon should not appear.
- If the user disable airplane the CF icon should appear if the user check the status in the settings app.
- If the user switches sim cards and airplane mode is disabled, the icon should reflect the correct setting of the SIM card in use.
The patch is almost ready. Waiting for bug 837755 and bug 836257 get uplifted then we can test the patch on v1-train.
(In reply to Arthur Chen [:arthurcc] from comment #10)
> The patch is almost ready. Waiting for bug 837755 and bug 836257 get
> uplifted then we can test the patch on v1-train.

Can we land on master and close the bug first? Looks like bug 837755 and bug 836257 has landed on master already.
OK, I will land on master first.
Jose, I've check the code use the latest m-c and it works well. Behaviors in comment 9 are realized in the following rules:

 - CF setting is cached in async storage along with the icc id while setting.
 - When reboot, the appearance of the icon is determined by the cached CF setting until the icc id is available. (There is a chance that the cached CF setting becomes invalid if an user change the CF setting on another phone)
 - When entering the CF setting panel, the cached CF setting is updated based on the initial query. The appearance of the icon is also updated.

Could you help review the change with m-c? Then we can land it on master first. Thanks!
Comment on attachment 718840 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/8343

Good job. See comments on github. I'd like to see the PR again once you address the comments. Thanks.
Attachment #718840 - Flags: feedback+
(Assignee)

Updated

5 years ago
Attachment #718840 - Flags: review?(josea.olivera) → review-
Comment on attachment 718840 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/8343

Jose, your comments have been addressed. Could you help review it again? Thank you.
Attachment #718840 - Flags: review- → review?(josea.olivera)
Comment on attachment 718840 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/8343

This is almost ready, comments on PR. Thanks!
Attachment #718840 - Flags: review?(josea.olivera)
Comment on attachment 718840 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/8343

Jose, the implementation of trying to cache the CF state in settings app was so wrong. I've rewritten it. Details please check the PR. Thanks!
Attachment #718840 - Flags: review?(josea.olivera)
Created attachment 728297 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/8767

Stealing bug. Arthur, you have already reviewed it but this is the proper way. r?
Assignee: arthur.chen → josea.olivera
Attachment #718840 - Attachment is obsolete: true
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #718840 - Flags: review?(josea.olivera)
Attachment #728297 - Flags: review?(arthur.chen)
Attachment #728297 - Flags: review?(arthur.chen) → review+
https://github.com/mozilla-b2g/gaia/commit/cece889827f81fd8ec33cc50e0b9cedbefb4fc85
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted commit cece889827f81fd8ec33cc50e0b9cedbefb4fc85 as:
v1-train: 5bf647a01ce23cb9e62d74024010b602ab462a60
status-b2g18: --- → fixed
(Assignee)

Updated

5 years ago
Blocks: 857691
Noming for tef+, it blocks bug 857691.
(Assignee)

Updated

5 years ago
blocking-b2g: leo+ → tef?
Note: Useful information to consider for landing this bug.

This bug depends on bugs 836257 and 837755. The thing is as follow:

Bug 836257 was already uplifted to both v1-train and v1.0.1 gaia branches. Nothing to do. 
Bug 837755 must land before this one in mozilla-b2g18_v1.0.1 (already in mozilla-b2g18) release repo.

I'll request tef+ flag for bug 837755 and all its dependencies.

Updated

5 years ago
blocking-b2g: tef? → tef+
status-b2g18-v1.0.1: --- → affected
This bug still conflicts even with bug 827282  uplifted. Can you supply a patch that will apply?
Flags: needinfo?(josea.olivera)
Before uplifting this bug to v1.0.1 gaia branch bug 822522 and bug 837755 must uplift to mozilla-b2g_v1_0_1 release repo.

I'll uplift this bug once the platform dependencies reach the mozilla-b2g_v1_0_1 release repo. James, I'll contact you in case of I need help. Thanks a lot for your support in previous upliftings.
Flags: needinfo?(josea.olivera)
v1.0.1: dd77838c814c34e96cfafebac6886706261d0c71
(Assignee)

Updated

5 years ago
status-b2g18-v1.0.1: affected → fixed

Comment 26

5 years ago
On Unagi
Flags: needinfo?

Comment 27

5 years ago
On Unagi with the following: 

Environmental  Variables:
Unagi Build ID: 20130506070204
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/00c554abfc17
Gaia: 9377636cee5ac55b9f1d68f598afc7aadfbb2b00

The Call Waiting toggle switch can be turned off and on, but the "Cancel" and "set" buttons did nothing. This was with the SIM removed.

Is this considered part of the bug?

See attached screen shot.
Flags: needinfo?

Comment 28

5 years ago
Created attachment 746061 [details]
Call Waiting button accessible even without SIM card.
Flags: needinfo?
(In reply to mlevin from comment #28)
> Created attachment 746061 [details]
> Call Waiting button accessible even without SIM card.

This issue was not part of this bug. Call settings are not accessible in case of airplane mode. IHMO that should also happen in case of SIM card absent. Filling a bug for it.
Flags: needinfo?

Comment 30

5 years ago
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #29)
> (In reply to mlevin from comment #28)
> > Created attachment 746061 [details]
> > Call Waiting button accessible even without SIM card.
> 
> This issue was not part of this bug. Call settings are not accessible in
> case of airplane mode. IHMO that should also happen in case of SIM card
> absent. Filling a bug for it.

Verified fixed that the call forwarding settings can not be operated when SIM card is removed. Also verified that the call forwarding icon does not appear in the status bar when the SIM card is removed.

Tested on:

Environmental  Variables:
Unagi Build ID: 20130507070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/884ad1bbe24e
Gaia: 1bac83700810f27e00a937e34e7c865da02e0215

and on:

Environmental  Variables:
Inari Build ID: 20130507070205
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/7e9e10889942
Gaia: 29f5faf992aa2bacf6a9d500494093edd9472c69

NOTE:
The Call Waiting setting can be accessed and the toggle switch can be turned off and on, but the "Cancel" and "set" buttons do nothing. This was with the SIM removed. This is not part of this bug per comment 29.
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
status-b2g18-v1.0.1: fixed → verified
Flags: needinfo?(kaze)
You need to log in before you can comment on or make changes to this bug.