Closed Bug 836461 (bedrock-thunderbird) Opened 7 years ago Closed 4 years ago

Finish moving the rest of Thunderbird pages to Bedrock

Categories

(www.mozilla.org Graveyard :: Thunderbird, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sancus, Assigned: kohei)

References

()

Details

(Keywords: meta)

This bug is to track the various tasks involved in moving Thunderbird pages from PHP to Bedrock.
Summary: [tracking] move major Thunderbird pages to bedrock → (bedrock-thunderbird) [bedrock][tracking] l10n improvements on bedrockmove major Thunderbird pages to bedrock
OS: Windows 7 → All
Hardware: x86_64 → All
Assignee: nobody → sancus
Summary: (bedrock-thunderbird) [bedrock][tracking] l10n improvements on bedrockmove major Thunderbird pages to bedrock → (bedrock-thunderbird) [bedrock][tracking] move major Thunderbird pages to bedrock
Depends on: 836462
Alias: bedrock-thunderbird
No longer depends on: 836462
Summary: (bedrock-thunderbird) [bedrock][tracking] move major Thunderbird pages to bedrock → [bedrock][tracking] move major Thunderbird pages to bedrock
Depends on: 836462
Duplicate of this bug: 667932
Product: Websites → www.mozilla.org
Any status update on this?
So is there actually someone working on this / planning to work on this?
Flags: needinfo?(sancus)
Depends on: 1103396
I'm happy to work on this if :sancus is busy.
I think we can interpret the silence as "go ahead!"
Assignee: sancus → kohei.yoshino
Flags: needinfo?(sancus)
Okay, I'll start working on this next week.
Status: NEW → ASSIGNED
Blocks: 1123399
No longer blocks: 1123399
Depends on: 1123399
Depends on: 1124037
Depends on: 1124038
Depends on: 1124042
So Thunderbird 38 coming this May will be a major release with Lightning integration? Sounds great. I'll work on this before that.
(In reply to Kohei Yoshino [:kohei] from comment #7)
> So Thunderbird 38 coming this May will be a major release with Lightning
> integration? 

Unclear just yet that the Lightning bit will happen
Depends on: 1133266
Depends on: 1150649
Apologies for the delay of my work. Here's the current status of the Bedrock migration. There are 17 pages left. We really have to do this quickly because the SVN repo is going to shut down.
Blocks: 1186102
/all-beta.html	Download page	Need migration	?	Blocked by product-details
/channel/index.html	Download page	Need migration	?	Blocked by product-details
/all-earlybird.html (we don't have this page yet)	Download page	Need creation	No	Blocked by product-details
/features/index.html	Feature page	Need migration	Yes	Blocked by content & design
Keywords: meta
(bloody backspace)

Kohei, 

Are there any other bugs to be filed against what's in your spreadsheet?
Anything need to be picked up from https://gist.github.com/sgarrity/85a1b33f9d92f8d5b7ee ?

I'll try to solidify content for bug 1124037 start/what's new and bug 1124042 features
Flags: needinfo?(kohei.yoshino)
I think my spreadsheet and dependency bugs cover everything that needs migration, other pages like /about/press or /gs/ can be just archived or removed.
Flags: needinfo?(kohei.yoshino)
Depends on: 1196578
Depends on: 1199614
Depends on: 1199621
Almost done! The remaining pages are the channel page, Beta download page, and (new) Earlybird download page.
Summary: [bedrock][tracking] move major Thunderbird pages to bedrock → Finish moving the rest of Thunderbird pages to Bedrock
Depends on: 1204579
Actually all Thunderbird pages are now served from Bedrock. Bug 1204579 is just a clean-up so it doesn't block this. Mission complete!
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
No longer depends on: 1204579
Resolution: --- → FIXED
Thanks you so much Kohei for working on this. Much appreciated!
You are welcome :) I wish I could meet Thunderbird guys in Toronto at the end of this month, but I'm out of town until December. See you someday!
Indeed, great job Kohei!
Product: www.mozilla.org → www.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.