Closed Bug 837019 Opened 8 years ago Closed 8 years ago

update mozilla-central gonk snapshot

Categories

(Release Engineering :: General, defect, P2)

defect

Tracking

(firefox20 wontfix, firefox21 wontfix, firefox22 fixed, b2g18 wontfix, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

RESOLVED FIXED
B2G C4 (2jan on)
Tracking Status
firefox20 --- wontfix
firefox21 --- wontfix
firefox22 --- fixed
b2g18 --- wontfix
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix

People

(Reporter: hwine, Assigned: rail)

References

Details

(Whiteboard: [re-b2g])

Attachments

(2 files)

After the v1.0.0 manifests are updated in bug 837015 RelEng may need to generate an updated gonk snapshot.
Component: Release Engineering: Releases → Release Engineering: Automation (General)
QA Contact: bhearsum → catlee
Assignee: nobody → rail
Priority: -- → P2
Depends on: 836105
No longer depends on: 837015
I updated the master branch gonk snapshot and pushed to try https://tbpl.mozilla.org/?tree=Try&rev=c27a3210771b

Panda build should be fixed once bug 838261 lands to production.
Panda build failed:

07:04:52    ERROR -  make: *** No rule to make target `out/target/product/panda/obj/lib/libexif.so', needed by `out/target/product/panda/obj/SHARED_LIBRARIES/camera.omap4_intermediates/LINKED/camera.omap4.so'.  Stop.
@jhford, afaik you tried to reproduce the failure last Friday. Any chance to figure out the root clause?
Flags: needinfo?(jhford)
(In reply to Rail Aliiev [:rail] from comment #3)
> @jhford, afaik you tried to reproduce the failure last Friday. Any chance to
> figure out the root clause?

I was not able to reproduce.
Flags: needinfo?(jhford)
Depends on: 840170
per mtg w/rail, we need this for all branches, not just v1.0.0. Tweaking summary to match.
Summary: update gonk snapshot for v1.0.0 → update gonk snapshot
I've just pushed the v1.0.1 snapshot to try: https://tbpl.mozilla.org/?tree=Try&rev=39d33cb8ac6c
Depends on: 840835
Depends on: 840848
Depends on: 840863
I've just pushed another m-c snapshot to try: https://tbpl.mozilla.org/?tree=Try&rev=ea60f692fdc1
P3 since I'm blocked.
Priority: P2 → P3
Depends on: 843221
Blocks: 845000
Summary: update gonk snapshot → update mozilla-central gonk snapshot
Priority: P3 → P2
Attached patch m-c snapsotSplinter Review
woot, green build.
Attachment #718130 - Flags: review?(hwine)
I'll update otoro as a separate patch, because there is no way to push it to try.
Attached patch otoroSplinter Review
Attachment #718413 - Flags: review?(hwine)
Comment on attachment 718130 [details] [diff] [review]
m-c snapsot

Review of attachment 718130 [details] [diff] [review]:
-----------------------------------------------------------------

removed libraries intentional per bug 825142
Attachment #718130 - Flags: review?(hwine) → review+
Comment on attachment 718413 [details] [diff] [review]
otoro

Review of attachment 718413 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #718413 - Flags: review?(hwine) → review+
Comment on attachment 718413 [details] [diff] [review]
otoro

https://hg.mozilla.org/integration/mozilla-inbound/rev/6bca0d84ff84

I pushed otoro as a separate changeset because there is no way to test it in try.
Attachment #718413 - Flags: checked-in+
Target Milestone: --- → B2G C4 (2jan on)
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.