Closed Bug 837317 Opened 7 years ago Closed 7 years ago

[video] "[object Object] is now full screen" shows when playing a video

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:tef+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed, b2g18-v1.0.0 fixed)

VERIFIED FIXED
B2G C4 (2jan on)
blocking-b2g tef+
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- fixed

People

(Reporter: nhirata, Assigned: fabrice)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot
## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_0/rev/361d9359f4f3
Gaia   0abc95774d0bbdfe314fa588e09fc92cac3e6427
BuildID 20130130113326
Version 18.0
Unagi
  
## Repro :
1. launch video
2. play a video

## Expected :
full screen and shows video

## Actual :
full screen message of  "[object Object] is now full screen"

## Note :
1. it's probably related to bug 837282 and bug 798647?
2. not sure if it has to do with changes to the sdcard?  need to do further testing.
3. I get the feeling it's more system wide than just browser.
er. meant to say browser or video...
Recategorising this as a system bug. Its not specific to any one app.  But more likely it is a gecko or chrome bug.

In the past things like this have been something going wrong in a chrome object wrapper.  Cc'ing Fabrice because I think he's dealt with stuff like this before.

Thanks for filing this Naoki. I'd been seeing it today too, but hadn't filed a bug yet.
Component: Gaia::Video → Gaia::System
QA Contact: mozillamarcia.knous
In this bug and the two related bugs mentioned in the description, the [object Object] text is supposed to be the origin of an app.  So somewhere an object is being stringified incorrectly. I'd look for recent changes to the system app and recent changes to the b2g chrome.
Duplicate of this bug: 837837
Nom - perm prompts pretty much have to always indicate the origin of the request (security requirement). This is likely a regression.
blocking-b2g: --- → tef?
Keywords: regression
Duplicate of this bug: 837935
Attached patch patchSplinter Review
That's a regression from the BEP refactoring done in a performance related bug.
Assignee: nobody → fabrice
blocking-b2g: tef? → tef+
Attachment #709996 - Flags: review?(dale)
Blocks: 838672
Blocks: 838795
Comment on attachment 709996 [details] [diff] [review]
patch

Testing on device
Attachment #709996 - Flags: review?(dale) → review+
Smoketest, regression:
This is still repros in:

Unagi build#20130207070202
Gecko: cf1b9d27345e70daf242514733f848e76241ea1d

Gaia:   7e54ca673277b20b1d91d18477dc44d6ad226761
https://hg.mozilla.org/mozilla-central/rev/8ededceee28f
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
No longer appears in Unagi version 20130211070202.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.