Closed Bug 838008 Opened 8 years ago Closed 7 years ago

[E-Mail][User Story] E-Mail video attachment

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:-, b2g18+ affected, b2g-v1.2 fixed)

RESOLVED FIXED
1.2 FC (16sep)
blocking-b2g -
Tracking Status
b2g18 + affected
b2g-v1.2 --- fixed

People

(Reporter: pdol, Assigned: dkuo)

References

Details

(Keywords: feature, Whiteboard: [LOE:M])

Attachments

(1 file)

UCID: Email-144

User Story:
As a user, I want to be able to attach one or more video files (based on currently supported MIME types) to new emails or within replies to emails so that I can share content with my recipients.
Keywords: feature
Summary: [B2G][E-Mail][User Story] E-Mail video attachment → [E-Mail][User Story] E-Mail video attachment
This will need to be primarily addressed in the video app via its implementation of the 'pick' web activity; the bug filed for that is bug 836498.
Depends on: 836498
Andrew, I posted the flows to bug 836498 as well.
Whiteboard: u=user c=email s=v1.1-sprint-1
Whiteboard: u=user c=email s=v1.1-sprint-1 → u=user c=email s=v1.1-sprint-1 p=1
Whiteboard: u=user c=email s=v1.1-sprint-1 p=1 → u=rmacdonald@mozilla.com c=email s=v1.1-sprint-1 p=1
to dkuo as he's assigned to various email attachment work
Assignee: nobody → dkuo
Whiteboard: u=rmacdonald@mozilla.com c=email s=v1.1-sprint-1 p=1 → u=rmacdonald@mozilla.com c=email s=v1.1-sprint-1 p=1 [LOE:M]
Whiteboard: u=rmacdonald@mozilla.com c=email s=v1.1-sprint-1 p=1 [LOE:M] → [LOE:M]
Depends on: 844215
Clearing tracking-b2g18 flag from User Story bugs. This flag is for bugs that we would take fixes for in the 1.x branch. Feature work should be officially slotted into a release instead with leo+. If this story is intended for v1.1, please nominate for leo? blocking.
tracking-b2g18: + → ---
These flows have been updated and moved to dropbox...

https://www.dropbox.com/s/5giljes7ao9gyrg/email-attachments.pdf
Blocks: 849768
Hey, I think it's great that we can attach videos as well as other items.

Is there anything to account for error messages from server ie: account too full, file not found, etc?

(file not found in regards to attaching then hitting home deleting a picture and then coming back to finish the email)

Otherwise this stuff looks great!
Ni Naoki... That's a good point about the error case. In this case we'd need to display an error message when the user attempts to send the email. 

The dialog would look like this - https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/UX/Building_blocks/Confirmation#Without_a_title

and read

Missing attachment
The attached file is no longer available on your phone. Send the email anyway?
[Cancel][Send]

for multiple attachments, the dialog reads:

Missing attachments
One or more of the attached files are no longer available on your phone. Send the email anyway?
[Cancel][Send]

I'm out of the office the next few days but feel free to flag Casey if there are any urgent questions.
No longer blocks: 849768
Depends on: 849768
The link to the spec in Dropbox appears to have been broken:

https://www.dropbox.com/s/c9rrz0ymxvg0osw/email-attachments.pdf
needed to be +'d for 1.1 work since its a feature/user story
blocking-b2g: --- → leo?
-- Mass Edit -- 
These user stories are not P1, therefore not blockers to shipping. We will track for now and look into how to keep tabs on these going forward.
blocking-b2g: leo? → -
tracking-b2g18: --- → +
Hi All, we expect to have this feature in v1.2, thanks.
blocking-b2g: - → koi?
this issue has been reported again on FFOS 1.1 during the Latam Certification
blocking-b2g: koi? → -
Target Milestone: --- → 1.2 FC (16sep)
Andrew, looks like we need this landed in this week, it should be a simple patch that just add "video/*" to the activity filter, but do you think we need to restrict the total attachment size, just like what sms app does?
Flags: needinfo?(bugmail)
(In reply to Dominic Kuo [:dkuo] from comment #15)
> Andrew, looks like we need this landed in this week, it should be a simple
> patch that just add "video/*" to the activity filter, but do you think we
> need to restrict the total attachment size, just like what sms app does?

We already have size limiting logic in apps/email/js/cards/compose.js.  Search on MAX_ATTACHMENT_SIZE.

I think the 2 things we need to do are:

- Modify our activity filter in manifest.webapp as you say.

- Modify our pick activity triggered in compose.js so that it can match videos too.  We can't just drop the filter constraint because of the "webcontacts/*" types as documented at https://developer.mozilla.org/en-US/docs/WebAPI/Web_Activities#Firefox_OS_activities.  (I think using 'pick' for that is semantically different/problematic.  I argue it shouldn't work that way.)  But if we change that from 'image/*' to ['image/*', 'video/*'], it does the right thing.
Flags: needinfo?(bugmail)
Blocks: 836497
Blocks: 838007
Andrew,

This patch is pretty simple just like you said, and more, I found we should disable the pick activity for music2 because it does not support it(also open activity), and will not be listed when we try to pick attachment in email. Would you please review this? thanks.
Attachment #803614 - Flags: review?(bugmail)
Comment on attachment 803614 [details]
Enable picking video and audio files as attachment

r=asuth; please also modify apps/email/manifest.webapp so that our share activity also accepts those other wildcarded mime types.
Attachment #803614 - Flags: review?(bugmail) → review+
Thanks for catching that, Andrew! I have also modify the manifest.webapp in the patch.

Landed on master: 82ea2882cc6e03f867dc23d0fffefb0a6da92fe5
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Blocks: 836498
No longer depends on: 836498
Dylan Oliver deleted the linked story in Pivotal Tracker
Blocks: 905011
Duplicate of this bug: 823280
You need to log in before you can comment on or make changes to this bug.