rethink UI of /contribute/local maps pages

RESOLVED FIXED

Status

www.mozilla.org
Information Architecture & UX
P3
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jbertsch, Assigned: Habber)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=migration p=, URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Holly-

Could you please rethink the UI for these pages linked from http://www.mozilla.org/en-US/contribute/#location:

http://www.mozilla.org/contribute/local/northamerica.html
http://www.mozilla.org/contribute/local/latinamerica.html
http://www.mozilla.org/contribute/local/asia.html
http://www.mozilla.org/contribute/local/europe.html
http://www.mozilla.org/contribute/local/africamideast.html
http://www.mozilla.org/contribute/local/southpole.html

As you mentioned, maybe we can also then use these as part of the careers redesign.

Thx,
Jen
(Reporter)

Comment 1

5 years ago
Also, can we combine /local with /spaces?

http://www.mozilla.org/en-US/about/mozilla-spaces/
(Reporter)

Comment 2

5 years ago
Also http://www.mozilla.org/en-US/about/contact#map-mountain_view
(Reporter)

Updated

5 years ago
Duplicate of this bug: 849807
(Reporter)

Comment 4

5 years ago
Note:  check to make sure all office info is accurate.
(Reporter)

Updated

5 years ago
Duplicate of this bug: 850020
(Reporter)

Updated

5 years ago
Duplicate of this bug: 850376
(Reporter)

Comment 7

5 years ago
also consider https://bugzilla.mozilla.org/show_bug.cgi?id=850376
(Reporter)

Updated

5 years ago
Depends on: 856970
(Reporter)

Updated

5 years ago
Duplicate of this bug: 799741
Blocks: 808563

Updated

4 years ago
Component: Pages & Content → Information Architecture & UX
OS: Mac OS X → All
Hardware: x86 → All
I want to add some drivers to this bug.

1) Firefox 23 will introduce mixed-content-blocking by default. It's in Beta now; it will be released in August 2013. 
2) Mozilla.org is not currently forcing requests to use HTTPS, so mixed-content bugs are not an issue today. But bug 796109 is an attempt to force requests to use HTTPS, and it may be implemented anytime.
3) Maps pages (like contact.html) have mixed content on them. Bug 767767 is aimed at fixing the mixed content issue on contact.html by implementing Cloudmade maps. 
4) There is some talk in bug 767767 comment 11 about holding off on changes to the PHP page, since we're trying to stop maintaining PHP.

That's where this bug comes in. I highly recommend using Cloudmade maps as the maps provider, since they've been thoroughly vetted by various teams in the organization.
See Also: → bug 767767, bug 796109
See Also: → bug 888751
Blocks: 767767
(Assignee)

Comment 10

4 years ago
Created attachment 779300 [details]
First Draft Locations & Spaces Wirefraes

I've made a first pass at wireframes, but they are in progress. 

You can also find my notes, use cases, notes about what capabilities we'd need from Box Maps, etc in this folder on google drive: https://drive.google.com/a/mozilla.com/folderview?id=0B0MU8m1rqpdUMkM5TWcyLUo0elU&usp=sharing
(please request access)

In the wires I still need to address the page footer, have more consistency in interaction between contact types and page states. We also need to remember to add press links and remove spaces/locations that don't exist yet.

Comment 11

4 years ago
Holly...considering that Offices and Spaces are basically the same, would it be a good idea to consolidate both maps?

Actually...I think that Debbie/Jim always talk about Mozilla Offices as Mozilla Spaces...in other words, Mozilla Offices don't exist...they are only Spaces.

The rest looks killer!
(Reporter)

Comment 12

4 years ago
Ibai - the only exception might be Boston and NYC - which have co-working spaces that we would want job seekers to know about but don't have community space within the co-working space.  Aimee - what do you think?
(Assignee)

Comment 13

4 years ago
I'm all for combining and simplifying if that is possible. 

There is a lot of description text about spaces that would be nice to keep near this map instead of recreating the map on an additional page like we do now. We want to try to get rid of redundant pages. Can this content be shortened? https://www.mozilla.org/en-US/about/mozilla-spaces/


If the only case is: an office with full-time employees exists that also has a community/co-working space, then I think we can have them appear on the same map. However, in this case, the contact info for the spaces would be appearing in the same context as the office for full-time employees. This email may then get a lot of inquiries that would not relate to the community space. Keeping the purposes in separate tabs makes them very clear and easily distinguishable. I'm just noting this so that if we combine the tabs, we are very clear about the purpose of a community space vs. employee office.

Will there ever be a community/co-working space that has no full-time employees? (Boston, Taipei?)
Blocks: 897082

Comment 14

4 years ago
(In reply to Holly Habstritt [:Habber] from comment #13)
> Will there ever be a community/co-working space that has no full-time
> employees? (Boston, Taipei?)

Potentially.  There has been interested in partnering with hacker spaces to create a space for Mozillians in areas with a lot of community members but no office and that could serve volunteers and any staff near by.

On a separate note, I saw a reference to updating the Get Involved page with the information from the timeavailable.html page.  That's a legacy page that the community builders aren't supporting now, so we can remove and redirect to the main /contribute page.

Comment 15

4 years ago
One other note about the local communities wireframes -- I don't think we need to move over the idea of promos from the current version of the pages.

That was an idea we played with originally, but there seems to be more interest in keeping the contribute information general and not frequently updated so it's easier for localizers.  I'm fine with removing them.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 874683
Hi All, 

Adding in a few comments in prep for our meeting today. 

In general this looks amazing! A few notes: 

We definitely call them Mozilla Spaces in leiu of Offices. As we are in the process of rolling out the second phase of Moz spaces - we are starting to note Home Spaces and what will become more Organic Spaces (similar to what Boswell referenced above).  I'm curious what's possible in this new design to help visually display the differences. 

Also - we have more content about Mozilla spaces, that we'd like to share. I'm curious if there is room for us to build on that a bit. The guidelines we have published on wiki pages really need to get moved onto the main page. We have also gathered several creative assets to start to capture what life in our spaces looks like. I've recently been working with Creative on the career site and how we will leverage the Mozspaces information as part of that career site refresh. 

They had asked me to file a creative bug for this - but I've held off until we have this meeting as I want to make sure we are all working form the same page.  Would love to chat more about this in our discussion today as well. 

Looking forward to it! 
Amie

Updated

4 years ago
Blocks: 885896
(Assignee)

Comment 18

4 years ago
Created attachment 795975 [details]
26AUG13_Locationsandspaces.pdf

Updated wires in response to feedback from David, Amie, and Ibai
Attachment #779300 - Attachment is obsolete: true
https://www-demo3.allizom.org/en-US/contact/ has the new UI for the contacts page. Marking this a resolved
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.