Integrated PDF-Viewer in v19 creates new Tabs in a endless loop

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
6 years ago
6 months ago

People

(Reporter: klaus.haller, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-integration] [testday-20140227] )

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 715924 [details]
BUG_Firefox_v19_PDF-Viewer.pdf

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

I tested the new integrated PDF-Viewer in v19 under Win7/64/Prof with a standard URI of a PDF-Report in a Web-Application. It worked well, as long I did not select the checkbox "Für Dateien dieses Typs immer diese Aktion ausführen" in the attached screenshot (see Part 1 in BUG_Firefox_v19_PDF-Viewer.pdf).



Actual results:

When I selected this checkbox, i Firefox_v19 created new Tabs in a endless loop until I closed whole Window. See attached screenshot (see Part 2 in BUG_Firefox_v19_PDF-Viewer.pdf).


Expected results:

Firefox should present only one new Tab inlcuding the selected PDF-Report.
(Reporter)

Updated

6 years ago
Severity: normal → critical
Component: Untriaged → PDF Viewer

Updated

6 years ago
Severity: critical → normal

Comment 2

6 years ago
I open pdf Mozilla 19 and opened new tab and exit! (flash in screen for tab)

Updated

6 years ago
Priority: -- → P3
Whiteboard: [pdfjs-c-integration]
Klaus, is the issue still reproducible in latest Firefox versions? Thank you
Flags: needinfo?(klaus.haller)
Marking as RWFM, please reopen the issue if it is still reproducible on latest builds, after checking the link from Comment 1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 5

5 years ago
Same problem here. [Manjaro 0.8.9 - Firefox 28.0 Beta 6]
When I have assigned Firefox as predetermined pdf viewer and I have opened a pdf file a endless loop of tabs has appeared

Build: 	20140224220227

[testday-20140227]
Re-open based on comment 5, thanks Yunito!
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(klaus.haller)
Resolution: WORKSFORME → ---

Comment 7

5 years ago
I cannot reproduce this bug using Windows XP and Firefox 28 Beta 6, build: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0
Whiteboard: [pdfjs-c-integration] → [pdfjs-c-integration] [testday-20140227]
Resolving since comment 5 is for Linux and per discussion at http://irclog.gr/#show/irc.mozilla.org/testday/45721 . The steps below has no relation to the PDF viewer and indicate bad software configuration:

1. Open Edit->Preferences-Applications
2. Set "Web Feed" to "use other..." then "/usr/bin/firefox"
3. Open "http://www.npr.org/rss/rss.php?id=1001"
Status: NEW → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME

Comment 9

4 years ago
I have the same issue with the newest version on Windows 7: 
Go to the URL:
http://www.ligne-roset.com/Content/Resources/en-GB/pdf/General_Guide_for_Upholsery.pdf

This causes that Firefox keeps opening hundreds of empty tabs with the URL:
C:/Users/thh/AppData/Local/Temp/General_Guide_for_Upholsery-1.pdf

Please do not mark this bug as RESOLVED! It is anything but.
ThomasH, please to configure PDF Document to use "Preview in Firefox" in the Preferences->Applications. Otherwise your configuration is invalid and not a subject to this bug.

Updated

4 years ago
See Also: → bug 768788

Updated

3 years ago
Duplicate of this bug: 1223641

Updated

2 years ago
Duplicate of this bug: 1266367

Updated

6 months ago
Duplicate of this bug: 1417668
You need to log in before you can comment on or make changes to this bug.