Blocklist WhiteSmoke B add-on

RESOLVED FIXED

Status

()

RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: kmag, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #812303 +++

Now being installed with a new ID, as "WhiteSmoke B" by c|net installers.

Let's block this ASAP since they've already been warned. Twice.

ID: {f0e59437-6148-4a98-b0a6-60d557ef57f4}
Blocked: https://addons.mozilla.org/en-US/firefox/blocked/i304
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 2

6 years ago
Hi Kris,

My name is Asaf and I am head of marketing at WhiteSmoke.
We made all the needed changes with our toolbar and would like to request you to white-list our toolbar.
We at WS working hard to provide added value to our users and making sure to present proper disclosure to our users about the uninstall and revert search settings of our toolbar. 
Please let me know if we need to do any other change and we will do it ASAP.

Thanks
Asaf
Hello Asaf,

The issues with the toolbar are explained in bug 812303. Distributing it again with a different ID doesn't help, either. We need you to create a new version of your add-on and installer that complies with our guidelines, and send it to us for review.
(Reporter)

Comment 4

6 years ago
Asaf,

All three of your toolbar add-ons that I've come across have been silently installed, bypassing about:newaddon, which, as we've already warned you, is explicitly forbidden. We also have explicit rules against using multiple IDs for the same add-on, as layed out in our Add-on Guidelines: https://developer.mozilla.org/en-US/docs/Addons/Add-on_guidelines

Comment 5

6 years ago
Hi Jorge, Kris,

Thank you for your fast response.
We are value our users and doing everything to be transparent with our users. 

The issue that was explained in bug 812303 was solved and now user should enable the toolbar after the install (we never install the toolbar silently, user always must accept to install the toolbar by click "accept" in our offer screen).
We also fixed the issue related to revert the search settings of the user's browser after the uninstall. 

Using different IDs of the toolbar done following internal needs of the marketing team and not to by pass your blocks. 

You can test the most updated version of the toolbar from here: 

http://whitesmokeb.ourtoolbar.com/?Marketingchannelname=controlpanel_editTB&utm=controlpanel

Thanks
Asaf
Asaf, I just tested this new version and here's what I found:

* You don't restore the homepage after the add-on is removed. This needs to be included, just like the search settings changes.
* The settings changes happen independently from the add-on. We need them to be included as part of the add-on, so that users can choose not to install any of it, and other Firefox profiles aren't affected.

Finally, it looks like the blocklist dialog isn't showing up correctly when your add-on is installed. This is possibly a Firefox bug because of the combination of the add-on being blocked and the opt-in dialog showing up. Blair, do you know if this is the case?
Flags: needinfo?(bmcbride)
(In reply to Jorge Villalobos [:jorgev] from comment #6)
> Finally, it looks like the blocklist dialog isn't showing up correctly when
> your add-on is installed. This is possibly a Firefox bug because of the
> combination of the add-on being blocked and the opt-in dialog showing up.
> Blair, do you know if this is the case?

Never mind this bit. We already confirmed it and filed bug 853584.
Flags: needinfo?(bmcbride)

Comment 8

6 years ago
Hi again Jorge, to my knowledge and according to our tests, the homepage revert function is working. Can you send me the specific toolbar name or ID so I can double check? Barring any bugs, which I don’t think exist, this would have to be due to not testing on a clean machine. Let’s rule our bugs – please send me the ID. Regarding the second issue, as it is a new request, I will have to look into that.
Asaf, I used the link you posted on comment #5, on a clean machine.

Comment 10

6 years ago
Jorge, checked internally and we tested many times the homepage revert function. According to our tests it is working fine.
Please make sure you are using the correct toolbar that located here: 

http://whitesmokeb.ourtoolbar.com/?Marketingchannelname=controlpanel_editTB&utm=controlpanel

If it is still does not works for you please describe the test scenario. 

Thanks
Asaf
(Reporter)

Comment 11

6 years ago
I agree that the homepage and search settings are reverted as expected. However, they are still changed before users accept your add-on installation, which still needs to be addressed.
(Reporter)

Updated

5 years ago
Blocks: 949558
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.