Update pdf.js to version 0.7.337

RESOLVED FIXED in Firefox 22

Status

()

Firefox
PDF Viewer
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: RyanVM, Assigned: RyanVM)

Tracking

Trunk
Firefox 22
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #842087 +++

Changes since the last update:
#2734 Hide header/footer by default when printing from Firefox. See Bug 743252
#2735 Translated chrome.properties to Polish
#2743 Update README.md
#2741 viewer.properties - Polish lang : English file -> Polish and translated new values
#2732 Remove the test of experimental properties in workers
#2731 Add icons to the Chrome extension
#2705 More even way of zooming
#2779 Fixes to findbar CSS.
#2676 Add 'pagemode' URL parameter
#2785 Add a dummy byte at end of the CFF table to satisfy sanitizer
#2773 Makes navigation keys work on document load
#2794 JBIG2: Fixes template 1 for decoding
#2782 Fixes symbols positioning in JBIG2
#2686 Implement vertical writing
#2789 Fixes getString
#2805 Don't hide the download/print buttons when view is small.
#2781 Ignore empty strings for text selection
#2821 Add "cursor: text;" to textLayer div CSS.
#2823 Add myself to AUTHORS file
#2786 JBIG2: finds end of a segment when length is not specified
#2832 Fix TypedArrays on IE9
#2822 Spacing fixes in CSS.
#2838 Add Support for big5 encoding.
#2712 Make PDF links work in fullscreen mode
#2836 Fix handling of inline annotation dictionaries
#2826 Implement "83pv" CMap and fix CIDFontType0 handling
#2816 Resize the zoom box width to fit the content - fix embedding
#2809 Fix text selection for oddly-spaced TJ commands (Issue #2808)
#2844 Fix spacing calculation of TJ operator
#2848 CSS fixes to the sidebar
#2839 Hack to support automatic printing from pdf javascript.
#2858 Fix decrypting of arrays
#2862 Update finnish localization
#2868 Fixes NameTree reading
#2865 Implement "90pv" CMap
#2866 Convert cid to Unicode when rebuilding Type 2 CID fonts encoded with non...
#2877 Pass commonObjs to TilingPattern constructor
#2875 Convert CID fonts using "ToUnicode" CMap if available
#2874 Replacing page shadow with image; removing some prefixed styles
#2879 Skip FontName vs. BaseFont check for Type 3 fonts
#2872 Fix handling of [page /XYZ null null null] destinations.
#2880 Takes top border width in account (cont #2874)
#2861 Add save as support for Firefox.
#2818 Seac support for Windows
(Assignee)

Comment 1

5 years ago
Created attachment 721979 [details] [diff] [review]
Update pdf.js to version 0.7.331
Assignee: nobody → ryanvm
Attachment #721979 - Flags: review?(ydelendik)

Updated

5 years ago
Blocks: 848866

Updated

5 years ago
Blocks: 845783
Comment on attachment 721979 [details] [diff] [review]
Update pdf.js to version 0.7.331

Review of attachment 721979 [details] [diff] [review]:
-----------------------------------------------------------------

browser/extensions/pdfjs/content/web/images/shadow.png is missing
Attachment #721979 - Flags: review?(ydelendik) → review-
(Assignee)

Comment 3

5 years ago
Forgot to hg addremove :(. New patch coming...
(Assignee)

Comment 4

5 years ago
Updating to 0.7.337 now.

New fixes from comment 0:
#2901 Updates shell.js to v0.1.2
#2905 Takes clientTop in account in getVisibleElements
#2910 Make sure IE9 get integers for rgb
Summary: Update pdf.js to version 0.7.331 → Update pdf.js to version 0.7.337
(Assignee)

Comment 5

5 years ago
Created attachment 722880 [details] [diff] [review]
Update pdf.js to version 0.7.337
Attachment #721979 - Attachment is obsolete: true
Attachment #722880 - Flags: review?(ydelendik)
Comment on attachment 722880 [details] [diff] [review]
Update pdf.js to version 0.7.337

Review of attachment 722880 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good
Attachment #722880 - Flags: review?(ydelendik) → review+
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/mozilla-central/rev/8c5d7b67d20d
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Seems like this also fixed my bug (bug 818055) \o/
Duplicate of this bug: 818055

Updated

5 years ago
Blocks: 849903
(Assignee)

Updated

5 years ago
Blocks: 843342
Blocks: 770409
(Assignee)

Updated

5 years ago
Blocks: 852981

Updated

5 years ago
Depends on: 863159
Blocks: 833676

Updated

5 years ago
Depends on: 864619
Blocks: 862313
(Assignee)

Updated

5 years ago
No longer depends on: 863159
(Assignee)

Updated

5 years ago
Blocks: 836091

Updated

5 years ago
Blocks: 842916

Updated

5 years ago
Blocks: 843532

Updated

5 years ago
Blocks: 843653
You need to log in before you can comment on or make changes to this bug.