Ask the user when the last browser window is closed with ongoing downloads

RESOLVED FIXED in Firefox 26

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: kathampy, Unassigned)

Tracking

(Blocks 1 bug)

21 Branch
Firefox 26
x86_64
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20130312 Firefox/21.0
Build ID: 20130312042013

Steps to reproduce:

Start downloading a file and let it run only in the new download panel toolbar icon. Do not open the download manager window. Now close the Firefox Window.


Actual results:

The download stops without warning and Firefox exits.


Expected results:

There should have been a prompt confirming whether to stop the download. However the prompt does appear if the download window is docked as a tab in Private Browsing mode.
That's because you can't restart the download in PB mode. If you quit in a normal session, the download will continue once you restart.
Component: Untriaged → Downloads Panel
It's ignorant to assume that downloads can be resumed. If anything it should behave like Safari and leave just the downloads running. On Windows it could pop up the download manager window when the browser is closed.
Download resuming is not supported by all servers. If I start a download, I certainly expect that the download goes on and completes and is not terminated unless I specifically want to do that. If FF closes down then I'd assume that the DL has been completed or if not, FF would ask me what I want to do.

Also, please consider whether it would be possible to run every download in a separate process (or all downloads in one download process). Kind of annoying if a long non-resumable download dies when FF crashes. Not all users have 100Mb bandwidths...
I think it's worth brainstorming a bit on the behavior when closing and non resumable downloads are in-progress, confirming for that.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Even resumable downloads should NOT be interrupted. There are so many times when I close a browser window and forget about running downloads. Then I look for them 30 minutes later and realise they haven't even been running!
Duplicate of this bug: 861477
When there's a pending file download, if I close the last browsing window, Firefox should open the Library window (download section) to keep the download alive.
Internet Explorer uses the same approach.
At the very least this should be an option to have a prompt show up. This behavior is radically different to the old download experience, and not an improvement.
Duplicate of this bug: 864225
Duplicate of this bug: 863973
Summary: Closing window cancels downloads in new download panel. → Ask the user when the last browser window is closed with ongoing downloads
Duplicate of this bug: 868105
When one or more downloads are in progress, and the user closes the last Firefox tab or window, Firefox should warn the user that a download is in progress. Or the Downloads window should pop up to replace the last window being closed. Even keeping the process running in the background and adding a download icon to the notification area would be a better solution than what's happening right now...
This should be fixed by the new Downloads API implemented by dependencies of bug 825588.
Blocks: jsdownloads
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
thank you, I can confirm it works as expected in Nightly.
You need to log in before you can comment on or make changes to this bug.