Add more fields to Address book

NEW
Unassigned

Status

--
enhancement
18 years ago
7 years ago

People

(Reporter: alik, Unassigned)

Tracking

(Depends on: 2 bugs, Blocks: 3 bugs)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The following should be added to the addressbook:

1. Birthday field (already reported in 13595 on 1999-09-10)
If we already have a mozilla calander project in progress would that not 
benefit from this? Also, a birthday field has become a common feature in almost 
ALL addressbooks. Some clients event send users e-mail reminders that a 
birthday is coming up!

2. Add ICQ# and AIM ScreenName fields
The word for today is CONVERGENCE!.. If you add these fields tomorrow they can 
be used by some very someone working on a mozilla based P2P application using 
ICQ or AIM file transfers. And it is not long before we see AIM and ICQ in the 
sidebar!

3. Add atleast 2 more e-mail address fields!

Thanx!

Comment 1

18 years ago
*** Bug 85345 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: RFE: Add more fields to Address book → [RFE] Add more fields to Address book

Updated

17 years ago
QA Contact: fenella → nbaca

Comment 3

17 years ago
reassigning to cavin.
Assignee: chuang → cavin
Target Milestone: --- → Future

Comment 4

17 years ago
Regarding part 2:

I would be happier to see this happen in a common solution involving all IM
clients, rather than perpetuate specific solutions ad nauseum.

IIRC, Jabberzilla will communicate with the other systems in this way.  Are
there any plans to make Jabberzilla part of default distributions?
See also bug 142845.
*** Bug 150360 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
About adding more e-mail fields: see Bug 150360 where I have a few suggestions.

Comment 8

17 years ago
For multiple email addresses, how about the same approach bugzilla uses - a list
box with an add and a remove button?

Comment 9

17 years ago
Ian, you mean something similar to attachment 86997 [details] (of bug 150360). I would say
yes, this is definitely the approach that makes the most sense. However I would
suggest some interesting labels, at least for 2 fields: Home address and work
address.
(Reporter)

Comment 10

17 years ago
Hi All,

Since i am the one who started this bug.. i am gonna try to revive it too. 

PLEASE PLEASE PLEASE... make the address book better!.. You can take a look at
the windows/outlook address book and it has so many fields!!!

1. The birthday field is a MUST!
2. The IM nicks can be useful especially when AIM and ICQ are coming built in
with NS 7.

The customised fields are NOT suitable for this purpose. Since the information
entered in them cannot be used by any application!.  

I have installed the mozilla calendar and will try to convince guys over there
to have the birthdays integrated into the calendar.

rgds

(Reporter)

Comment 11

17 years ago

*** This bug has been marked as a duplicate of 13595 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
Sorry, this is not a dupe of bug 13595 (which is only about the birthdate
field). This one is more general and addresses not only birthdate field but also
IM fields and additional e-mail fields.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 13

17 years ago
*** Bug 13595 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
Many fields including birthday are already in the Addressbook, just not in the 
UI. Looking at abook.mab (not sure why that isn't rdf?) I see the fields:
  (80=ns:addrbk:db:row:scope:card:all)
  (81=ns:addrbk:db:row:scope:list:all)
  (82=ns:addrbk:db:row:scope:data:all)(83=FirstName)(84=LastName)
  (85=DisplayName)(86=NickName)(87=PrimaryEmail)
  (88=LowercasePrimaryEmail)(89=SecondEmail)(8A=PreferMailFormat)
  (8B=WorkPhone)(8C=HomePhone)(8D=FaxNumber)(8E=PagerNumber)
  (8F=CellularNumber)(90=HomeAddress)(91=HomeAddress2)(92=HomeCity)
  (93=HomeState)(94=HomeZipCode)(95=HomeCountry)(96=WorkAddress)
  (97=WorkAddress2)(98=WorkCity)(99=WorkState)(9A=WorkZipCode)
  (9B=WorkCountry)(9C=JobTitle)(9D=Department)(9E=Company)(9F=WebPage1)
  (A0=WebPage2)(A1=BirthYear)(A2=BirthMonth)(A3=BirthDay)(A4=Custom1)
  (A5=Custom2)(A6=Custom3)(A7=Custom4)(A8=Notes)(A9=LastModifiedDate)
  (AA=RecordKey)(AB=AddrCharSet)(AC=LastRecordKey)
  (AD=ns:addrbk:db:table:kind:pab)(AE=ListName)(AF=ListNickName)
  (B0=ListDescription)(B1=ListTotalAddresses)(B2=LowercaseListName)>

These are also available when choosing Tools/Import/Address Book/Text file.

Comment 15

17 years ago
Additional Comment #13 From Erich 'Ricky' Iseli:
> Bug 13595 has been marked as a duplicate of this bug.

I think that marking Bug 13595 (add birthdate field in Adressbook) as a
duplicate of this bug (85344 - add more fields) is not legal:
Adding birthday field is clearly not dependent on adding AIM etc. fields.
Since there were 6 votes for 13595 and only 2 votes for this more comprehensive
bug, marking 13595 as a duplicate seems an unfair manipulation.

Comment 16

17 years ago
Paul Berendson, I see your point. Then I guess duping one of the other is not a
good idea. The problem is that 1 bug = 1 issue is not always that easy. One can
argue that "add more fields" is an issue, and one could say: add more e-mail
fields is an issue, add birthday field is another issue and so on. Therefore
marking this one as dependent from bug 13595, which makes much more sense, imho.
Sorry for the confusion.
Depends on: 13595
cavin is working on adding a bunch of new column to the ab, and and then after 
that, we'll be adding some UI for them.

Comment 18

16 years ago
Here are some fields that would be useful:
1. Categories (user-defined, multiple selections possible)
2. Spouse's Name
3. Anniversary (this should place an entry in Calendar with both spouses' names)
4. Childrens' Name(s)
5. Parents' Name(s)
6. User's "Relationship" to person in AB (colleague, friend, daughter, etc.)
7. Which e-mail to use for "Scheduling" (drop-down list)
8. Confidential (Y/N) <-- only viewable with PW <-- profile PW needed
9. Track Activities (all calls & schedules with person are listed)
10. Button to "Create new Activity" (dropdown select: create schedule, call, ...)
11. Ability to "link" any entry/event with any other entry/event
12. Creating a new Activity should automatically create a "link".
13. "Custom 1-4" titles should be editable (and affects *all* AB entries)
14. Display 4 phone numbers, 2 e-mail addresses, and 1 webpage - but give each a
dropdown list where user can select from a longer list of types of entries (see
screenshot in my next post). This allows the user to:
(A) Select *which* entries are shown (e.g., 4 business phone #'s, or 2 business
and 2 home phone #'s, etc.) and 
(B) Select the *order* in which the entries are shown (A & B should be reflected
in the display and (leter) prining of AB entries).

Comment 19

16 years ago
Created attachment 95387 [details]
Screenshot showing selection of which Phone # to display (from long list)

As explained in my previous comment under Item 14.

Comment 20

16 years ago
Once this is done, we'll add a hook in the calendar
(http://www.mozilla.org/projects/calendar/) to display the birthday in the calendar.

Comment 21

16 years ago
Please make *all* dates, times and numbers in AB localized (i.e., mm.dd.yyyy and
16:45, and thousands separators: 1,000,000.00). ;)
accepting on behalf of caving.

I know he's got changes to add anniversary and birthday, and a few other fields.

Once the backend changes are reviewed and landed on the trunk, we'll start the 
UI to use them.

As far as the rest of the fields peter suggests, there are some we won't be 
adding.

> Once this is done, we'll add a hook in the calendar
> (http://www.mozilla.org/projects/calendar/) to display the birthday in the 
> calendar.

That will be slick.  Let's take that RFE to another bug.
Status: REOPENED → ASSIGNED

Comment 23

16 years ago
bug 151994 is open to track the calendar integration, marking this bug as
blocking that bug.
Blocks: 151994

Updated

16 years ago
Blocks: 58769

Comment 24

16 years ago
It would be pretty cool to provide latitude and longitude for each address. This
then easily allows linking to maping websites so you can easily click a 'get
map'. Problem being that geocoding actual addresses may work fine in the USA,
but doesn't work that well overseas. And as GPS units become more popular, I
believe it makes sense to integrate individual and organisation coordinates into
the addressbook. I'll leave this request under this umbrella bug, unless
suggested otherwise. Cheers Gav.

Updated

16 years ago
Blocks: 194784

Updated

16 years ago
Blocks: 194783

Updated

16 years ago
Blocks: 126267

Comment 25

15 years ago
PLEASE do something...it's so older this bug!

Comment 26

15 years ago
In addition to supporting the fields for birthdate, latitude & longitude, 
more email addresses and phone numbers, and anniversaries, I'd like to add 
a few wrinkles/requests:

Please split (geo) home address into mailing (PO Box) and residence addresses.
Note that these may have separate ZIP codes in the US (perhaps differing cities
and states in some instances). Alternate home addresses (seasonal residence) 
would be nice, too.

Please allow entry of a birthday (month and day of month), rather than a full
birthdate where the year of birth is unknown or omitted.

(Tongue encheeked) Does adding a single anniversary field add some i18n issues?
Can the address book back end model polygamy or polyamory?

Comment 27

15 years ago
adding bug 233209: "Add other fields to Address Book for other IM software"
Blocks: 233209

Comment 28

15 years ago
*** Bug 243308 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

14 years ago
Blocks: 118665
Assignee: cavin → nobody
Status: ASSIGNED → NEW
Component: Address Book → MailNews: Address Book
Product: Mozilla Application Suite → Core
QA Contact: nbaca → addressbook
Target Milestone: Future → ---
No longer blocks: 194784
Dropping RFE from summary, severity = enhancement is enough.
Summary: [RFE] Add more fields to Address book → Add more fields to Address book
No longer blocks: 58769

Updated

13 years ago
No longer blocks: 194783
Depends on: 194783

Comment 30

12 years ago
Over a year since the last update!

Why is this blocked on 194783?   The two seem only tangentially related.

Updated

11 years ago
Flags: blocking-thunderbird3?

Comment 31

11 years ago
I would like to be able to search and filter on the new fields.  There are some fields that are not searchable or filterable (including "Custom 1, custom 2, etc").  Having these be included in the column listing, and/or be otherwise fully functional, would greatly enhance its utility, allowing users to (for example) tag entries with functional codes for contacts that belong in more than one category (i.e. friends, musicians, relatives, children, plays they were in) and then be able to find all that fall into any category.

As it is I used the custom fields for this purpose, and now find I can't make any use of the data except by hand, which is unwieldy given the number of contacts.

Jose
Blocks: 398868

Comment 32

11 years ago
>>
The following should be added to the addressbook:
1. Birthday field (already reported in 13595 on 1999-09-10)
<<

A single birthday field is not very useful, as Email addresses do not map one-to-one to individual people.  Some addresses represent more than one person (husband and wife, for example) and for such addresses, the birthday field is useless (this is an issue I have with the Palm address book too).  A way should be devised to have it support multiple birthday dates, even if they are not distinguished between different "owners" of the Email address.  One possibility would be to let the birthday field be a comma separated list.

Jose

Comment 33

10 years ago
What about adding or changing how the spouse/children feature would even work.  Since we can not match them up with there own info why not have them link to a separate vCard.  
ie..  Click on <Add Spouse> -> Opens a new vCard so you can add his/her info.
From now on the Spouse section would be a link to the Spouses vCard.

Same thing for a possible <Add Child>.

This way all vCards would contain only info on the single person and links to other vCards.

Comment 34

10 years ago
>>
ie..  Click on <Add Spouse> -> Opens a new vCard so you can add his/her info.
From now on the Spouse section would be a link to the Spouses vCard.
<<

This would be cool if it were complete.  The new card should =have= a link to the originating card, and the originating card should link to the new one... but in addition, there are many kinds of links and if we do this right, it could be mongo useful.

Parents have several children.  Children have several parents.  Children have siblings (and half siblings).  Households have live-ins (sharing the same Email address but different personal info).  And it would be useful to link to cousins, friends, theater buddies, (theater buddies who are also friends...)...

SeaMonkey should be indifferent to the =kind= of link, but should let the user choose.

Add: [parent|child|spouse|friend|{type in other link}]
Reflexivity:  * full  o partial  o none
Shares:  [ ] address   [ ] city  [ ] state   [ ] Email   [ ] etc... (all fields)

To do this right, the database needs to be relational.  To do it halfway may lead to something that ultimately would not be used.

Also, making it relational would eliminate the "OtherEmail1, OtherEmail2, OtherEmail3, ran_out_of_slots" dilemma.

And while I'm at it (should this be a different bug/feature?)... it would be =real= nice if the address book entry could be made directional - that is, I could use it to screen for incoming Email (not spam) but it would not come up as a suggestion when typing a name in the TO box.  This is for people who only want to get mail at one address but send from several.  (I find this is very common)

Jose

(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
We're not going to block a release on a bug that doesn't have a clear definition of what it is trying to do.

Later today/tomorrow I will go through this bug and ensure we have separate bugs filed for all the ideas mentioned, and then close this bug down. That way we can ensure that all the individual ideas are tracked and we don't loose any.
Flags: blocking-thunderbird3? → blocking-thunderbird3-

Updated

10 years ago
No longer blocks: 126267
Depends on: 126267

Updated

9 years ago
Flags: blocking-thunderbird3-
No longer blocks: 151994
You need to log in before you can comment on or make changes to this bug.