Closed Bug 853893 Opened 8 years ago Closed 8 years ago

[Meta] Make workers to use same event and eventdispatcher implementations as the main thread

Categories

(Core :: DOM: Events, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: ehsan, Assigned: smaug)

References

Details

(Keywords: meta)

No description provided.
Blocks: 504553
Summary: Make it possible to dispatch events in workers → Make workers to use same event and eventdispatcher implementations as the main thread
Component: DOM: Events → DOM: Workers
Assignee: nobody → bugs
Component: DOM: Workers → DOM: Events
Duplicate of this bug: 887239
Depends on: 902481
Depends on: 862627
Depends on: 887241
Depends on: 903772
Summary: Make workers to use same event and eventdispatcher implementations as the main thread → [Meta] Make workers to use same event and eventdispatcher implementations as the main thread
Depends on: 910797, 910910
Depends on: 914334
No longer depends on: 862627
Depends on: 862627
No longer depends on: 914334
Depends on: 916373
Once bug 862627 is merged to m-c, this should be fixed.
EventListeners and EventHandlers should work, and Event object itself is available on workers
(but it can't be dispatched to old-style worker EventTargets. Worker specific EventTargets can handle only Worker Events, not thread agnostic Events).

EventTarget implementations should inherit nsDOMEventTargetHelper and there is an example
in Bug 862627.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Yay! Thanks everyone for fixing this and its blockers!
You need to log in before you can comment on or make changes to this bug.