Switch EventListener to WebIDL codegen

RESOLVED FIXED in mozilla27

Status

()

Core
DOM: Events
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: bz, Assigned: bz)

Tracking

(Depends on: 2 bugs)

unspecified
mozilla27
x86
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 4 obsolete attachments)

+++ This bug was initially created as a clone of Bug #835643 +++
Created attachment 738285 [details] [diff] [review]
Patch that I can land once all the dependencies are fixed
Depends on: 862629
Depends on: 874502
Created attachment 752315 [details] [diff] [review]
An additional bit to rip out now-unused code
Attachment #752315 - Flags: review?(bugs)
Created attachment 752808 [details] [diff] [review]
This should make the new Telephony bits happy
Attachment #752808 - Flags: review?(bugs)
Attachment #752315 - Flags: review?(bugs) → review+
Attachment #752808 - Flags: review?(bugs) → review+
Blocks: 887239

Updated

5 years ago
Duplicate of this bug: 896928
Blocks: 853893
No longer blocks: 887239
Blocks: 865916
Whiteboard: [Australis:P?][Australis:M?]
Whiteboard: [Australis:P?][Australis:M?]
No longer blocks: 865916
Created attachment 801190 [details] [diff] [review]
Main patch, merged to tip
Attachment #738285 - Attachment is obsolete: true
Created attachment 801191 [details] [diff] [review]
Cleanup, merged to tip
Attachment #752315 - Attachment is obsolete: true
Attachment #752808 - Attachment is obsolete: true
Depends on: 914434
Depends on: 914438
Depends on: 914444
Depends on: 914450
Depends on: 914748
No longer blocks: 853893
Depends on: 914985
Blocks: 853893
Depends on: 876277
Depends on: 916995
Try run with all dependencies except bug 840201 fixed: https://tbpl.mozilla.org/?tree=Try&rev=672313bc75e1
Depends on: 919717
https://tbpl.mozilla.org/?tree=Try&rev=d627866a8122
   https://hg.mozilla.org/integration/mozilla-inbound/rev/29b3256131f4
   https://hg.mozilla.org/integration/mozilla-inbound/rev/872d79fd1982

Halleluiah!
Flags: in-testsuite?
Target Milestone: --- → mozilla27
\o/
Created attachment 809130 [details] [diff] [review]
a test impl for workers

Since khuey had some problem using EventTarget on workers, here is a dummy
implementation. (Really dummmy - because of returning null GetParentObject,
EventReceiver on the main thread may work in a bit unusual way.)

Testcase is loading 
var retval = "FAIL"; var er = new EventReceiver(); er.addEventListener("PASS", function(e) {retval = e.type;}); er.dispatchEvent(new Event("PASS")); retval;
in http://mozilla.pettay.fi/workerconsole/
Created attachment 809146 [details] [diff] [review]
a simple thread agnostic EventTarget object

(this one behaves ok on main thread too, and is simpler)
Attachment #809130 - Attachment is obsolete: true
Happydance!!
https://hg.mozilla.org/mozilla-central/rev/29b3256131f4
https://hg.mozilla.org/mozilla-central/rev/872d79fd1982
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Depends on: 920436
Blocks: 921485
Depends on: 924905
Blocks: 409737
Depends on: 971650

Updated

3 years ago
Depends on: 1180525
You need to log in before you can comment on or make changes to this bug.