Bookmark select/cut/paste operation is sensitive to order of selection and reverses it

RESOLVED WORKSFORME

Status

P5
normal
RESOLVED WORKSFORME
18 years ago
6 years ago

People

(Reporter: doctor__j, Unassigned)

Tracking

Trunk
Future
x86
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

18 years ago
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1+) Gecko/20010612
BuildID:    2001061206

Reproducible: Always
Steps to Reproduce:
1. Open bookmark manager.
2. Create a list of bookmarks, say 1, 2, 3, 4, 5, up to 10.
3. Select bookmarks in a special order, say 2, 5, 3 and 7 (of course by
Ctrl-clicking) Note that the order of selection *DOES* matter.
4. Cut them and paste them back in some place.

Actual Results: Bookmarks are pasted in the order of 7, 3, 5 and 2.

Expected Results: Ignore order of selection and paste bookmarks in the order of
2, 3, 5, 7.

Comment 1

18 years ago
<thinking out loud>how does this interplay with respecting the sort order of the
container you're pasting into? - or do/should we ingore that too?
(Reporter)

Comment 2

18 years ago
Well, at least I think the paste order should remain as "2, 3, 5, 7" in Unsorted
View...  For other sorted views... haven't got an idea...
This is probably related to tree's 'selectedItems' array and how it's 
populated. Outliner may work differently, or it may not. Nevertheless, future. 
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 5

17 years ago
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Priority: -- → P5

Comment 6

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 7

17 years ago
*** Bug 124545 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
*** Bug 125592 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
*** Bug 131576 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Summary: Bookmark select/cut/paste operation is sensitive to order of selection → Bookmark select/cut/paste operation is sensitive to order of selection and reverses it

Comment 10

17 years ago
*** Bug 153531 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
*** Bug 154328 has been marked as a duplicate of this bug. ***

Updated

17 years ago
OS: Windows 98 → All

Comment 12

17 years ago
*** Bug 163211 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
taking
Assignee: ben → chanial
Depends on: 160019
"Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2b) Gecko/20021016"

What happens with DnD is:

*Select order does NOT matter :-)
*The global order of the selected items IS reversed: very annoying :-(

*Choosing 'Unsorted' [At first, I thought I could select it, now I can't anymore
:-(] or 'Sorted by Name' or 'Sorted by Location' views does not seem to make ANY
difference... (That may be a different bug !!?)
*I'm not familiar with the views: I guess that I am used to have it work as
"Unsorted" (== do it yourself);
 but my opinion about http://bugzilla.mozilla.org/show_bug.cgi?id=85469#c1 would
be to respect the selected view.


Same behaviour with CnP for folders. (CnP for bookmarks is reported broken in
this release.)


This bug may be a blocker for
http://bugzilla.mozilla.org/show_bug.cgi?id=84839#c5 !? (I have not try to check
this.)

Updated

16 years ago
Depends on: 167335
Regarding dependencies:

*I guess this bug depends on 160019, only to wait for the code "cleanup": the
subjects seem not otherwise related.

*<relf@os2.ru> just made this bug depend on 167335: this does not seem to be the
case based on subject only:
 *85496 is about order. (DnD or CnP)
 *167335 is about Cut and Paste. (only)
*I would rather see 167335 depends on 160019, if needed.

May be there are reasons which I don't know...  My 2 cents' worth.

Comment 16

16 years ago
There is nothing to do unless Paste (bug 167335) is fixed.

Comment 17

16 years ago
*** Bug 177987 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
*** Bug 178943 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
*** Bug 187134 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
I note that Bug 187134 has been marked as a duplicate of this one. But it is
about dragging bookmarks into a folder; is that the same as cutting and pasting?
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.3a) Gecko/20021212]

Like I said in comment 14 (v1.2b), the reverse order effect is still there.


Reply to comment 16:
*Bug 167335 seems fixed since 2002-11-2x.
*What is the next step for bug 85469 ? Wait for bug 160019 (currently targeted
to v1.5a) !?
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030401]

Bug seems fixed somehow:
DnD now maintains the initial order :-)

The fix may be included in bug 167335 and/or bug 160019 resolutions:
Could pch (= chanial(at)noos.fr) confirm this ?

NB: I assume that this applies to CnP too, but I can't check since 'Cut' seems
allways disabled (= greyed) in this release. See bug 200909.
Product: Browser → Seamonkey

Comment 24

13 years ago
Reassigning as per Bug #32644
Assignee: p_ch → nobody
QA Contact: claudius → bookmarks

Comment 25

6 years ago
WFM in trunk, pasted bookmarks sorted by name, closing
User agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120919003007
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.