Turn off --enable-metro on Aurora after uplift to Aurora

VERIFIED FIXED

Status

defect
--
major
VERIFIED FIXED
6 years ago
8 months ago

People

(Reporter: bajaj, Assigned: bajaj)

Tracking

22 Branch
All
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(firefox21+ verified, firefox22+ verified, firefox23+ verified, firefox24+ verified, firefox25+ verified, firefox26 wontfix, relnote-firefox 26+)

Details

(Whiteboard: [merge-day])

+++ This bug was initially created as a clone of Bug #841919 +++

Metro Firefox is currently enabled on the Nightly channel but is not yet ready for the Aurora audience.  We want to remove --enable-metro from the win32 mozconfigs on mozilla-aurora before Firefox 21 updates are published to the Aurora channel.
Assignee: nobody → bbajaj
This has been taken care during the merge today on win32/64 builds, check changeset below for more details .

http://hg.mozilla.org/releases/mozilla-aurora/rev/bc8a6b8e0280

Adding qawanted here to get similar verification as done earlier in : https://bugzilla.mozilla.org/show_bug.cgi?id=841919#c10
Keywords: qawanted, verifyme
Flags: needinfo?(jbecerra)
I'll check this as soon as we have Firefox Aurora 22 builds.
Flags: needinfo?(jbecerra)
Keywords: qawanted
QA Contact: anthony.s.hughes
Should these files have been modified too ?
 browser/config/mozconfigs/win32/nightly
 browser/config/mozconfigs/win64/nightly
(In reply to Nick Thomas [:nthomas] from comment #3)
> Should these files have been modified too ?
>  browser/config/mozconfigs/win32/nightly
>  browser/config/mozconfigs/win64/nightly

nope. We are supporting metro builds on nightly, but not on aurora yet.So these should be available for nightly audience hence no modifications needed
(In reply to bhavana bajaj [:bajaj] from comment #4)
> (In reply to Nick Thomas [:nthomas] from comment #3)
> > Should these files have been modified too ?
> >  browser/config/mozconfigs/win32/nightly
> >  browser/config/mozconfigs/win64/nightly
> 
> nope. We are supporting metro builds on nightly, but not on aurora yet.So
> these should be available for nightly audience hence no modifications needed

Ignore this comment, I just realized you meant "browser/config/mozconfigs/win64/nightly" these files for aurora, got tricked into the name here..I am checking now
(In reply to Nick Thomas [:nthomas] from comment #3)
> Should these files have been modified too ?
>  browser/config/mozconfigs/win32/nightly
>  browser/config/mozconfigs/win64/nightly

Have this covered now, thanks for catching this :nthomas :)

https://hg.mozilla.org/releases/mozilla-aurora/rev/6f40920a3968

looks good now ?
Yes indeed.
Confirmed that Aurora 22.0a2 2013-04-03 starts with the desktop UI and not the metro UI when passed --enable-metro.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee: bbajaj → lsblakk
Summary: Turn off --enable-metro on Aurora after Firefox 22 uplift to Aurora → Turn off --enable-metro on Aurora after uplift to Aurora
Keywords: verifyme
QA Contact: anthony.s.hughes
Verified as fixed on Firefox 23 beta 7 (it starts with the desktop UI and not the metro UI).
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
Build ID: 20130718163513
QA Contact: simona.marcu
Bhavana will be doing this merge of FF25 -> Aurora so she can confirm if this will be carried forward another release or not.
Assignee: lsblakk → bbajaj
https://hg.mozilla.org/releases/mozilla-aurora/rev/ede8780a15bc

This is resolved for Fx25.

Requesting QA verification here.
(In reply to bhavana bajaj [:bajaj] from comment #13)
> Requesting QA verification here.

Simona, please verify this with the Aurora 25 builds (first builds should show up tomorrow morning).
We have a NIGHTLY_BUILD variable that is only defined when building on the Nightly channel (or on local developer builds of central) (see bug 878291). If you have to make changes to configure flags after tree uplifts to enable/disable features, that feature didn't land properly as far as build config configuration integration is concerned. Please file bugs.
Someone corrected me: Metro landed before bug 878291 so it didn't land improperly. But, it is suboptimal and should be fixed. I'll clone this bug...
Blocks: 901806
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
Build ID: 20130806004002

Verified as fixed on the latest Aurora 25.0a2: it starts with the desktop UI and not the metro UI.
Mozilla/5.0 (Windows NT 6.2; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Windows NT 6.2; rv:26.0) Gecko/20100101 Firefox/26.0

Verified as fixed on Firefox 24 beta 1 (buildID: 20130806170643) and latest Nightly (buildID: 20130806104538), both builds start with desktop UI.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Moving this out of FF26 tracking since we kept --enable-metro on FF26 for Aurora testing & usage (as with FF27 which is now on Aurora).
OS: Windows 8 Metro → Windows 8.1
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.