Links to many wiki functions now broken on wiki

RESOLVED FIXED

Status

Websites
wiki.mozilla.org
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: David Boswell, Unassigned)

Tracking

({regression})

Details

(Reporter)

Description

5 years ago
A recent change has broken many key links on the wiki.  I noticed this around the time the captcha showed up when saving edits.

For example, when trying to create a new page, the edit this page link is broken and shows up as the following text: [?title=Foo&action=edit edit this page]

You can see this on the site at:

https://wiki.mozilla.org/Foo

I've also noticed these broken links in the email I get when a watched page gets updated -- for instance, the link to the edit in the history no longer works.

Marking as critical since this makes essential functions, such as creating new wiki pages, very difficult.
Ugh.  Probably a skin problem I introduced.  Investigating.
Is it only in the content area of the page (as in this example), or are there other areas as well?
(Reporter)

Comment 3

5 years ago
(In reply to Mark A. Hershberger (hexmode) from comment #2)
> Is it only in the content area of the page (as in this example), or are
> there other areas as well?

Yeah, on the site this seems to be limited to broken links in the content area vs. broken links in the nav.  There was also the broken link in the email I received.
Duplicate of this bug: 856643
Duplicate of this bug: 858162
bug 856021 is likely a duplicate of this one, but leaving both open pending :hexmode's investigation.
(Reporter)

Comment 8

5 years ago
Here's an example of the broken link inside the watch email when a page is changed:

"The MozillaWiki page Contribute/Dashboards has been changed on
5 April 2013 by Klahnakoski, see
https://wiki.mozilla.org/Contribute/Dashboards for the current revision.

See ?title=Contribute/Dashboards&diff=0&oldid=510452 for all changes
since your last visit."

The link in the second paragraph to see the changes used to work.
OS: Mac OS X → All
Hardware: x86 → All

Updated

5 years ago
Keywords: regression
The examples in the description (https://wiki.mozilla.org/Foo) and in comment 7 now work as expected for me. And the other bugs that strongly resembled this one (comment 4, comment 5, comment 6) have been fixed. Marking this as fixed; if it is not, please reopen.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.