Watch emails and other parts of wiki.mozilla.org are missing the domain name and have broken links

RESOLVED FIXED

Status

Websites
wiki.mozilla.org
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gerv, Assigned: solarce)

Tracking

({regression})

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I am watching various pages. I now get emails like this:

"Dear Gerv,

The MozillaWiki page Modules/Other has been changed on 26 March 2013 by
BenAdida, see https://wiki.mozilla.org/Modules/Other for the current
revision.

See ?title=Modules/Other&diff=0&oldid=536473 for all changes since your
last visit."

Note the missing domain name/link in the last line. This was working on the 19th but not the 23rd March so I suspect the wiki upgrade is implicated.

Gerv
Investigating.
Duplicate of this bug: 854471
(Reporter)

Comment 3

5 years ago
This might also be a symptom of the same thing; see:
https://wiki.mozilla.org/Capture_Mozilla/Bugzilla/Bugzilla_For_Humans_Transcriptxxx

That literally reads as:

There is currently no text in this page. You can search for this page title in other pages, [?title=Special:Log&page=Capture_Mozilla/Bugzilla/Bugzilla_For_Humans_Transcriptx search the related logs], or [?title=Capture_Mozilla/Bugzilla/Bugzilla_For_Humans_Transcriptx&action=edit edit this page].

Looks like more cases of a missing domain name.

Gerv

Updated

5 years ago
Duplicate of this bug: 856760
(Reporter)

Comment 5

5 years ago
This is still broken in the way described in comment 3. This is fairly serious breakage - can it be looked into, please?

hexmode: were you able to look at this?

Gerv
Severity: normal → major
(In reply to Gervase Markham [:gerv] from comment #5)
> hexmode: were you able to look at this?

Sorry, no.  I have recently been overwhelmed with other work.  I will make every effort to clear off the wikimo items in my queue, though.

Updated

5 years ago
Duplicate of this bug: 869231

Updated

5 years ago
Duplicate of this bug: 869534
(Reporter)

Comment 9

5 years ago
hexmode: this is pretty serious breakage. I'm sure lots of people are hitting this. You see it every time you type the name of a page which doesn't exist, and every time you get a watch notification email. And it doesn't look all that complex a problem. Can you tell us when you might be able to look into it?

Gerv
Summary: Watch emails are missing domain name → Watch emails and other parts of wiki.mozilla.org are missing the domain name and have broken links
I will have time this Thursday to look at the outstanding issues on wikimo.  If someone could send me a prioritized list of the outstanding issues, that would help me make sure the most onerous are handled.
(Reporter)

Comment 11

5 years ago
hexmode: I don't have insight into the issues anyone else is facing, or any idea of their relative priority, but this is the one I keep hitting! :-)

Gerv
(Reporter)

Comment 12

5 years ago
Oh: the other thing that is quite irritating is the fact that unordered lists <ul> have no bottom padding. Top and bottom margins of 0.8em should do the trick.

Gerv
(In reply to Gervase Markham [:gerv] from comment #12)
> Oh: the other thing that is quite irritating is the fact that unordered
> lists <ul> have no bottom padding. Top and bottom margins of 0.8em should do
> the trick.

Someone with permission to edit https://wiki.mozilla.org/MediaWiki:Common.css (I don't have those permissions) could edit that page to add this.

Alternatively, if https://www.mediawiki.org/wiki/Manual:$wgAllowUserCss were set true, you couls set up your own CSS rules.
(In reply to Gervase Markham [:gerv] from comment #12)
> Oh: the other thing that is quite irritating is the fact that unordered
> lists <ul> have no bottom padding. Top and bottom margins of 0.8em should do
> the trick.

(This should really be a new bug.)

jd added this to the [[MediaWiki:Common.css]] page but it looks like it was overridden by the gmo skin:

.mw-content-ltr ul, .mw-content-rtl .mw-content-ltr ul {
  margin: 0.3em 0 0 1.6em;
  padding: 0;
}

I don't know right now where this is, but I'll look this w/e.
(In reply to Gervase Markham [:gerv] from comment #0)
> I am watching various pages. I now get emails like this:
> 
> See ?title=Modules/Other&diff=0&oldid=536473 for all changes since your
> last visit."

Looking at the code, I think this is a result of $wgServer not being set correctly in LocalSettings.php

Could someone in Operations look at what $wgServer is set to and post here?
(In reply to Mark A. Hershberger (hexmode) from comment #15)

> Could someone in Operations look at what $wgServer is set to and post here?

$wgServer           = "https://wiki.mozilla.org";

Updated

5 years ago
Duplicate of this bug: 853563
(In reply to Shyam Mani [:fox2mike] from comment #16)
> $wgServer           = "https://wiki.mozilla.org";

Thanks.  $wgCanonicalServer (https://www.mediawiki.org/wiki/Manual:$wgCanonicalServer) isn't set anywhere, is it?

Without further investigation (which I will do when I get a response), I can't see anything else that would cause this.

If $wgCanonicalServer isn't set, could you attach a copy of the LocalSettings.php with passwords and the like removed?
(Reporter)

Updated

5 years ago
Blocks: 876678
(Reporter)

Comment 19

5 years ago
Palindromic bug 876678 filed about the CSS issue in comment 14 et al.

Gerv

Comment 20

5 years ago
Created attachment 756646 [details]
redacted local settings file

let me know if you need any more info

Thanks

Updated

5 years ago
Duplicate of this bug: 878596
Any news on this?
Flags: needinfo?(mah)

Updated

5 years ago
Flags: needinfo?(jcrowe)
I worked on bug #832030 last weekend since I had the time and it was more pressing.  I'll get to this one this weekend.
Flags: needinfo?(mah)
(Reporter)

Comment 24

5 years ago
Thanks, Mark :-)

Gerv

Updated

5 years ago
Flags: needinfo?(jcrowe)
$wgScript needs to be changed from

  $wgScript = "";

to

  $wgScript = "/index.php";

That should fix this.  This probably results from when I gave you the LocalSettings.php and you had to make some changes.  Note for the future.
(Assignee)

Comment 26

5 years ago
Pushed to dev, stage, and prod, looks good on all three
Assignee: nobody → bburton
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 860443
You need to log in before you can comment on or make changes to this bug.