"new bookmark" menu item not available when right-clicking in bookmarks manager (context menu)

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
RESOLVED WORKSFORME
17 years ago
7 years ago

People

(Reporter: jkng, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1+) Gecko/20010613
BuildID:    2001061304

In bookmarks manager, if you right-click either a folder or outside of one, "new
bookmark" is not an available option. This should be there and should be grouped
with "new folder". IMO, this should be fixed for netscape 6.1

Reproducible: Always
Steps to Reproduce:
read description

Actual Results:  no "new boomark" option in popup menu

Expected Results:  menu item should be there.

"new separator" should also be there as well, but it's not as important.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Hardware: PC → All

Comment 1

17 years ago
-->  UI Design
Assignee: ben → mpt
Component: Bookmarks → User Interface Design
QA Contact: claudius → zach

Comment 2

17 years ago
I think all the functions of the right click should also be available with
buttons or menu's.

- new bookmark
- duplicate bookmark (!)
- new seperator

Comment 3

17 years ago
I think all the functions of the right click should also be available with
buttons or menu's.

- new bookmark
- duplicate bookmark (!)
- new seperator

Comment 4

17 years ago
for the record if you have a request about a commercial product please use a 
commercial feedback page. bugzilla.mozilla.org is not such a site. given 
current leaks 6.1 is past the point of taking new feature work.

as for duplicate, we can't do that now because of arch so i wouldn't expect it 
before 095 at the earliest.  however I don't see a need for duplicate, 
copy+paste is equivalent, and i'd expect it to be a rarely used feature. plus 
what happens when someone asks us to add 'duplicate folder'?

As for the original bug, nc4messenger's folder context menu indeed includes new 
message ... 

Comment 5

17 years ago
dupe of bug 103920.

Comment 6

16 years ago
Not a dupe of bug 103290 (about personal toolbar folder), but of bug 139375 - or
vice-versa.

Comment 7

16 years ago
uid is being phased out.
Assignee: mpt → ben
Component: User Interface Design → Bookmarks
QA Contact: zach → claudius

Comment 8

16 years ago
CC: Pierre - this would be good to have in Phoenix as well

Comment 9

16 years ago
*** Bug 197826 has been marked as a duplicate of this bug. ***
You may want to mark the bug as a duplicate of (more general) bug 172110 !?
Summary: "new bookmark" menu item not available when right-clicking in bookmarks manager → "new bookmark" menu item not available when right-clicking in bookmarks manager (context menu)
*** Bug 262555 has been marked as a duplicate of this bug. ***
*** Bug 172110 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Comment 13

12 years ago
This is also a Netscape 4.x compatability issue. NS4 had a "New Bookmark" in
the context menu if you right-clicked on a folder *or* a bookmark.

Jim H. (aka CuriousJ)
Assignee: bugs → nobody
QA Contact: claudius → bookmarks

Comment 14

8 years ago
WFM, Gecko/20100720 Minefield/4.0b2pre.  Perhaps this got fixed somewhere along the way?

Comment 15

7 years ago
WORKSFORME probably when bookmarks moved to using the Places backend.
 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.2pre) Gecko/20110520 Firefox/4.0.2pre SeaMonkey/2.1.1pre
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.