Closed Bug 860006 Opened 9 years ago Closed 8 months ago

AcroForm/XFA is not supported

Categories

(Firefox :: PDF Viewer, defect, P3)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: tim_vdeynde, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [pdfjs-c-feature][pdfjs-d-form-xfa])

Attachments

(1 file)

The attached pdf file could not be opened correctly. In the web console, I get "Warning: AcroForm/XFA is not supported". Visible errors:

- The font is messed up
- A lot of the content actually exists of images. They are underlined.
- Loading was quite slow
- My mother had problems printing the page, but I didn't try to reproduce (I already printed it for her from Adobe Reader)
Priority: -- → P3
Whiteboard: [pdfjs-c-feature][pdfjs-d-form-xfa]
Status: UNCONFIRMED → NEW
Ever confirmed: true
I saw a PDF sample with the error message "Warning: AcroForm/XFA is not supported" then another error message. Should I file a new bug or is it the same?

[12:06:29.067] "An error occurred while rendering the page.
PDF.js v0.8.47 (build: added3d)
Message: Bad encoding in flate stream
Stack: error@resource://pdf.js/build/pdf.js:761
FlateStream_getCode@resource://pdf.js/build/pdf.js:31423
FlateStream_readBlock@resource://pdf.js/build/pdf.js:31574
DecodeStream_getBytes@resource://pdf.js/build/pdf.js:31155
streamSequenceStreamReadBlock@resource://pdf.js/build/pdf.js:31261
DecodeStream_getChar@resource://pdf.js/build/pdf.js:31182
Lexer_getObj@resource://pdf.js/build/pdf.js:30465
Parser_refill@resource://pdf.js/build/pdf.js:29996
Parser@resource://pdf.js/build/pdf.js:29990
PartialEvaluator_getOperatorList@resource://pdf.js/build/pdf.js:14491
Page_getOperatorList@resource://pdf.js/build/pdf.js:240
wphSetupRenderPage@resource://pdf.js/build/pdf.js:33603
messageHandlerComObjOnMessage@resource://pdf.js/build/pdf.js:33420
"
Got same error displaying a pdf created using LibreOffice writer 4.2.0.4
The text fields are not displayed,
the check boxes are ok,
Chrome, foxit reader, show this pdf ok. 
Can provide the pdf file if neeeded.
"Warning: AcroForm/XFA is not supported" on two PDFs. One with Form Fill Fields, the other with an Electronic Signature added.
Duplicate of this bug: 1336691

The form attached by the original reporter above now seems to work with Firefox 81 with "pdfjs.renderInteractiveForms = true" in about:config, as it now supports AcroForms. The Avaya factsheet URL is dead.

Probably this bug report could be closed? The next frontier would be bug #1671648

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1699219

Adding support for XFA is tracked in bug 1706133.

Let's actually mark it as fixed. It was fixed by supporting PDF form filling.

Resolution: DUPLICATE → FIXED
You need to log in before you can comment on or make changes to this bug.