[CBX]Form with selection input inside iframe pops up selector in wrong screen location

RESOLVED FIXED

Status

()

Core
Layout: Form Controls
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: Karl M. Hegbloom, Unassigned)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
I've got a page with an iframe in it that shows the output of a CGI program
(netsaint).

When I use some of the features of that CGI, it will present a form to fill out,
wich shows up inside the same iframe.  One part of the form is a selection drop
down... when I click on the little arrow, the list pops up but not where it
should.  It's up the screen farther, as though calculating its screen
coordinates based on the main frame rather than the scrolled iframe.
(Reporter)

Comment 1

17 years ago
See: http://www.hegbloom.net/~karlheg/iframe-forms-mozilla-bug.png
Could you possibly post a testcase or better yet attach one to this bug using
http://bugzilla.mozilla.org/createattachment.cgi?id=86909 ?

Over to HTML Form Controls.
Assignee: pollmann → rods
Component: HTMLFrames → HTML Form Controls
QA Contact: amar → madhur
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Status: NEW → ASSIGNED
Summary: Form with selection input inside iframe pops up selector in wrong screen location → [CBX]Form with selection input inside iframe pops up selector in wrong screen location
Target Milestone: --- → mozilla1.2
(Reporter)

Comment 3

16 years ago
A test case is simple to create.

Make a page with an iframe inside it that pulls in another page that has a form
on it.  In that form, create a dropdown selection list with a few items on it.

Make it so the iframe is larger than the main page.

+-------------------------------+
|            Banner             |
|                               |
+-------------------------------+
| menu |                        |
|      |     iframe here        |
|      |                        |
...    ...                      ...

 ... make the iframe long enough that the main window must scroll to show all of
it, and the contents of the ifram big enough so that you must scroll the iframe
in order to see everything inside of it.

 Then click the drop down, and see that depending on where the scrollbars are,
the popup menu part of the drop down is drawn in the wrong place.  I think it's
getting drawn relative to the main document, rather than relative to the iframe
or something.  You might just check there first rather than spend time creating
the test case.
Possibly related to bug 53318

Updated

16 years ago
Priority: -- → P2
Target Milestone: mozilla1.2 → Future

Comment 5

16 years ago
Created attachment 73660 [details]
2 iframe for ads and a login form

I've got an similar weird thing with this.
When typing (windows 2k mozilla 0.9.8 or 0.9.9), the second iframe "jumps" !

Comment 6

16 years ago
The example above run perfectly well with MacOs X. The weird thing happened with
Windows2000.

Comment 7

16 years ago
These 5 bugs:

bug#53318
bug#64902
bug#67661
bug#86909
bug#129782

all seem very similar to me. Are there any duplicates here? Or any useful
information from any of the others that may help any of them get fixed?

Updated

16 years ago
QA Contact: madhur → tpreston
This is almost certainly fixed on trunk now that bug 129782 is fixed.  Please
retest with a current build....

Comment 9

16 years ago
Bug#147806 is very similar, and has a patch

Comment 10

16 years ago
GavinS, I'm assuming that since think this might be a dup of #147806, this is
still happening? (even allowing for bzbarbsky's comment 8?)

Comment 11

16 years ago
James, 

Yes, my local test case still shows this problem, as does the test case I
attached to bug#64902 (you have to download and run locally), as does the latest
testcase on bug#64902 (runnable directly). These are all as described on this
bug - an IFRAME containing a <select> whose popup gets confused when the page is
scrolled.

Also, the issues with the EBAY UK SIdebar, and the Netscape Timezone sidebar
from bug#67661 and bug#105035 still happen.

As does the issue on bug#53318.

All in all, I see lots of these issues -- I hope your patch fixes them all :)

I haven't got a recent source tree, and a build takes about 2 days for me, but
I'd be interested if you can reproduce any of these other issues, with and
without your patch...

Comment 12

14 years ago
I also havce a simliar problem in Linux/X11.  Here is a screenshot:

http://caffeine.contactdesigns.com/~jolt/mozilla.png

Hope that helps.
This needs an actual usable testcase (one along the lines described in comment
3, I guess, but actually attached to the bug so that it's possible to test this).
Assignee: rods → nobody
Status: ASSIGNED → NEW
Keywords: qawanted
Priority: P2 → --
QA Contact: tpreston → core.layout.form-controls
Target Milestone: Future → ---
Depends on: 64902

Comment 14

13 years ago
Created attachment 161223 [details]
supporting file for testcase
Attachment #73660 - Attachment is obsolete: true

Comment 15

13 years ago
Created attachment 161225 [details]
testcase from comment 3

Comment 16

13 years ago
The testcase I attached works for me on Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.7.3) Gecko/20040925 Firefox/0.10.
Jason, I see the bug on that testcase if I open the select when the page
finishes loading, then scroll down about a line (after that the select starts
going out of the viewport), and open it again.  The second time, it's off by the
line I scrolled by.

Comment 18

13 years ago
(In reply to comment #17)
> Jason, I see the bug on that testcase if I open the select when the page
> finishes loading, then scroll down about a line (after that the select starts
> going out of the viewport), and open it again.  The second time, it's off by the
> line I scrolled by.

Still WFM, but glad you could reproduce.
Keywords: qawanted → testcase
Note that I'm testing on Linux, not Windows.
Fixed by checkin for bug 64902
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.