All users were logged out of Bugzilla on October 13th, 2018

getUserMedia - Video playback orientation does not adapt to device orientation

VERIFIED FIXED in Firefox 24

Status

()

VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: gcp)

Tracking

(Blocks: 1 bug, {reproducible})

Trunk
mozilla25
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(firefox24 verified, firefox25 verified, fennec+)

Details

(Whiteboard: [getUserMedia][android-gum+], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Currently when video playback is active through getUserMedia, the orientation of playback as shown to the user does not adapt to device orientation such as rotating a device from portrait to landscape.

Perhaps this will be fixed via bug 862808?

Steps to reproduce

i) http://mozilla.github.io/webrtc-landing/gum_test.html
ii) Tap 'Video'
iii) Rotate device to landscape

Expected Results: Portrait → Landscape → (Video element responds to device orientation and changes appropriately)
Actual Results: Portrait → Landscape → (Video element does not respond to device orientation change and it remains in former orientation; video is facing sideways)

--
HTC One (Android 4.1, Nightly 05/21)
LG Nexus 4 (Android 4.2.2, Nightly 05/21)
I would retest this with the fix in bug 862808 to confirm if this still a bug or not.
Blocks: 750010
Whiteboard: [getUserMedia] → [getUserMedia][blocking-gum-][android-gum+]
(Reporter)

Comment 2

6 years ago
Bug 862808 did not fix this.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 877244

Updated

5 years ago
Whiteboard: [getUserMedia][blocking-gum-][android-gum+] → [getUserMedia][android-gum+]
Important for any camera-based web application you build for the web. A camera app that doesn't change it's video reflective of the device's orientation would be a significant loss of functionality.
tracking-fennec: --- → ?
Don't think this needs to block pref on, however. But we need this for any camera-based web application before we ship the feature.
tracking-fennec: ? → +
Assignee: nobody → gpascutto
(Assignee)

Comment 6

5 years ago
Created attachment 768500 [details] [diff] [review]
Patch 1. Adjust rotation amounts

1) Remove SetPreviewRotation and friends. We try very hard not to show the preview in the first place, how the image is rotated there is none of our concern, so this code can go.

2) Add a listener for onConfigurationChanged, recalculate rotation amounts. Make the rotation amount a per-frame parameter, instead of calculating it once as the Camera is initialized.
Attachment #768500 - Flags: review?(blassey.bugs)
Attachment #768500 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/89a5e4356ad1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25

Updated

5 years ago
Keywords: verifyme
QA Contact: jsmith
(Reporter)

Comment 9

5 years ago
Looks fine on trunk, needed on Aurora.
Status: RESOLVED → VERIFIED
status-firefox24: --- → affected
status-firefox25: --- → verified
Keywords: verifyme
(Assignee)

Comment 10

5 years ago
Comment on attachment 768500 [details] [diff] [review]
Patch 1. Adjust rotation amounts

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 881875 (metabug)
User impact if declined: gUM video won't rotate along with the device
Testing completed (on m-c, etc.): landed on m-c a few days ago, verified by QA
Risk to taking this patch (and alternatives if risky): Low, limited to Android WebRTC
String or IDL/UUID changes made by this patch: NA
Attachment #768500 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #768500 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
Whiteboard: [getUserMedia][android-gum+] → [getUserMedia][android-gum+][webrtc-uplift]
gcp - Can you land this on Aurora 24 now that we have aurora approval?
Flags: needinfo?(gpascutto)
(Assignee)

Comment 12

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/3cc5b3484a88
status-firefox24: affected → ---
status-firefox25: verified → ---
Flags: needinfo?(gpascutto)
Target Milestone: mozilla25 → ---
(Assignee)

Updated

5 years ago
status-firefox24: --- → fixed
status-firefox25: --- → verified
Target Milestone: --- → mozilla25
(Reporter)

Updated

5 years ago
status-firefox24: fixed → verified
Whiteboard: [getUserMedia][android-gum+][webrtc-uplift] → [getUserMedia][android-gum+]
You need to log in before you can comment on or make changes to this bug.