Animated GIF pauses and skips frames

RESOLVED DUPLICATE of bug 876332

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 876332
5 years ago
5 years ago

People

(Reporter: Bram Speeckaert, Unassigned)

Tracking

({regression})

24 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox24-)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I noticed this GIF animates differently, at least since Nightly build 2013-05-25. It seems to pause and then skip ahead to catch up with the animation at specific points repeatedly. It works okay in other browsers, as well as Firefox 21.0.
(Reporter)

Comment 1

5 years ago
Created attachment 755391 [details]
Faulty GIF

Comment 2

5 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/00b264c7cced
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130522 Firefox/24.0 ID:20130522092949
Bad:
http://hg.mozilla.org/mozilla-central/rev/8eebe35aae63
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130523 Firefox/24.0 ID:20130523044333
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=00b264c7cced&tochange=8eebe35aae63

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/2a4461b9480b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130522 Firefox/24.0 ID:20130522221332
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/aaa399729ff4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130522 Firefox/24.0 ID:20130522221631
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2a4461b9480b&tochange=aaa399729ff4

In local build
Last God: b0d4c7e61aed
First Bad: 9ac8495cf585
Regressed by
9ac8495cf585	Joe Drew — Bug 873505 - Set the animation frame's start time based on when we *wanted* to start, not when we actually did. r=seth
Blocks: 873505
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Updated

5 years ago
tracking-firefox24: --- → ?
Version: Trunk → 24 Branch
Luckily, this is fixed in bug 876332.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 876332

Updated

5 years ago
Duplicate of this bug: 877564

Updated

5 years ago
tracking-firefox24: ? → -
You need to log in before you can comment on or make changes to this bug.