Remove UA override for domains starting 2013-08-30

RESOLVED FIXED in Firefox 26, Firefox OS v1.2

Status

Firefox OS
Gaia
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: karlcow, Assigned: karlcow)

Tracking

unspecified
1.2 C3(Oct25)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+, firefox25 wontfix, firefox26 fixed, firefox27 fixed, b2g-v1.2 fixed)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
New list of removal of domains
(Assignee)

Comment 1

5 years ago
Bug 802981 to remove maps.google.com
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Depends on: 802981
(Assignee)

Comment 2

5 years ago
Bug 843134 to remove news.google.com
Depends on: 843134
(Assignee)

Comment 3

5 years ago
Bug 829478  to remove mail.google.com
Depends on: 829478
(Assignee)

Updated

5 years ago
Depends on: 828376
(Assignee)

Comment 4

5 years ago
to remove plotek.pl Bug 828376
(Assignee)

Comment 5

5 years ago
to remove nytimes.com Bug 843137
Depends on: 843137
(Assignee)

Comment 6

5 years ago
to remove icanhas.cheezburger.com Bug 843197
Depends on: 843197
(Assignee)

Comment 7

5 years ago
to remove cnn.com Bug 878635
Depends on: 878635
(Assignee)

Comment 8

5 years ago
to remove ofeminin.pl Bug 887739
Depends on: 887739
(Assignee)

Comment 9

5 years ago
to remove enfemenino.com Bug 843109
Depends on: 843109
(Assignee)

Comment 10

5 years ago
Fixing also the file according to 
https://groups.google.com/forum/#!topic/mozilla.compatibility/7rDkuiNaGWk

There discrepancies in the file. 

+bancobrasil.com.br
should be removed it is a duplicate of
https://bugzilla.mozilla.org/show_bug.cgi?id=826711

+bet365.com
was fixed a while ago
https://bugzilla.mozilla.org/show_bug.cgi?id=878226


+live.com
Bug 826332 was closed as a duplicate of Bug 759111 which has now been closed too. Removing it.
https://bugzilla.mozilla.org/show_bug.cgi?id=826332
Depends on: 826711, 878226, 826332, 759111
(Assignee)

Updated

5 years ago
Depends on: 826736
No longer depends on: 826711
(Assignee)

Comment 11

5 years ago
Created attachment 809244 [details] [diff] [review]
patch-911260-ua-override.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #809244 - Flags: review?(lmandel)
Attachment #809244 - Flags: review?(lmandel) → review+
I removed bug 887739 from the dependency list as there was no override for the associated domain.
No longer depends on: 887739
Karl, when requesting approval, please fill in the questionnaire.

[Approval Request Comment] Request to uplift UA override changes.
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: Certain sites on the list will continue to display Android app ads. This impacts user experience.
[Testing completed]: All override removals have been tested on device.
[Risk to taking this patch] (and alternatives if risky): Very low risk. As the patch shows, this change removes prefs.
[String changes made]: None.
(Assignee)

Comment 14

5 years ago
Added the pull request https://github.com/mozilla-b2g/gaia/pull/12398(In reply to Lawrence Mandel [:lmandel] from comment #12)
> I removed bug 887739 ☐ from the dependency list as there was no override for
> the associated domain.

Ah good catch. Oversight from me.
(Assignee)

Comment 15

5 years ago
(In reply to Lawrence Mandel [:lmandel] from comment #13)
> Karl, when requesting approval, please fill in the questionnaire.
> 
> [Approval Request Comment] Request to uplift UA override changes.
> [Bug caused by] (feature/regressing bug #): N/A
> [User impact] if declined: Certain sites on the list will continue to
> display Android app ads. This impacts user experience.
> [Testing completed]: All override removals have been tested on device.
> [Risk to taking this patch] (and alternatives if risky): Very low risk. As
> the patch shows, this change removes prefs.
> [String changes made]: None.

Oh! in the attachment form. 
Will do next time, I didn't know I had to. Thanks.


And I added the pull request
https://github.com/mozilla-b2g/gaia/pull/12398
(Assignee)

Updated

5 years ago
Blocks: 902122
(Assignee)

Updated

5 years ago
blocking-b2g: --- → leo?
(Assignee)

Updated

5 years ago
blocking-b2g: leo? → koi?
Created attachment 812070 [details] [diff] [review]
mozilla-central patch
Attachment #812065 - Attachment is obsolete: true
(Assignee)

Comment 18

5 years ago
Comment on attachment 812070 [details] [diff] [review]
mozilla-central patch

Review of attachment 812070 [details] [diff] [review]:
-----------------------------------------------------------------

looks good.
Attachment #812070 - Flags: review+
koi+ for low risk reasons
blocking-b2g: koi? → koi+
https://hg.mozilla.org/mozilla-central/rev/edd87e1f3268
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.2 C3(Oct25)
https://hg.mozilla.org/releases/mozilla-aurora/rev/3aab2cb0a1a7
status-b2g-v1.2: --- → fixed
status-firefox25: --- → wontfix
status-firefox26: --- → fixed
status-firefox27: --- → fixed

Updated

4 years ago
Depends on: 990767
(Assignee)

Updated

4 years ago
No longer depends on: 990767

Updated

4 years ago
Depends on: 990767
(Assignee)

Updated

4 years ago
No longer depends on: 990767

Updated

4 years ago
Depends on: 990767

Updated

4 years ago
No longer depends on: 990767
You need to log in before you can comment on or make changes to this bug.