Closed Bug 879675 Opened 7 years ago Closed 7 years ago

B2G MMS: If the mmsc in APN settings end with '/', it will cause sending MMS fail.

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 885685
1.1 QE2 (6jun)
blocking-b2g leo+
Tracking Status
firefox22 --- wontfix
firefox23 --- wontfix
firefox24 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: ctai, Assigned: ctai)

References

Details

(Whiteboard: [fixed-in-birch])

Attachments

(3 files, 1 obsolete file)

No description provided.
Attached patch Patch v1.0 (obsolete) — Splinter Review
Attachment #758460 - Flags: review?(vyang)
Nominate this bug, because some sim card might have mmsc end with '/'.
blocking-b2g: --- → leo?
No longer blocks: 877424
Summary: B2G NNS: If the mmsc in APN settings end with '/', it will cause sending MMS fail. → B2G MMS: If the mmsc in APN settings end with '/', it will cause sending MMS fail.
Attached patch Patch v1.1Splinter Review
Attachment #758460 - Attachment is obsolete: true
Attachment #758460 - Flags: review?(vyang)
Attachment #758480 - Flags: review?(vyang)
I changed flag to Leo+ and milestone to QE2 because it is really basic thing to support MMS. 
- jinyoon -
Severity: normal → critical
blocking-b2g: leo? → leo+
Target Milestone: --- → 1.1 QE2 (6jun)
Attachment #758480 - Flags: review?(vyang) → review+
https://hg.mozilla.org/mozilla-central/rev/6f19d6debc1c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Flags: in-moztrap-
Duplicate of this bug: 877424
I think because of this we are not able to send MMS in certain networks.

In India Vodafone MMSC is having "/" at the end.
With the auto detected MMSC we are getting XHR response 404.
But when I added "//" to nullify this patch effect its working fine. Please find the attached MMS Service log.

I dont know about the root issue why this patch is required.
Unfortunately with this patch MMS sending is failing.
So re opening this issue.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #766614 - Attachment description: With default APN → With default MMSC (Ending with "/")
Let's solve this issue at bug 885685.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 885685
You need to log in before you can comment on or make changes to this bug.