B2G MMS: Use nsIURI Object in applyFilter for MmsProxyFilter.

RESOLVED FIXED in Firefox 25, Firefox OS v1.1hd

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: ctai, Assigned: ctai)

Tracking

unspecified
mozilla25
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+, firefox23 wontfix, firefox24 wontfix, firefox25 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

Details

(Whiteboard: [fixed-in-birch])

Attachments

(1 attachment, 4 obsolete attachments)

Some content location from some MMSC will contain port:80. But it will be ignore in prePath. That should be a problem.
This bug is found by LEO. Nominate to leo+.
blocking-b2g: --- → leo?
Attachment #765880 - Flags: review?(vyang)
Comment on attachment 765880 [details] [diff] [review]
Patch v1.0

Review of attachment 765880 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/mobilemessage/src/ril/MmsService.js
@@ +379,5 @@
>    return conn;
>  });
>  
>  function MmsProxyFilter(url) {
> +  this.url = Services.io.newURI(url,null,null); ;

nit: SP after comma, and remove the extra semicolon in the end.
Attachment #765880 - Flags: review?(vyang) → review+
Unless this is a certification blocker or leo wants to champion blocking on this we'll just wait for a fix in the next version. Found by != blocker.
blocking-b2g: leo? → -
Created attachment 766546 [details] [diff] [review]
Patch v1.1
Attachment #765880 - Attachment is obsolete: true
Keywords: checkin-needed
Keywords: checkin-needed
Need a fix for bug 879675.
Created attachment 767009 [details] [diff] [review]
Patch v1.2
Attachment #766546 - Attachment is obsolete: true
Comment on attachment 767009 [details] [diff] [review]
Patch v1.2

Review of attachment 767009 [details] [diff] [review]:
-----------------------------------------------------------------

For bug 879675.
Attachment #767009 - Flags: review?(gene.lian)

Comment 9

5 years ago
Discussed with CTAI. This should be a leo+. It resolves the issue of a patch which removes /.
blocking-b2g: - → leo+
Comment on attachment 767009 [details] [diff] [review]
Patch v1.2

Review of attachment 767009 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!

::: dom/mobilemessage/src/ril/MmsService.js
@@ +373,5 @@
>    return conn;
>  });
>  
>  function MmsProxyFilter(url) {
> +  this.url = Services.io.newURI(url,null,null);

Please add spaces among parameters.

@@ +384,5 @@
>  
>    applyFilter: function applyFilter(proxyService, uri, proxyInfo) {
> +    if (!this.url.equals(uri)) {
> +      if (DEBUG) debug("applyFilter: content uri = " + JSON.stringify(this.url) +
> +                       " is not matched url = " + JSON.stringify(uri) + " .");

s/is not matched/is not matched with/
Attachment #767009 - Flags: review?(gene.lian) → review+
Duplicate of this bug: 879675
Created attachment 767059 [details] [diff] [review]
Patch v1.3
Attachment #767009 - Attachment is obsolete: true
Keywords: checkin-needed
Keywords: checkin-needed
Created attachment 767060 [details] [diff] [review]
Patch v1.4

Rename this.url to this.uri.
Attachment #767059 - Attachment is obsolete: true
Keywords: checkin-needed
https://hg.mozilla.org/projects/birch/rev/428cd9da48d3
https://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
status-b2g-v1.1hd: --- → affected
Keywords: checkin-needed
Whiteboard: [fixed-in-birch]
https://hg.mozilla.org/mozilla-central/rev/428cd9da48d3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
https://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/29933d1937db
status-b2g-v1.1hd: affected → fixed
status-firefox23: --- → wontfix
status-firefox24: --- → wontfix
status-firefox25: --- → fixed
You need to log in before you can comment on or make changes to this bug.