[MMS] The device doesn’t send MMS with vodafone network

RESOLVED DUPLICATE of bug 883022

Status

()

Core
DOM: Device Interfaces
P1
major
RESOLVED DUPLICATE of bug 883022
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: ctai)

Tracking

(Blocks: 1 bug)

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: GCF [TD-344272])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
1. Title: The device doesn’t send MMS with vodafone network.
2. Precondition: Settings -> Language -> Select Portugues
3. Tester's Action: Precondition:(1)VDF has 2 APNs (one for web, one for MMS). Turn data off on DUT and try to send the MMS.
(2)If the MMS is not sent (stuck in sending status): delete the MMS->turn on data->turn off data->send a new MMS. Note that sometimes, the MMS is stuck in sending status even if the Primary PDP context for MMS is activated and deactivated by DUT.
4. Detailed Symptom (ENG.) : DUT doesn’t send MMS and shows an exclamation point near the image, or it is stuck in a sending status It should send the MMS
5. Expected:The MMS should be sent with each network
6. Reproducibility: Y
1) Frequency Rate : 70%
7. Gaia Master/v1-train: Reproduced on v1-train
8. Gaia Revision:  f25d5e8552e6d395435047de1d767889129701c3
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo+
Priority: -- → P1
Whiteboard: [TD-344272]
Target Milestone: --- → 1.1 QE3 (24jun)
(Reporter)

Updated

5 years ago
Summary: [SMS] The device doesn’t send MMS with vodafone network → [MMS] The device doesn’t send MMS with vodafone network
Could you please post the APN settings of DATA/MMS?
Could you please follow below steps to get log with MMS log for me? Those informations will be very useful for me because of I have no vodafone SIM card. Please use adb logcat -v time -b main -b radio. Thanks.

rm user.js 2>/dev/null
adb remount
adb pull /system/b2g/defaults/pref/user.js user.js
sed -i -e '$ a\
pref("ril.debugging.enabled", true);\
pref("mms.debugging.enabled", true);
' user.js
adb push user.js /system/b2g/defaults/pref/user.js
adb shell reboot

## update for replacing user.js script
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 2

5 years ago
Hi,
I will provide the logs immediately once i will get.
Flags: needinfo?(leo.bugzilla.gaia)

Updated

5 years ago
Assignee: nobody → ctai

Updated

5 years ago
Whiteboard: [TD-344272] → GCF [TD-344272]
(Reporter)

Comment 3

5 years ago
Created attachment 765180 [details]
logs

I tried to sent 3 MMS with attachments:
1) JPEG 640x480 ->not sent
2) WBMP 160x120 ->not sent
3) JPEG 80x60 -> sent
Leo,
I am sorry to tell you that this log has no MMS log.
Could you please make sure pref("mms.debugging.enabled", true); in user.js?

But from the symptom of sometimes work, sometimes not work, my guess is the bug might related to bug 883022.
If I can get the log with MMS, I might be able to find the relationship with bug 883022.
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 5

5 years ago
Hi,
I am sorry,i will send the logs again.
Flags: needinfo?(leo.bugzilla.gaia)

Updated

5 years ago
Whiteboard: GCF [TD-344272] → GCF [TD-344272], TaipeiWW
I do not know that we are shipping a release with Vodafone in 1.1, so re-nominating for leo?. We should not block on this bug if we are not shipping with the carrier.
blocking-b2g: leo+ → leo?
Depends on: 879675
Depends on: 885685
Component: Gaia::SMS → DOM: Device Interfaces
Product: Boot2Gecko → Core

Updated

5 years ago
Whiteboard: GCF [TD-344272], TaipeiWW → GCF [TD-344272]
(Reporter)

Comment 7

5 years ago
Created attachment 768138 [details]
Radio logs and logcat logs attached
Still no MMS log..:( Am I right?
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 9

5 years ago
Hi,
We are waiting to get the logs from the tester.
We will provide the logs immediately,once we got from the tester.
Thanks
Flags: needinfo?(leo.bugzilla.gaia)
Blocks: 744684
(Reporter)

Comment 10

5 years ago
Hi,
This issue is not reproducible in the latest binary.
Thanks
Closed because of not reproducible in the latest binary. Should be the same problem as 883022.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 883022

Updated

5 years ago
blocking-b2g: leo? → ---
You need to log in before you can comment on or make changes to this bug.