Clicking on icons/links on desktop/apps is broken

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
P2
major
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: timeless, Assigned: Bill Law)

Tracking

({helpwanted})

Trunk
Future
x86
Windows 2000
helpwanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [correctness] win32-registry)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
from Bugzilla Bug 58848 Click Excel Hyperlink, N6 loads it twice in separate 
windows.

Click on a HyperLink in Excel.
If N6 is already running, it loads web page twice, in separate windows.
If it is not running, it launches, loads the web page in one window, and the
home page in another.
The first time I tried this, N6 crashed, but appeared to remain running, as if
there were two instances of the app running, one of which crashed.
This would also explain why I saw two Java icons in the Win98 taskbar on some 
tries.

------- Additional Comments From Bill Law 2001-06-01 16:16 -------
I looked into this a little bit.  We are getting *two* requests from excel/word 
(I tested using an MS Word document link).  I don't know why.  Will take at 
least 1 day to figure it out.

------- Additional Comments From Bill Law 2001-06-12 16:41 -------
I investigated this a bit over the last couple of days.

Clicking on a http: link in a Word document (I presume Excel does the same) 
generates two invocations of Mozilla:

1. The one registered under the http protocol.
2. The one registered under the .html file extension (this might differ based 
on the extension of the link).

The tricky thing is knowing what the heck Word is thinking when it's doing 
this.  It has something to do with DDE, because if I clear out the ddeexec 
subkey under HKCR/http/shell/open, then we only get 1 request (the one 
registered under http).  It seems that the presence of the ddeexec entry causes 
Word to then issue a second request based in the file extension in the URL.

The funny thing is that it doesn't seem to actually do any DDE.

So a fix may be hard.  I am working to completely remove our so-called support 
for these ddeexec subkeys.  That's a little tricky because we can't just ignore 
them; other applications (i.e., Communicator or IE) will have already set these 
so we have to force them to be blank.

There's also the interaction between those keys and integration with Explorer 
(i.e, dbl-clicking Internet shortcuts on the desktop).  I have to go see if 
removing this degrades our support for that.  Ideally, taking this step will 
also fix the problems related to that (e.g., bug 58770).

------- Additional Comments From Nick Hansen 2001-06-22 11:23 -------
Using the 2001062004 build of Moz as well as the N6.1beta under Win2K results 
in the following when there is no browser currently open and a link is clicked:

2. Word/Excel/Outlook opens two browsers, the first loads the page & the second
remains blank but obscures the first browser window that actually loads the 
URL.

------- Additional Comments From Nick Hansen 2001-06-22 11:41 -------
I installed N6.1beta this nutty behavior changed.  At that point, when I 
clicked a link in Outlook, it only opened one browser (N6.1b) but also put up a 
dialog asking me to locate the program used to open/handle this link (loose 
paraphrase).  It replicated this behavior upon successive attempts until I 
helped Outlook locate the appropriate application (N6.1b).  After doing this, 
it now opens two browser windows, etc. . .

------- Additional Comments From Frank Burleigh 2001-06-26 14:03 -------
*two* browser windows open in Word 2000, in Excel 2000 and in Outlook 2000.
paw able to repro this on his w2k machine with an office 2000 [he'll comment
with details here soon].

cc'ing lisa as well.
Severity: normal → major
Keywords: rtm
ack, forgot to reaasign, since bill is away.
Assignee: law → pchen
[sheesh, i keep forgetting to add comments at the right time...] as i had
mentioned in bug 88086, i wonder if this might also be an issue on the Mac...
or, relevant?

Comment 4

17 years ago
Thanks for tackling this, sairuh@netscape.com; hopefully these moves will get
this on the radar again.  Perhaps you could solicit the newsgroups for Mac
testers?  I am close to the support people in our building of several hundred
NS4 users, and would say simply that the browser must behave in line with user
expectations; any behavior short of that (opening two windows or IE) prevents us
from deploying the browser, with all that implies.  I know, I've tried. ;-) 
Thanks to you and to timeless.

zach is checking to see if he can repro this on his Mac OS X system [which has
Office 2001 --not sure if/how that'd matter here, but couldn't hurt to check].

also cc'ing mpt and lordpixel to see if they might have access to Office apps,
and hence see if they run into this bug. [if not, apologies for the spam.]

Comment 6

17 years ago
Works correctly for me (launches one browser window only) with Mac OS 9.1, Moz 
build 2001062708 and Word 98. Don't have Office 2001:mac...

Comment 7

17 years ago
I'm seeing this exact problem on my Win98SE system.   Eudora behaves the same
way, too.    (which makes me see this bug every day)

I've had Mozilla set up to handle HTML files , URLs, etc..  for quite a long
time.   Perhaps there is something wrong in the URL: HyperText Transport
Protocol settings?     In particular, the "DDE Application Not Running" section?
   I'm saying this because if Mozilla isn't running at all on my system and I
click a URL in Eudora, 2 Mozilla browser windows are opened.     If Mozilla is
currently running, then it will just open one new window as expected.

Just a guess...

Comment 8

17 years ago
Created attachment 40822 [details]
URL: HTTP handler settings on my PC
Is this not a dupe of bug 59078 ?

Comment 10

17 years ago

*** This bug has been marked as a duplicate of 59078 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 11

17 years ago
timeless didn't seem to think so.  I don't believe it is unless you believe the
behaviors have the same underlying cause.  Bill Law Checked in stuff on another
bug that improved this whole situation *but did not fix* Moz when run from links
in MS Office apps.

Also, I've found that by turning off DDE in my File Types dialog I can make Moz
open once window when double clicking an HTML file in the file system.
(Reporter)

Comment 12

17 years ago
i went to great effort to file these bugs seperately. if you want to accuse 
them of being dupes i expect you to run the qa to prove it to me. REOPEN.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 13

17 years ago
Timeless, thanks for stepping back in.  Do we (testers and administrators) need
to do anything further (other than file Outlook 2k/XP as a separate issue)?
(Reporter)

Comment 14

17 years ago
please try to provide the info i asked for in bug 88086 date: 2001-06-28 15:38.

my impression was outlookxp behaved like office2k if that's the case it can 
live in this bug.
Status: REOPENED → NEW

Comment 15

17 years ago
Ok, I will review bug 88086.

Your impression is correct: Outlook XP and Outlook 2000 behave the same.  In bug
88086 Blake Ross 2001-07-01 12:59 seemed to suggest filing a separate Outlook
bug.  I kinda want to hop a plane so we can all be in the same room, there's so
much stuff around these. ;-)

*** Bug 90622 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
*** Bug 91134 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
I just wanted to report on similar experiences using Outlook 2000 on Win2k. 
However, when I click on a link in Outlook, it actually opens both in Mozilla
and in IE.  Clearing out the ddeexec subkey under HKCR/http/shell/open
 as described above fixed the problem, so I believe it is the same bug, however
I do not know why it would open both Mozilla and IE (as opposed to two seperate
Mozilla windows as everyone else is reporting).  I don't believe I have changed
any of my settings, aside from letting Mozilla set itself as the default for
.html, http, etc.
Will clearing out the ddeexec key screw up other programs though?  Office
programs, or things that rely on IE specifically?

Updated

17 years ago
Keywords: nsbeta1

Comment 19

17 years ago
nav triage team:

Removing nsrtm keyword, adding blaker to cc-list, marking p2 and mozilla0.9.4
Keywords: nsrtm
Priority: -- → P2
Target Milestone: --- → mozilla0.9.4

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+
(Reporter)

Comment 20

17 years ago
*** Bug 94643 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
*** Bug 94632 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
Pchen - Are we gonna get to this one for eMojo? If so, please mark as nsbranch+.
(Assignee)

Comment 23

17 years ago
I had to debug this at home, 'cause that's the only system I could find with
Office2K.

What I found was that Office2K (or the shell APIs it calls) will utilize the
http protocol registry entries and invoke Mozilla.  It will then (for some
unknown reason) utilize the .html registry entries and launch Mozilla again.  We
can't tell this from two completely separate requests so we process both.

While I don't know *why* we get the second request, I did figure out how to stop
it.  This is basically the same sort of thing I found for bug 58848.  In that
case, if the default value under shell/open/ddeexec existed, then the shell
tried the .html route.  With Office2K, it does that if there is *anything* under
the shell/open/ddeexec subkey (e.g., empty Application or Topic subkeys).

I can fix the problem by deleting the shell/open/ddeexec subkey in its entirety.

I will be implementing code shortly that does that (rather than blank the dde
subkey default values).  But that code will come after I tweak the same code for
bug 97813.

I will have code early next week.

See also my comments in bug 59078 (a similar problem reported on some Win2K
system(s)).

Comment 24

17 years ago
Don't think Bill's fix will come in time for 0.9.4 ;-) Marking nsBranch and 0.9.5
Keywords: nsbranch
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Updated

17 years ago
Blocks: 99227

Comment 25

17 years ago
nsbranch+, since you have a fix in mind that sounds simple.  If that is not the
case, I'd question the risk/benefit ratio of making such changes this late in
the release.
Keywords: nsbranch → nsbranch+

Comment 26

17 years ago
Adding correctness Status Whiteboard, correct/expected behavior does not occur.
Whiteboard: [correctness]
*** Bug 101427 has been marked as a duplicate of this bug. ***

Comment 28

17 years ago
The patch that was promised for early in the week of 9/10 still hasn't shown up.
 PDT-.  (It's too bad since it was supposedly a simple fix.)
Whiteboard: [correctness] → [correctness] PDT-
->bill, since he was last working on it...but reassign if needed.
Assignee: pchen → law

Comment 30

17 years ago
nsbranch-
Keywords: nsbranch+ → nsbranch-
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.5 → mozilla0.9.7
(Assignee)

Comment 31

17 years ago
*** Bug 70338 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 32

17 years ago
*** Bug 98646 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 33

17 years ago
*** Bug 98837 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 34

17 years ago
Generalizing summary to encompass all symptoms of this problem.
Summary: clicking links in Office 2000 Apps triggers two browser windows → Clicking on icons/links on desktop/apps is broken

Updated

17 years ago
Blocks: 107067

Updated

17 years ago
Keywords: nsbranch-
(Assignee)

Comment 35

17 years ago
Resetting target milestone for all "window integration" bugs to mozilla0.9.8.  
I'm working on performance and won't get to that till next milestone.
Target Milestone: mozilla0.9.7 → mozilla0.9.8
(Assignee)

Comment 36

17 years ago
Not getting to this, either.
Target Milestone: mozilla0.9.8 → mozilla0.9.9
*** Bug 121181 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Whiteboard: [correctness] PDT- → [correctness] PDT- win32-registry
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Depends on: 59078
Target Milestone: mozilla0.9.9 → ---
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 38

16 years ago
Spam: Moving out bugs that there is no time for.

Please note that some of these will hopefully be fixed in the course of fixing 
bug 59078.  I just can't commit to fixing them all.
Keywords: helpwanted
Target Milestone: mozilla1.0 → Future

Updated

16 years ago
No longer blocks: 107067
Whiteboard: [correctness] PDT- win32-registry → [correctness] win32-registry

Comment 39

16 years ago
I have also had success (with 0.9.8) using DDE only.  By removing the '-url'
option from the end of the mozilla command line, but leaving the DDE to
application 'IExplore', topic 'WWW_OpenURL'.

Comment 40

16 years ago
*** Bug 125224 has been marked as a duplicate of this bug. ***

Comment 41

16 years ago
I also noticed this bug, and I tried to change the settings for URL:http. I
managed to get some improvements when I change the DDE Application from
"IExplore" to "Mozilla". After the changes, clicking a link in another
application correctly load the page in an existing Mozilla window, or launch
Mozilla if it wasn't already opened.

Comment 42

16 years ago
You're almost there!

I worked with that thing on my machine, and the following seems to fix it:

Set ddeexec default value to
-url "%1"

(Quotes are important!)
Set ddeexec/Application to 
Mozilla

And voila - I can finally open links in Outlook
QA Contact: sairuh → tpreston

Comment 43

15 years ago
Last comment was made one year ago. Is this still an issue?

Comment 44

15 years ago
I haven't seen this problem in quite a while and I seem to remember it being
fixed. I just tried the testcase and, with Mozilla open, it reuses the last used
browser window as expected. I'd say it's FIXED or WFM.

Comment 45

15 years ago
Fixed ages ago.

Comment 46

15 years ago
marking worksforme based on comments (I can't test on win), please reopen if
this is still an issue
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → WORKSFORME

Comment 47

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.