[MMS] The device uses the default orange APN to send MMS instead of the proper APN

RESOLVED FIXED in 1.1 QE3 (26jun)

Status

Firefox OS
Gaia::SMS
P2
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: kenkai)

Tracking

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: GCF [TD-345170], TaipeiWW)

(Reporter)

Description

5 years ago
1. Title:The device uses the default orange APN to send MMS instead of the proper APN
2. Precondition: SMS app should be working
3. Tester's Action:  (1) Insert Orange USIM 
                     (2) Set up MMS APN(orange.acte)
                     (3) Send/Receive MMS
4. Detailed Symptom (ENG.) : The Device sends and receives MMSs using the internal APN orange instead of the proper orange.acte APN.
5. Expected: The Device should use the APN orange.acte to send/receive the MMSs.
6. Reproducibility: Y
1) Frequency Rate : 50%
7. Gaia Master/v1-train: Reproduced on v1-train and master
8. Gaia Revision:  bd07ce233160a0e6325bf736769772a9d2273458
9. Personal email id: sasikala.paruchuri8@gmail.com
Component: Gaia::SMS → DOM: Device Interfaces
Product: Boot2Gecko → Core
Version: unspecified → 18 Branch
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo+
Component: DOM: Device Interfaces → Gaia::SMS
Product: Core → Boot2Gecko
Whiteboard: [TD - 345170]
Target Milestone: --- → 1.1 QE3 (24jun)
Version: 18 Branch → unspecified
(Reporter)

Updated

5 years ago
Whiteboard: [TD - 345170] → [TD-345170]
Hi Ken and Chia-Hung, this issue might be related to your work recently.
Blocks: 744684
(Assignee)

Comment 2

5 years ago
(In reply to Leo from comment #0)
Can you please provide MMS and data apn setting what you used to us? Thanks.
Flags: needinfo?(leo.bugzilla.gaia)
Is there relationship between this bug and bug 883031? Are the sim card the same one?
(Assignee)

Updated

5 years ago
Assignee: nobody → kchang
(Reporter)

Updated

5 years ago
Flags: needinfo?(leo.bugzilla.gaia)
Priority: -- → P2
Anshul, 
Could you please check this bug?
Flags: needinfo?(anshulj)

Comment 5

5 years ago
Phil will be looking at this issue.
Flags: needinfo?(anshulj) → needinfo?(pgravel)

Updated

5 years ago
Whiteboard: [TD-345170] → GCF [TD-345170]
I think I found the root cause. The root cause should be the wrong state from the value of getDataCallStateByType("mms") on QC RIL.
http://mxr.mozilla.org/mozilla-central/source/dom/mobilemessage/src/ril/MmsService.js#316
After deactivate MMS data call, the value of gRIL.getDataCallStateByType("mms") should not be "Ci.nsINetworkInterface.NETWORK_STATE_CONNECTED"
Blocks: 883033
No longer depends on: 883033

Updated

5 years ago
Whiteboard: GCF [TD-345170] → GCF [TD-345170], TaipeiWW

Comment 7

5 years ago
Fixed in AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.135+.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(pgravel)
Resolution: --- → FIXED
Duplicate of this bug: 883031
Duplicate of this bug: 883033
Duplicate of this bug: 884238
You need to log in before you can comment on or make changes to this bug.