Firefox for Android (Fennec) search providers missing in B2G

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
6 months ago

People

(Reporter: danielsi, Unassigned)

Tracking

({productwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.89 Safari/537.36

Steps to reproduce:

Typed a search query into the address/search bar


Actual results:

Got a prompt to search Bing for the term.


Expected results:

Should be prompted to search with the same providers as Firefox for Android: Amazon, Google, Twitter, and Wikipedia.  They are listed in https://mxr.mozilla.org/mozilla-central/source/mobile/locales/en-US/searchplugins/list.txt
(Reporter)

Comment 1

5 years ago
Note that the Amazon provider should be updated from m.amazon.com to www.amazon.com.  This is filed separately as https://bugzilla.mozilla.org/show_bug.cgi?id=891879
(Reporter)

Updated

5 years ago
Blocks: 819110

Comment 2

5 years ago
It's my understanding that search deals are different on Firefox OS than Firefox for Android?

In practice this may be a duplicate of bug 833149 or bug 883002.
Flags: needinfo?(ffos-product)
Keywords: productwanted
The search deals are different. Let me check what we can do here.

Comment 4

5 years ago
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/53546839
Moving NI to Karen who is working with the Browser team.
Flags: needinfo?(ffos-product) → needinfo?(krudnitski)
This bug is sitting in our (Browser) Icebox in Pivotal as we clarify what to show where. ie it's on my list.
Flags: needinfo?(krudnitski)

Comment 7

6 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.