Defect - [8.1] Metro Firefox works very slow compare to desktop Firefox for latest nightly

RESOLVED DUPLICATE of bug 896627

Status

Firefox for Metro
General
P2
normal
RESOLVED DUPLICATE of bug 896627
5 years ago
3 years ago

People

(Reporter: Samvedana, Unassigned)

Tracking

25 Branch
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent : Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:25.0) Gecko/20130715 Firefox/25.0
Build ID: 20130715030202

Tested on Windows 8.1 preview using latest nightly from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-15-03-02-02-mozilla-central/

Metro Firefox works slowly. It is taking long time to open any page. Desktop Firefox works fine for the same build.

Updated

5 years ago
Whiteboard: feature=defect c=tbd u=tbd p=0
(Reporter)

Comment 1

5 years ago
I installed Windows 8.1 again and installed new nightly. It was working fine.

This issue can be reproduced when device is not used long time and nightly is open so when any one start using it. Firefox metro works slowly. Device needs to be restarted.

Updated

5 years ago
Depends on: 896627
Priority: -- → P2
(Reporter)

Updated

5 years ago
No longer depends on: 896627
(Reporter)

Updated

5 years ago
Depends on: 896627
(Reporter)

Comment 2

5 years ago
It looks like restarting the device doesn't affect Metro Firefox performance.

Comment 3

4 years ago
I can confirm this on my 8.1 device but I see similar problems with other apps on 8.1.  We need to understand what's going on here. How can I help if I have an affected machine (up to and including putting the device in the mail and sending to a dev.)

Updated

4 years ago
Blocks: 898795

Updated

4 years ago
Whiteboard: feature=defect c=tbd u=tbd p=0 → feature=defect c=Other_charms_and_integration u=metro_firefox_user p=0 [8.1]

Comment 4

4 years ago
8.1 is a preview release, we might want to wait until we have an rc candidate. Some other bugs related to 8.1 (see bug 890829) are already seeing fixes in newer builds.
Whiteboard: feature=defect c=Other_charms_and_integration u=metro_firefox_user p=0 [8.1] → feature=defect c=Other_charms_and_integration u=metro_firefox_user p=0 [8.1][preview-triage]
I looked into this and the reason may be because we're getting blocked d2d whether or not OMTC is enabled.  So we're relying on GDI for OMTC and I think that's causing slowdowns and other issues. I'm going to track / fix those in different bugs in case it's not related to this bug, but if that ends up being it, then we can mark this as resolved/wfm eventually.
Depends on: 901071
Depends on: 901025, 901002
No longer depends on: 901002, 901025, 901071
No longer depends on: 896627
Seems like the same thing to me, undupe if I'm wrong.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 896627
No longer blocks: 859003, 898795
Whiteboard: feature=defect c=Other_charms_and_integration u=metro_firefox_user p=0 [8.1][preview-triage]
(Assignee)

Updated

3 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.