Closed Bug 895208 Opened 8 years ago Closed 6 years ago

Use tooltool for spidermonkey builds

Categories

(Infrastructure & Operations Graveyard :: CIDuty, task)

All
macOS
task
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1146520

People

(Reporter: glandium, Assigned: sfink)

References

(Blocks 1 open bug)

Details

OSX spidermonkey builds are currently failing with a crash in clang after the backout of bug 883381. Before that, the debug builds were failing during compilation with some weird error. There is really no reason why this should fail when everything builds just fine when building Firefox, and the main difference is that spidermonkey builds are using plain xcode clang, as opposed to Firefox builds using mozilla-built clang downloaded with tooltool.

Thus, spidermonkey builds should use tooltool.
Blocks: 862657
Product: mozilla.org → Release Engineering
Found in triage.
Component: Other → Platform Support
Depends on: 898970
Done, a while back. I'm marking it as a dupe of a bug that expanded the tooltool usage, even though it's not the original. Close enough.
Status: NEW → RESOLVED
Closed: 6 years ago
QA Contact: coop
Resolution: --- → DUPLICATE
Duplicate of bug: 1146520
Component: Platform Support → Buildduty
Product: Release Engineering → Infrastructure & Operations
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.